Problema montaggio partizione NTFS

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1103

ferretti75 ha scritto:

Citazione:


/dev/sda2	/media/sda2	ntfs-3g	noauto,users,exec,umask=000	0	0

potrebbe essere user e non users come hai scritto ??

a quanto ne so'/ricordo l'opzione users non esiste ...

Ho cambiato l'ultima riga dell'fstab nel modo seguente

UUID=348ACC718ACC3162   /media/sda2     ntfs-3g noauto,[b]user[/b],exec,umask=000      0       0

L'attuale messaggio di errore è il seguente:

Si è verificato un errore durante l''accesso a <<Disco fisso da 127, GiB>>, il sistema ha riferito:
org.freedesktop.Hal.Device.Volume.PermissionDenied: Device /dev/sda2 is listed in /etc/fstab. Refusing to mount.

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di ferretti75
ferretti75
(Guru)
Offline
Guru
Iscritto: 08/07/2005
Messaggi: 526

Scusa la domanda banale ma non riesco a capire ; il tuo fstab e'

UUID=348ACC718ACC3162   /media/sda2     ntfs-3g noauto,[b]user[/b],exec,umask=000      0       0

oppure

UUID=348ACC718ACC3162   /media/sda2     ntfs-3g noauto,user,exec,umask=000      0       0

nota : l'utente e' user, non [ b ]user[ /b ] . Scusa ma non si capisce ...

apt-get -a beer

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1103

Hai ragione. In realtà l'errore è del forum, non dell'fstab. Volevo evidenziare che avevo cambiato users in user evidenziando user in grassetto (i cui codici, appunto, sono ), ma è uscita quella schifezza.
Per cui, l'ultima riga del mio fstab è la seguente

UUID=348ACC718ACC3162   /media/sda2     ntfs-3g noauto,user,exec,umask=000      0       0

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di paolo
paolo
(Webmaster)
Offline
Webmaster
Iscritto: 04/10/2004
Messaggi: 1277

Claudio ha scritto:

Hai ragione. In realtà l'errore è del forum, non dell'fstab. Volevo evidenziare che avevo cambiato users in user evidenziando user in grassetto (i cui codici, appunto, sono ), ma è uscita quella schifezza.
Per cui, l'ultima riga del mio fstab è la seguente

UUID=348ACC718ACC3162   /media/sda2     ntfs-3g noauto,user,exec,umask=000      0       0

Il fatto è che non si possono usare tag bbcode all'interno del tag code, questo perchè vengono intepretati e modificafo dal geshifilter, inoltre non avrebbe senso parsarli ancora, si presume che tutto quello che è dentro al tag bbcode deve essere stampato cosi come è scritto.

Paolo Mainardi
CTO Twinbit http://www.twinbit.it
Vice Presidente -- ILDN - Italian Linux DIstro Network

Ritratto di sette70
sette70
(Geek)
Offline
Geek
Iscritto: 14/01/2005
Messaggi: 116

Credo che servano entrambe le opzioni user,users.
Vi segnalo due link:
http://en.opensuse.org/SDB:NTFS

http://en.gentoo-wiki.com/wiki/NTFS-3G

Ho visto anche una guida su "debianizzati.org" che ha una approcio diverso
modificare una policy per hal:

http://guide.debianizzati.org/index.php/Montare_in_automatico_drive_USB_NTFS_con_Hal_e_Ntfs-3g

Ritratto di ferretti75
ferretti75
(Guru)
Offline
Guru
Iscritto: 08/07/2005
Messaggi: 526

Ho visto passare qualcosa anche in forums.debian.net ( si e' attivato il neurone in ritardo ma si e' attivato ) ... quindi googlando l'errore e' uscito il post incriminato (fyi) .

Fondamentalmente ( non chiedetemi perche' ) pare che il problema sia HAL che non "riesce" a trattare i dischi locali come ntfs quindi gli fanno credere che il disco sia rimuovibile. L'approccio e' lo stesso di debianizzati ( mi sorge il sospetto che le fonti siano le stesse ) .

Se non ti interessa tutta la discussione, salta direttamente al penultimo mesaggio e fai gli opportuni cambiamenti per il matching del disco.

facci sapere !!

apt-get -a beer

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1103

Niente di nuovo anche dopo aver seguito la guida di debianizzati Confused Crying

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di ferretti75
ferretti75
(Guru)
Offline
Guru
Iscritto: 08/07/2005
Messaggi: 526

Claudio ha scritto:

Niente di nuovo anche dopo aver seguito la guida di debianizzati Confused Crying


Scusa l'infinita serie di domande idiote . Mi pareva di aver capito che tu hai un disco interno ( non esterno ) e la guida di debianizzati serve per fare il mount in automatico di un disco usb ( quindi esterno ) formattato ntfs...

Controlla (se non l'hai gia' fatto ) i post che ti ho segnalato : vedrai che l'approccio e' un attimo diverso anche perche' tu avevi detto che non volevi il mount automatico del disco ...

apt-get -a beer

Ritratto di marcolnx
marcolnx
(Junior)
Offline
Junior
Iscritto: 14/01/2011
Messaggi: 8

Salve a tutti (primo messaggio),
hai provato a fare il mount della partizione da root?
Io utilizzo una vecchia distro sidux appena reinstallata a causa cambio disco fisso nel mio portatile (praticamente una stable) e ho notato che come utente (marco) sono presente nel gruppo "fuse".
Eventualmente puoi anche provare ad editare il tuo fstab (fai un backup prima) inserendo semplicemente "defaults" nelle opzioni e poi prova a riavviare. Se funziona e non vuoi venga montato in automatico aggiungi "noauto" o altre restrizioni.

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1103

Ragà, oggi ho provato a mettere l'opzione defaults al posto di
noauto,user,exec,umask=000
e il montaggio va senza problemi.

Ho anche risostituito /dev/sda2 al posto di UUID=348ACC718ACC3162 e ho persino cancellato le modifiche che avevo fatto dalla guida di debianizzati sul montaggio in automatico dei drive in usb con ntfs.
Sembra, però, che il problema derivi dall'opzione noauto in quanto ho provato a metterlo dopo l'opzione defaults e al successivo riavvio il montaggio non va.

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde