Problema luminosità su debian 8 con XFCE

5 risposte [Ultimo contenuto]
Ritratto di lucaloby
lucaloby
(Newbie)
Offline
Newbie
Iscritto: 17/12/2015
Messaggi: 4

Salve a tutti... vi scrivo per disperazione... ora vi spiego...
Ho da poco installato Debian su mio portatile Lenovo flex-14D con XFCE. Il problema è che non c'è alcun modo per poter regolare il valore della luminosità. In pratica quando premo i pulsanti "fn" relativi alla regolazione sullo schermo compare una barra di regolazione ma la luminosità effettiva non cambia...stesso risultato l'ho avuto con la regolazione attraverso il "gestore di energia"...allora ho consultato il web e ho trovato diverse "soluzioni" al problema...tra cui quello di cambiare il valore GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor acpi_osi=Linux" in /etc/default/grub e poi dare sudo update-grub e riavviare...ma non ho ottenuto nessun risultato...così come ho provato a installare driver proprietari AMD tramite il comando sudo apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver fglrx-modules-dkms ... dopo centinaia di tentativi diversi che non sto ad elencare tutti (ma credetemi ho provato ogni guida/soluzione possibile) ho notato che la mia cartella /sys/class/backlight/ contiene esclusivamente una cartella chiamata ideapad con all'interno file come brightness (che, modificandone il valore interno, non dà risultati), e nessuna cartella di tipo acpi_video0... non so più cosa provare ... vi prometto ogni cosa in cambio di una soluzione Crying

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Purtroppo la regolazione della retroilluminazione è una delle poche cose che in Linux non funzionano tanto bene. Ogni produttore la fa in modo diverso, poi scrive un driver ad hoc solo per Windows e si dimentica che esistono altri SO. Sad

Se ti può essere d'aiuto, vedi come l'ho risolto io (con le dovute differenze: la mia scheda video è Intel, non AMD).

Vedi anche questa discussione di un caso simile al tuo. L'utente ha risolto il problema, ma non ci ha detto se grazie ai consigli del forum...

Ritratto di lucaloby
lucaloby
(Newbie)
Offline
Newbie
Iscritto: 17/12/2015
Messaggi: 4

Per quanto riguarda la tua soluzione...l'ho gia provata ma purtroppo in quella cartella non esiste qualcosa come 20-backlight...e se provo ad aggiungerla al riavvio non mi parte più la GUI fin quando non cancello il file... Per quanto riguarda la seconda è già stata provata e niente... In ogni caso a me non serve necessariamente poter modificare la luminosità dai tasti "fn" mi basta poterla modificare in qualche modo... Pra come ora è davvero troppo forte...
Grazie comunque...spero si riesca a trovare una soluzione...

Ritratto di lucaloby
lucaloby
(Newbie)
Offline
Newbie
Iscritto: 17/12/2015
Messaggi: 4

Quindi nessuna risposta? A quanto pare non esiste una soluzione reale al problema...ho risolto cambiando distro sul portatile con xubuntu (dove il problema non persiste) poiché con quel problema mi era impossibile vivere visto che, essendo un programmatore, sono costretto a diverse ore davanti al computer...terrò Debian solo sul fisso dove mi sto trovando benissimo. Grazie lo stesso.

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1124

Io ho un portatile con scheda ATI Radeon e non ho problemi col backlight, mi funziona out-of-the box e quindi non saprei dirti cosa controllare perché non ho fatto assolutamente nulla per farla funzionare.

Nella directory /sys/class/backlight ho i seguenti device:

0 lrwxrwxrwx  1 root root 0 Dec 27 23:08 acpi_video0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0
0 lrwxrwxrwx  1 root root 0 Dec 27 23:08 radeon_bl0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card0/card0-LVDS-1

Uso i driver open non quelli proprietari ed ho il modulo "radeon" caricato.

Puoi provare il pacchetto radeontool ma non l'ho mai usato e non saprei dirti se è quello adatto al tuo caso.

Debian. Be unique.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Sarebbe interessante sapere qual è la configurazione di xubuntu che funziona. Ad esempio la versione del kernel, del driver (open o proprietario), eventuali stringhe acpi_osi passate al BIOS, ecc.