Problema: login gdm con tastiera americana

1 risposta [Ultimo contenuto]
Ritratto di Jun_Shindo
Jun_Shindo
(Newbie)
Offline
Newbie
Iscritto: 10/01/2009
Messaggi: 4

Salve a tutti
ho installato da poco debian 5.0.2 via netinstall, tutto regolare, al riavvio noto che non riesco a fare login... dopo un po di tentativi capisco che la tastiera è settata come americana, nella password uso la chiocciolina e per inserirla ora devo fare shift+2...
ok, mi loggo, setto la tastiera italiana per il mio utente, riavvio, ma il login gdm rimane con la tastiera sbagliata... Naturale penso, durante il login non viene ancora letta la configurazione della tastiera di un utente non ancora loggato....
Ho abilitato il login grafico a root, per fargli settare la tastiera ita anche li, ma nada...
Ho provato a dare il comando install-keymap e tastiera ita, ma nada, comando va ma al riavvio il login è in americano....
Ho provato a vedere i settaggi sul file /etc/X11/xorg.conf, ma il file è vuoto, mi par di aver capito che X ora si riconfigura tutto al volo (mannaggia, finalmente avevo capito dove mettere le mani quando non andava qualcosa in xserver, ora me lo togliete? Laughing)...
Non sono riuscito a trovare altre info, se non qualche bug d'annata...
Mi sapete dire che files potrei controllare? o magari qualche test da effettuare per vedere se l'errore è su gdm o da qualche altra parte?
Ah, in aggiunta... è normale che, a volte, passando alla console 1 con ctrl+alt+f1, lo schermo sbianchi lentamente ed a righe, lasciando intravedere ancora il desktop/finestre dove mi trovavo? come se il monitor non ricevesse più segnale, e i cristalli un po alla volta, si portino sul bianco... il monitor non è rotto, anche se sintomi simili li ho notati su monitor danneggiati...
Ripetendo ctrl+alt+f7, ctrl+alt+f1 poi torna tutto regolare... idee?
Grazie!

Ritratto di dariospy
dariospy
(Junior)
Offline
Junior
Iscritto: 18/05/2007
Messaggi: 31

Ciao, puoi modificare la disposizione della tastiera di X mediante il comando

dpkg-reconfigure xserver-xorg

la disposizione viene rilevata automaticamente, puoi comunque cambiarla se non ti aggrada.

Per quanto riguarda il monitor potrebbe essere un problema di configurazione di X.
Avevo problemi simili al tuo su un dell 1501, avevo installato i driver proprietari ATI (tanto per provare), non so se è il tuo caso.

Fammi sapere, ciao

condividi le tue conoscenze www.mytwocent.it
linux-user # 449678