problema con init

4 risposte [Ultimo contenuto]
Ritratto di Noise
Noise
(Geek)
Offline
Geek
Iscritto: 02/02/2005
Messaggi: 107

ciao a tutti, mi capita da qualche giorno, da quando ho aggiornato con apt-get che quando spengo il portatile mi viene riportato:

INIT: no more processes left in this runlevel

e dopo quel messaggio il sistema rimane lì fermo e non si spegne (devo spegnerlo grezzamente dal pulsante), cosa può essere il prob? ho provato a riconfigurare i pacchetti sysvinit initscripts ma niente, il prob è ancora lì.

A sopravvivere non è la specie piu' forte, neanche quella più intelligente ma quella che si sa adattare meglio ai cambiamenti.... LINUX è evoluzione.

Ritratto di paolo
paolo
(Webmaster)
Offline
Webmaster
Iscritto: 04/10/2004
Messaggi: 1277

MMh...hai pensato ad un problema di ACPI/APM ? Magari con l'aggiornamento del Kernel qualcosa è andato storto.

Per toglierti il dubbio prova a lanciare un:

<br />halt<br />

Se si spegne normalmente, escludiamo subito questa ipotesi.

Aggiornamento:

Oppure prova:

<br />apt-get install --reinstall sysvinit <br />

CIao.

Paolo Mainardi
CTO Twinbit http://www.twinbit.it
Vice Presidente -- ILDN - Italian Linux DIstro Network

Ritratto di madbrains
madbrains
(Monster)
Offline
Monster
Iscritto: 16/01/2005
Messaggi: 330

Oppure prova a dare un occhiata a cosa parte con i diversi runlevel utilizzando: sysv-rc-conf su questo stesso forum trovi informazioni su questo tool lo consiglio ad un sacco di gente

Ritratto di lnessuno
lnessuno
(Junior)
Offline
Junior
Iscritto: 07/09/2004
Messaggi: 26

stesso problema con debian sid... proobabilmente è sysvinit danneggiato, boh!

hai per caso provato initng? perchè a me è capitato più o meno nel periodo in cui ho scoperto initng e l'ho provato...

Ritratto di Noise
Noise
(Geek)
Offline
Geek
Iscritto: 02/02/2005
Messaggi: 107

Quote:

lnessuno ha scritto:
stesso problema con debian sid... proobabilmente è sysvinit danneggiato, boh!

hai per caso provato initng? perchè a me è capitato più o meno nel periodo in cui ho scoperto initng e l'ho provato...

si esatto, ho provato initng e mi sa proprio che il problema è dovuto da initng, molto probabilmente va a modificare qualcosa che non dovrebbe. il problema l'ho risolto, come consiglio di paolo ho dato apt-get install --reinstall sysvinit et voilà.

A sopravvivere non è la specie piu' forte, neanche quella più intelligente ma quella che si sa adattare meglio ai cambiamenti.... LINUX è evoluzione.