Problema aggiornamento Debian Sid

4 risposte [Ultimo contenuto]
Ritratto di JoErNanO
JoErNanO
(Geek)
Offline
Geek
Iscritto: 16/03/2006
Messaggi: 78

Da una settimana a questa parte provo ad aggiornare la mia debian sid e ottengo il seguente errore:

DeBiAn-BoX:/home/joe# apt-get dist-upgrade<br />Lettura della lista dei pacchetti in corso... Fatto<br />Generazione dell&#039;albero delle dipendenze in corso... Fatto<br />È consigliabile eseguire `apt-get -f install&#039; per correggere questi problemi.<br />I seguenti pacchetti hanno dipendenze non soddisfatte:<br />  flashplayer-mozilla: Dipende: libc6-i386 (&gt;= 2.6-1) ma 2.5-11 è installato<br />  lib32stdc++6: Dipende: gcc-4.2-base (= 4.2.1-5) ma 4.2-20070627-1 è installato<br />  libc6-dev-i386: Dipende: libc6-i386 (= 2.6.1-2) ma 2.5-11 è installato<br />  libc6-i386: Dipende: libc6 (= 2.5-11) ma 2.6.1-2 è installato<br />E: Dipendenze non trovate. Riprovare usando -f.<br />

A questo punto provo con il buon vecchio
apt-get -f install
e ottengo:

(Lettura del database ... 187515 file e directory attualmente installati.)<br />Mi preparo a sostituire libc6-i386 2.5-11 (con .../libc6-i386_2.6.1-2_amd64.deb) ...<br />Spacchetto il sostituto di libc6-i386 ...<br />dpkg: errore processando /var/cache/apt/archives/libc6-i386_2.6.1-2_amd64.deb (--unpack):<br /> tentata sovrascrittura di `/usr/lib32&#039;, che si trova anche nel pacchetto lib32z1<br />Sono occorsi degli errori processando:<br /> /var/cache/apt/archives/libc6-i386_2.6.1-2_amd64.deb<br />E: Sub-process /usr/bin/dpkg returned an error code (1)<br />

Sto uscendo pazzo. Pensavo di aspettare che gli sviluppatori debian aggiornassero i pacchetti in questione ma è passato fin troppo tempo.

Secondo voi cosa dovrei fare?? Thinking

—¤÷(`[¤*°o.O -NoN DiStUrBaRe Il NaNo ChE DoRmE- O.o°*¤]´)÷¤—
«una strana creatura dai poteri informatici illimitati, un nano cybernetico...»
Linux Registered User #380227
Amd 64 x2 4800+ // Debian Sid
Topolinux Freelance

Ritratto di gabry
gabry
(Monster)
Offline
Monster
Iscritto: 29/10/2006
Messaggi: 395

regola: cercare su google prima di postare Wink
provato questo?
http://www.mail-archive.com/debian-glibc@lists.debian.org/msg35237.html

ciao ciao

"Non e' la legge che decide cosa e' giusto e cosa e' sbagliato"
R. Stallman

Ritratto di sette70
sette70
(Geek)
Offline
Geek
Iscritto: 14/01/2005
Messaggi: 116

ciao,a quanto pare dpkg ti si pianta sull pacchetto ibc6-i386_2.6.1-2_amd64.deb prechè tenta di sovraschivere
altri file presenti nel sistema.Un modo poco pulito per risolvere il problema e di forzare dpkg a sovrashivere.
Vai in /var/cache/apt/archives e dai : dpkg -i --force-all ibc6-i386_2.6.1-2_amd64.deb.Ripeto non molto elegante come metodo ma spesso funziona.

Ritratto di Stemby
Stemby
(Guru)
Offline
Guru
Iscritto: 05/10/2006
Messaggi: 776

Magari prima prova con aptitude, che in generale gestisce meglio le dipendenze:
<br /># aptitude update<br /># aptitude upgrade<br />
eventualmente poi
<br /># aptitude dist-upgrade<br />

Registered Linux User #443882
Registered Debian User #9

Ritratto di JoErNanO
JoErNanO
(Geek)
Offline
Geek
Iscritto: 16/03/2006
Messaggi: 78

Quote:

gabry ha scritto:
regola: cercare su google prima di postare Wink
provato questo?

Yeah.
Quote:

Worked around by removing lib32z1 first, then reinstalling it.

Già fatto:

DeBiAn-BoX:/home/joe# apt-get remove lib32z1<br />Lettura della lista dei pacchetti in corso... Fatto<br />Generazione dell&#039;albero delle dipendenze in corso... Fatto<br />È consigliabile eseguire &#039;apt-get -f install&#039; per correggere questi problemi:<br />I seguenti pacchetti hanno dipendenze non soddisfatte:<br />  flashplayer-mozilla: Dipende: libc6-i386 (&gt;= 2.6-1) ma 2.5-11 sta per essere installato<br />  ia32-libs: Dipende: lib32z1 ma non sta per essere installato<br />  lib32stdc++6: Dipende: gcc-4.2-base (= 4.2.1-5) ma 4.2-20070627-1 sta per essere installato<br />  lib32z1-dev: Dipende: lib32z1 (= 1:1.2.3.3.dfsg-3) ma non sta per essere installato<br />  libc6-dev-i386: Dipende: libc6-i386 (= 2.6.1-2) ma 2.5-11 sta per essere installato<br />  libc6-i386: Dipende: libc6 (= 2.5-11) ma 2.6.1-2 sta per essere installato<br />E: Dipendenze non soddisfatte. Provare &#039;apt-get -f install&#039; senza pacchetti (o specificare una soluzione).<br />
Hai presente il cane che si morde la coda??
Wink

Ora provo con aptitude.
@Stemby: Però ti devo chiedere perchè gestisce meglio le dipendenze. :-P

Grazie a tutti.

—¤÷(`[¤*°o.O -NoN DiStUrBaRe Il NaNo ChE DoRmE- O.o°*¤]´)÷¤—
«una strana creatura dai poteri informatici illimitati, un nano cybernetico...»
Linux Registered User #380227
Amd 64 x2 4800+ // Debian Sid
Topolinux Freelance