ibernazione non funziona sospensione funziona

6 risposte [Ultimo contenuto]
Ritratto di antpanlinux
antpanlinux
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 7

Salve a tutti
avrei un problema che non riesco a risolvere. Il pc (debian 9 stable ) mi effettua la sospensione ma non l'ibernazione.
Ho cercato nel forum e cambiato parametri a grub ma non ho risolto nulla. La partizione di swap è di 8GB (do come informazione).
Preciso che il tutto è iniziato dopo che ho trasferito l'immagine di debian da un hard disk di 120GB ad uno di 250.
Ho sempre usato, per l'ibernazione il file che allego e per la sospensione un altro file (che è una semplice rivisitazione) trovato su internet tempo fa e funzionano benissimo. Adesso funziona solo la sospensione.
In pratica il pc inizia il procedimento di ibernazione e si risveglia subito. Ripeto la sospensione, invece, funziona.
Qualcuno può aiutarmi?
Grazie
PS ho rinominato il file .doc è, ovviamente, .

AllegatoDimensione
ibernasinoalle.doc2.1 KB

debian main no contrib no non-free

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1382

Puoi riportare in chiaro nel messaggio il testo dello script (piuttosto che come allegato)?

Puoi riportare l’output dei comandi di seguito impartiti come utente root (troverai tutto nel file log.txt):

script log.txt
systemctl hibernate
journalctl -n 100 --no-pager
exit

Infine, per cortesia, correggi il titolo della discussione perché, se non erro, è incoerente con la stessa (forse era lungo ed è stato troncato senza che te accorgessi)

Ritratto di antpanlinux
antpanlinux
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 7

questo è lo script come richiesto

#!/bin/bash

# Auto suspend and wake-up script
#
# Puts the computer on standby and automatically wakes it up at specified time
#
# Written by Romke van der Meulen
#
# Takes a 24hour time HH:MM as its argument
# Example:
# suspend_until 9:30
# suspend_until 18:45
# suspend_until 0325
# suspend_until 515

# (just drag the scriptfile into terminal window and add time to the line)

# ------------------------------------------------------
# Argument check
if [ $# -lt 1 ]; then
echo "Usage: suspend_until HH:MM"
fi

# Check whether specified time today or tomorrow
DESIRED=$((`date +%s -d "$1"`))
NOW=$((`date +%s`))
if [ $DESIRED -lt $NOW ]; then
DESIRED=$((`date +%s -d "$1"` + 24*60*60))
fi

# Define hours/mins/sec to wake-up (for printing purposes only):
hours=$(((DESIRED-NOW)/3600))
minutes=$(( ((DESIRED-NOW)-(hours*3600))/60 ))
seconds=$(( ((DESIRED-NOW)-((hours*3600)+(minutes*60))) ))

# Kill rtcwake if already running #blocco sotto
sudo killall rtcwake

# Let user know what we're going to do
echo "Going to suspend for $hours h $minutes min"

echo "To cancel, press Ctrl+c within the next 10 seconds."
sleep 10

# Set RTC wakeup time #blocco sotto
sudo rtcwake -l -m on -t $DESIRED &

# feedback
echo "Suspending..."

# give rtcwake some time to make its stuff
sleep 2

# then suspend #blocco sotto
sudo pm-hibernate

# -------------------------------------------------------------------------------------
# Any commands you want to launch after wakeup can be placed here
# Remember: sudo may have expired by now

# Wake up with monitor disabled
# xset dpms force off

# Set volume level and (just in case) unmute system
# amixer -c 0 set Master 80% unmute
# amixer -c 0 set PCM 70% unmute

# echo "Good morning"

# Open VLC (vlc + path to your audio/video file)
# vlc '/home/USER/Music/audiofile.mp3'

# Unload rtcwake if it's running, otherwise next time computer won't wake up from sleep
SERVICE='rtcwake'
if ps ax | grep -v grep | grep $SERVICE > /dev/null
then
echo "$SERVICE running, killing process..."
sudo killall rtcwake
else
echo "$SERVICE is not running, no action taken."
fi

debian main no contrib no non-free

Ritratto di antpanlinux
antpanlinux
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 7

è questo è il file log.txt (grazie per aiuto)

Script started on dom 05 ago 2018 11:41:03 CEST
root@debant:/home/antonio# systemctl hibernate
Failed to hibernate system via logind: Sleep verb not supported
root@debant:/home/antonio# journalctl -n 100 --no-pager
-- Logs begin at Sun 2018-08-05 11:27:58 CEST, end at Sun 2018-08-05 11:41:32 CEST. --
ago 05 11:38:26 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:28 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:30 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:32 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:34 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:36 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:38 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:40 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:42 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:44 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:46 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:48 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:50 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:52 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:54 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:56 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:38:58 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:39:00 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:39:02 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:39:04 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:39:06 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:39:08 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:39:10 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:39:12 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:39:14 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita
ago 05 11:39:16 debant gpg-agent[1520]: can't connect to the SCdaemon: Chiamata "connect" IPC non riuscita

debian main no contrib no non-free

Ritratto di antpanlinux
antpanlinux
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 7

preciso anche, ad ogni buon fine, che ho un altro hard disk con windows 10 ma ho disabilitato il fast boot di windows e faccio spegnere regolarmente windows quelle rare volte che mi serve usarlo.
ciao

debian main no contrib no non-free

Ritratto di antpanlinux
antpanlinux
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 7

Risolto grazie al tuo aiuto.
Era la partizione di swap non attiva. Adesso provvedo ad attivarla.
Grazie

debian main no contrib no non-free

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1382

Felice di esserti stato d’aiuto