Errore montaggio disco USB NTFS

10 risposte [Ultimo contenuto]
Ritratto di arwen
arwen
(Geek)
Offline
Geek
Iscritto: 13/06/2005
Messaggi: 91

Salve a tutti.

Ho installato Debian Testing e per il momento funziona tutto tranne che non riesco a montare il mio disco esterno NTFS.

L'errore che ottengo è quello sotto :

Impossibile montare «PACKARDBELL»
 
Error mounting: mount exited with exit code 1: helper failed with:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://ntfs-3g.org/support.html#unprivileged

Fuse è in esecuzione infatti :

root@debian:/home/francesco# lsmod | grep fuse
fuse                   55666  1 

I gruppi a cui il mio utente è iscritto sono :

francesco@debian:~$ groups
francesco disk cdrom floppy tape audio dip video plugdev users netdev bluetooth lpadmin fuse scanner powerdev

E ntfs-3g è installato .

Ho letto un pò in giro ma sinceramente non ho capito cosa devo fare per fare in modo che il disco venga montato in automatico (su ubuntu veniva montato in automatico).

Mi date una scaletta di verifiche da fare o qualche link ad una guida in modo che il disco venga montato in automatico in lettura e scrittura ?

Grazie mille

===================================
http://www.flussiliberi.it/
===================================

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Sembra che la pagina da guardare sia questa: http://www.tuxera.com/community/ntfs-3g-faq/#unprivileged

Prima di tutto pero` prova a spiegarci meglio in che modo stai cercando di montare il disco esterno. Mount automatico, da terminale, in qualce ambiente?

Ciao,
Marco

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di arwen
arwen
(Geek)
Offline
Geek
Iscritto: 13/06/2005
Messaggi: 91

Citazione:

Prima di tutto pero` prova a spiegarci meglio in che modo stai cercando di montare il disco esterno. Mount automatico, da terminale, in qualce ambiente?

Utilizzo GNOME e l'unica cosa che ho fatto è stato iscrivere il mio utente ai gruppi Disk e fuse .
Vorrei che il disco venisse montato in automatico come succede con le chiavette USB che però sono FAT32.
Probabilmente se il disco fosse Fat32 funzionerebbe ma il disco è pieno di dati e non posso formattarlo.

Attualmente sto facendo dei test sul portatile perchè vorrei togliere UBUNTU anche dal fisso (dal computer su cui ho bisogno di accedere a questo disco removibile) perchè Debian testing mi è piaciuta molto ( pulita , con molto software aggiornatissimo , veloce , e 'rolling' come archlinux ma senza farti impazzire per installarla) .

Spero di riuscire ad accedere al disco NTFS perchè è basilare per poter passare a Debian anche sul mio secondo PC .

Grazie a tutti

===================================
http://www.flussiliberi.it/
===================================

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Saro` duro a capire, ma COME stai tentando di montarlo? A caldo, durante l'avvio? Quando ricevi il messggio di errore? Purtroppo non abbiamo la sfera di cristallo Wink

Ciao,
Marco

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di arwen
arwen
(Geek)
Offline
Geek
Iscritto: 13/06/2005
Messaggi: 91

Citazione:

Saro` duro a capire, ma COME stai tentando di montarlo? A caldo, durante l'avvio? Quando ricevi il messggio di errore? Purtroppo non abbiamo la sfera di cristallo Wink


Dopo aver fatto Login e caricato il desktop di Gnome inserisco il cavo USB .
Il sistema si accorge della presenza del disco e credo provi a montarlo ma non riesce , a quel punto si apre una finestra con il messaggio che ho incollato nel primo post.
In pratica sembra che gli automatismi di mount automatico funzionino ma il sistema non riesce a montare il disco e mi segnala l'errore.
Il disco mi appare anche nel menù Risorse ma anche da qui se ci 'clicco' sopra mi segnala lo stesso errore.

Premetto che non ho toccato fstab

===================================
http://www.flussiliberi.it/
===================================

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Non so se l'eseguibile ntfs-3g distribuito da Debian sia compilato con il supporto FUSE. A proposito, sapresti dirci quali permessi ha l'eseguibile?

Ritratto di arwen
arwen
(Geek)
Offline
Geek
Iscritto: 13/06/2005
Messaggi: 91

Citazione:

A proposito, sapresti dirci quali permessi ha l'eseguibile?

In un terminale di root ho provato anche questo ma senza risultato :

chown root $(which ntfs-3g)

Quindi ntfs-3g dovrebbe girare come se lo avesse lanciato root , ora però non ho sotto mano il portatile quasta sera guardo e vi dico.

Oggi ho riprovaro a collegare il drive in questione sulla macchina UBUNTU e viene montato correttamente quindi il file system non ha problemi.

Sicuramente il problema è causato da una stupidaggine perchè se lo monta UBU lo deve anche montare Debian.

Ho anche accarezzato l'idea di installare ntfs-config che dovrebbe creare in modo grafico una linea in fstab ma non sò se risolva o meno.

===================================
http://www.flussiliberi.it/
===================================

Ritratto di arwen
arwen
(Geek)
Offline
Geek
Iscritto: 13/06/2005
Messaggi: 91

Forse ho trovato infatti per installare ho utilizzato una chiavetta USB per i driver WiFi e
questa sera proverò come dice qui :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=609201

Vedremo

===================================
http://www.flussiliberi.it/
===================================

Ritratto di arwen
arwen
(Geek)
Offline
Geek
Iscritto: 13/06/2005
Messaggi: 91

Risolto !!

Questo era il mio vecchio fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda1 during installation
UUID=ed1d5e0e-115f-4fe6-9e82-4d09d969c9c3 /               ext3    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=da53c8e1-573a-481b-8054-ab93263e99e1 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0

E come potete vefere c'è la fatidica riga inerente la usb.
Per risolvere ho semplicemente commentato la riga e ora il mio disco esterno USB NTFS viene montato in automatico senza problemi (non ho ancora provato a scriverci ora che faccio mente locale).

In pratica quando ho installato la macchina avevo una chiavetta USB inserita con su i firmware per la mia scheda WiFi, probabilmente l'istaller mi ha detto di rimuoverla prima di riavviare ma mi è sfuggito così l'installer ha creato una riga in fstab per montare già al boot il disco.
Per quanto sopra non può quindi essere considerato un'errore ma probabilmente solo una mia svista in fase di installazione.

Ora non mi resta che installare Debian Testing anche sul fisso e poi sarò completamente Debianizzato Big Grin

===================================
http://www.flussiliberi.it/
===================================

Ritratto di DarkSimon
DarkSimon
(Newbie)
Offline
Newbie
Iscritto: 20/05/2012
Messaggi: 1

Ho avuto lo stesso medesimo problema anche io ho risolto come diveva arwen. Grazie mille Big Grin

Ritratto di maurrox
maurrox
(Newbie)
Offline
Newbie
Iscritto: 24/04/2015
Messaggi: 1

Anch'io avevo questo problema nel tentativo di montare un vecchio disco esterno con interfaccia USB.
Commentando la riga di /etc/fstab

/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0

... tutto si è risolto.
grazie Big Hug