E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

3 risposte [Ultimo contenuto]
Ritratto di andrea0
andrea0
(Geek)
Offline
Geek
Iscritto: 17/07/2017
Messaggi: 64

Salve amici, sto provando ad installare closure-linter ma ottengo questi errori:

root@nirvana:/home/andrea/lavoro/angular/CarsMarketPlace/node_modules# apt-get install closure-linter
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 closure-linter : Dipende: python-gflags ma non è installabile
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

come risolvere? ho provato a dare
apt-get --fix-broken install
ma non è successo niente e continuo ad avere il problema.
Debian unstable
Grazie

Devi cercare di trovare il lato positivo in ogni situazione. cit Dalai Lama

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Ciao,
come ti dice apt il problema è che manca una dipendenza in sid o unstable che dir si voglia.

Ora non voglio sapere perché stai usando sid e mi pare anche inutile ribadire che in sid non c'è nessuna garanzia per quanto riguarda l'integrità dei pacchetti a livello di dipendenze e non andrebbe mai usata se non al fine di contribuire alla segnalazione o correzione di bug.

Soluzioni ? Aspetti che venga reso disponibile .... forse non ci vorrà molto ( rif ) oppure scarichi il pacchetto e lo installi manualmente sperando che non vada a sua volta in conflitto con altro.

Ritratto di gio14
gio14
(Geek)
Offline
Geek
Iscritto: 05/03/2009
Messaggi: 58

Per riuscire ha sbloccare apt devi rimuovere closure-linter (in attesa di tempi migliori)
in modalità grafica apri "gestore pacchetti" in alto a sinistra dovresti trovare un menù
con "pacchetti danneggiati (o qualcosa di simile) ci clicchi sopra ti darà il
pacchetto danneggiato da rimuovere

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 397

Non so se può essere utile...

Citazione:

Note: Closure Linter is deprecated, and is rarely used anymore within Google. See this page for more information