Debian, blocco improvviso senza possibilità di recupero

13 risposte [Ultimo contenuto]
Ritratto di davide_maggi
davide_maggi
(Junior)
Offline
Junior
Iscritto: 19/08/2014
Messaggi: 10

Buongiorno,

ho installato l'ultima release Stable di Debian (7 Wheezy).
Tutto bene, tutto fluido senonchè all'improvviso senza un'apparente motivazione il PC si blocca in maniera impietosa senza nessuna possiblità di intervento. Tastiera inattiva, mouse e touchpad completamente bloccati e led dell'hd spento.
So che la domanda così posta potrebbe ricevere una risposta del genere: "beh non ci hai detto molto"... però onestamente non spo proprio cos'altro andare a raccontarvi perchè l'arresto avviene in qualsiasi situazione sia con basso che con alto carico di lavoro e sia poco dopo l'avvio che dopo un paio di ore di lavoro...

A qualcuno già succede una cosa del genere?

Grazie

Davide

Ritratto di Pipperss
Pipperss
(Junior)
Offline
Junior
Iscritto: 15/08/2014
Messaggi: 25

Ciao Davide,
potrebbe essere un problema hw tipo alimentatore e non di sw, hai la possibilità di testarne uno ?

Saluti,
pippersss

Ritratto di davide_maggi
davide_maggi
(Junior)
Offline
Junior
Iscritto: 19/08/2014
Messaggi: 10

La batteria l'ho cambiata 2 settimane fa ma già il problema si presentava con una certa frequenza...
L'unica cosa che mi fa sorgere un dubbio è l'aver cambiato i banchi di RAM passando da 4 a 8Gb...
C'è modo di poter analizzare il momento in cui avviene il blocco? Un file di log o qualcosa del genere...

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 386

Da come scrivi dovrebbe essere un portatile o sbaglio? In ogni caso aggiungere ram dopo aver installato il SO, su Linux, richiede anche la modifica proprio per l'aggiunta. Tieni però presente che: 2 gb sono più che validi per un SO a 32 bit; sono necessari 4 gb se il SO è a 64 bit. Mettere più ram (a meno che non sia un server vero) non so che beneficio possa darti... prova a tornare a 4 gb e vedere se funziona, anche se hai cambiato marca.

Ritratto di davide_maggi
davide_maggi
(Junior)
Offline
Junior
Iscritto: 19/08/2014
Messaggi: 10

Ciao,

Si, è un portatile.
no, la RAM è stata aggiunta un mese fa mentre il sistema è stata installato una settimana e mezza fa...
in origine su questo PC giravano Win7 e Fedora in dual boot mentre ora l'unico sistema installato è Debian 7.
Il processore è un i7 (prima edizione) a 64bit e la RAM installata è di 8Gb perchè ho necessità di lanciare abbastanza spesso una macchina virtuale con Win7 che a sua volta deve poter eseguire almeno office e un PDF Editor per questioni di lavoro.
I banchi di RAM sono stati sostituiti entrambi dal momento che in origine erano 2 da 2Gb...

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1325

davide_maggi ha scritto:

C'è modo di poter analizzare il momento in cui avviene il blocco? Un file di log o qualcosa del genere...


I file di log sono nella directory /var/log . Se esistono tracce del blocco nei log le trovi nel file /var/log/syslog (o nelle sue versioni storicizzate /var/log/syslog.1 e /var/log/syslog.*.gz )

Ritratto di Pipperss
Pipperss
(Junior)
Offline
Junior
Iscritto: 15/08/2014
Messaggi: 25

davide_maggi ha scritto:

C'è modo di poter analizzare il momento in cui avviene il blocco? Un file di log o qualcosa del genere...

Per i log ti ha risposto Homeless, cmq puoi sempre cotrollare la temperatura della cpu e tenere sottomano il carico di sistema, e quindi alla rinfusa i vari top, htop, cpufreq, cpufreq-info sono i tuoi amici.
Magari la cpu si surriscalda e il portatile va in protezione.

Per la ram magari una distro-live con un memtest da provarla a fondo; cmq penso sempre che sia un problema hw.

Saluti,
pippersss

Ritratto di Pipperss
Pipperss
(Junior)
Offline
Junior
Iscritto: 15/08/2014
Messaggi: 25

fareyes ha scritto:

In ogni caso aggiungere ram dopo aver installato il SO, su Linux, richiede anche la modifica proprio per l'aggiunta.

Scusa ma la modifica di che? Nel mio portatile sono passato da 4 a 8 giga e Wheezy manco ha fiatato, ha detto solo grazie!

fareyes ha scritto:

Tieni però presente che: 2 gb sono più che validi per un SO a 32 bit; sono necessari 4 gb se il SO è a 64 bit.

Anche questa me la devi spiegare, non capisco perchè i sistemi a 64 bit devono consumare più ram

Saluti,
pippersss

Ritratto di davide_maggi
davide_maggi
(Junior)
Offline
Junior
Iscritto: 19/08/2014
Messaggi: 10

mah oddio... se la CPU si surriscaldasse mi aspetterei magari un arresto per protezione, non un blocco totale del sistema con ancora tutto a video...

Senz'altro imparerò invece a padroneggiare i vari comandi che mi hai suggerito (intanto imparo qualcosa di nuovo dato che non sono ancora decisamente un maestro della bash... Smile

Vi terrò aggiornati sull'esito.

grazie intanto Smile

Ritratto di davide_maggi
davide_maggi
(Junior)
Offline
Junior
Iscritto: 19/08/2014
Messaggi: 10

Questo allegato è il syslog di stamattina con 2 arresti.

Da dove posso capire quando è avvenuto il blocco?
Immagino che sia più o meno in corrispondenza di quando si ripete la sequenza di caricamento del sistema operativo..

AllegatoDimensione
syslog_01092014.txt 363.08 KB
Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1325

Dai log risultano un freeze alle 09:42 e 11:07 circa:

Sep  1 09:41:02 jarvis kernel: [ 4880.534484] atkbd serio0: Unknown key released (translated set 2, code 0x8d on isa0060/serio0).
Sep  1 09:41:02 jarvis kernel: [ 4880.534495] atkbd serio0: Use 'setkeycodes e00d <keycode>' to make it known.
Sep  1 09:41:59 jarvis kernel: [ 4935.776117] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 0
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c: snd_pcm_avail() ha restituito un valore molto grande: 459288 byte (2603 ms).
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c: Molto probabilmente si tratta di un bug nel driver ALSA "snd_hda_intel". Segnalare questo problema agli sviluppatori ALSA.
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c: snd_pcm_dump():
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c: Soft volume PCM
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c: Control: PCM Playback Volume
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c: min_dB: -51
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c: max_dB: 0
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c: resolution: 256
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c: Its setup is:
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c:   stream       : PLAYBACK
Sep  1 09:42:03 jarvis pulseaudio[4997]: [alsa-sink] alsa-util.c:   access     Sep  1 09:43:27 jarvis kernel: imklog 5.8.11, log source = /proc/kmsg started.
Sep  1 09:43:27 jarvis rsyslogd: [origin software="rsyslogd" swVersion="5.8.11" x-pid="2581" x-info="http://www.rsyslog.com"] start
Sep  1 09:43:27 jarvis kernel: [    0.000000] Initializing cgroup subsys cpuset
Sep  1 09:43:27 jarvis kernel: [    0.000000] Initializing cgroup subsys cpu
Sep  1 09:43:27 jarvis kernel: [    0.000000] Linux version 3.2.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP Debian 3.2.60-1+deb7u3
Sep  1 09:43:27 jarvis kernel: [    0.000000] Command line: BOOT_IMAGE=/vmlinuz-3.2.0-4-amd64 root=/dev/mapper/jarvis-root ro quiet

e
Sep  1 11:05:11 jarvis dbus[2707]: [system] Successfully activated service 'org.freedesktop.PackageKit'
Sep  1 11:06:25 jarvis kernel: [ 5004.056369] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 0
Sep  1 11:06:30 jarvis kernel: [ 5009.056155] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 5
Sep  1 11:06:34 jarvis kernel: [ 5011.056283] [drm] nouveau 0000:01:00.0: PGRAPH TLB flush idle timeout fail: 0x00b00003 0x00000000 0x00001068 0x00000000
Sep  1 11:06:34 jarvis kernel: [ 5011.056283] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 0
Sep  1 11:06:39 jarvis kernel: [ 5018.056010] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 5
Sep  1 11:06:43 jarvis kernel: [ 5020.056226] [drm] nouveau 0000:01:00.0: PGRAPH TLB flush idle timeout fail: 0x00b00003 0x00000000 0x00001068 0x00000000
Sep  1 11:06:43 jarvis kernel: [ 5020.056226] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 0
Sep  1 11:06:48 jarvis kernel: [ 5027.056170] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 5
Sep  1 11:06:52 jarvis kernel: [ 5029.056282] [drm] nouveau 0000:01:00.0: PGRAPH TLB flush idle timeout fail: 0x00b00003 0x00000000 0x00001068 0x00000000
Sep  1 11:06:52 jarvis kernel: [ 5029.056282] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 0
Sep  1 11:06:54 jarvis kernel: [ 5033.060021] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 5
Sep  1 11:06:58 jarvis kernel: [ 5035.072147] [drm] nouveau 0000:01:00.0: PGRAPH TLB flush idle timeout fail: 0x00b00003 0x00000000 0x00001068 0x00000000
Sep  1 11:06:58 jarvis kernel: [ 5035.072147] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 0
Sep  1 11:07:03 jarvis kernel: [ 5043.471918] [drm] nouveau 0000:01:00.0: PFIFO_INTR 0x04200000 - Ch 4
Sep  1 11:07:05 jarvis kernel: [ 5043.576298] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 5
Sep  1 11:07:09 jarvis kernel: [ 5045.576412] [drm] nouveau 0000:01:00.0: PGRAPH TLB flush idle timeout fail: 0x00b00003 0x00000000 0x00001068 0x00000000
Sep  1 11:07:09 jarvis kernel: [ 5045.576412] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 0
Sep  1 11:07:10 jarvis kernel: [ 5050.900833] [drm] nouveau 0000:01:00.0: PFIFO_INTR 0x04000000 - Ch 4
Sep  1 11:07:12 jarvis kernel: [ 5050.916088] [drm] nouveau 0000:01:00.0: vm flush timeout: engine 5
Sep  1 11:30:21 jarvis kernel: imklog 5.8.11, log source = /proc/kmsg started.
Sep  1 11:30:21 jarvis rsyslogd: [origin software="rsyslogd" swVersion="5.8.11" x-pid="2589" x-info="http://www.rsyslog.com"] start
Sep  1 11:30:21 jarvis kernel: [    0.000000] Initializing cgroup subsys cpuset
Sep  1 11:30:21 jarvis kernel: [    0.000000] Initializing cgroup subsys cpu
Sep  1 11:30:21 jarvis kernel: [    0.000000] Linux version 3.2.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP Debian 3.2.60-1+deb7u3
Sep  1 11:30:21 jarvis kernel: [    0.000000] Command line: BOOT_IMAGE=/vmlinuz-3.2.0-4-amd64 root=/dev/mapper/jarvis-root ro quiet
Sep  1 11:30:21 jarvis kernel: [    0.000000] Disabled fast string operations

A mio avviso, la prima causa da indagare è il driver open source ("noveau") della scheda grafica poiché in entrami i casi immediatamente prima del crash si è verificato un errore a carico di tale driver: installa i driver proprietari per la tua scheda grafica nvidia.