Aggiornamento Wheeze problematico

9 risposte [Ultimo contenuto]
Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 595

Ciao ragazzi,
ieri ho avuto la malsana idea di provare plymouth. L'installazione non è avvenuta e ad ogni tentativo intrapreso dopo, mi venivano segnalate dipendenze non risolte con il consiglio di lanciare un

apt-get -f install

per sistemare il tutto. Eseguo e tutto torna alla normalità (nessun errore viene segnalato più), rinuncio a plymonth e già che ci sono lancio un upgrade.

Questa mattina avvio il pc, il boot avviene regolarmente, ma il server x non parte. Provo a lanciare un upgrade ma non risolve nulla, tento di reinstallare i driver nvidia, ma non ci riesco: module-assistant mi dice che non è possibile trovare i linux-headers relativi al mio kernel (il 2.6.32).
Pensando di poter risolvere, decido di lanciare un dst-upgrade, in questo modo aggiorno anche il kernel al 2.6.38.
Mai un aggiornamento fù più funesto!!!! Vengono rilevati problemi nel rimuovere OpenOffice per far posto a LibreOffice, con il risultato che l'aggiornamento si blocca senza poter avere la possibilità di riprenderlo...

Alla fine riesco ad avviare il server x solo con i driver "vesa" (che non riconoscono il mio monitor), il nuovo kernel non è stato installato e mi ritrovo con una Wheeze semi distrutta e inutilizzabile (vedi foto) Sad .

Inoltre allego dei log che possono servire.

Come posso ripristinare tutto???

.theShort Sad

AllegatoDimensione
history.log_.txt46.28 KB
term.log1_.txt595.91 KB
term.log2_.txt444.47 KB
Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 595

Qualche aggiornamento:
oggi come prima cosa ho cercato di fare un po' di pulizzia:

apt-get -f autoremove
apt-get clean

successivamente ho lanciato un:
apt-get -f install

ed infine:
apt-get update (non mi ha dato errori)
apt-get -f ugrade
apt-get -f dist-upgrade

In conclusione, non riesco a risolvere nulla. Ogni tentativo di aggiornamento o di installazione, si conclude con il messaggio:

dpkg: errore nell'elaborare /var/cache/apt/archives/mythes-it_2.0.7.gh.deb1-2_all.deb (--unpack):
 tentata sovrascrittura di "/usr/share/myspell/dicts/th_it_IT_v2.idx" presente anche nel pacchetto openoffice.org-thesaurus-it 2.0.7.gh.deb1-1.1
dpkg-deb: error: subprocess paste was killed by signal (Pipe rotta)
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/mythes-it_2.0.7.gh.deb1-2_all.deb

Ho provato anche ad eliminare "th_it_IT_v2.idx", ma non riesco ad ottenere risultati...

Maledetto openoffice!!!!!! Phbbbbt!

.theShort Sad

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 391

Intanto segnati questo che ti può servire per risolvere/sapere quali dipendenze sono collegate: apt-rdepends nomepacchetto o nomeprogramma. Ti permette di sapere quali siano le dipendenze al pacchetto/programma collegate, però la pecca è che tale apt-rdepends, non è installato di sistema, quindi bisogna farlo a mano.

Poi: prova ad installare i mancanti linux-headers relativi al SO e dopo fai un reboot. Non credo ancora funzionerà, ma almeno avrai più info (anche da postare) e capirai magari come agire.

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 595

Ciao e grazie dell'interessamento,

prima che leggessi la tua risposta ho provato a lanciare:

ls -la /var/lib/dpkg/info/ | grep mythes

e ho eliminato tutti i file che sono stati elencati e dopodichè ho ripulito la cahe di apt, ma il problema non si è risolto.
Però, sono riuscito a fare un piccolo passo avanti (o per meglio dire, indietro) dando:
dpkg --configure -a

In questo modo ho ristabilito, in parte, il sitema come era in origine. Ovviamente i driver nvidia non vengono caricati (sono sempre costretto a utilizzare i vesa) e in più, ora, mi ritrovo senza openoffice e nemmeno libreoffice, che durante l'aggiornamento non è nemmeno stato installato.

Ho cercato di installare apt-rdepends, ma non ci riesco. Per qualsiasi pacchetto per cui tento l'installazione o la rimozione,ricevo sempre come errore:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 libreoffice : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
               Dipende: libreoffice-writer ma non sta per essere installato
 libreoffice-base : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
                    Dipende: ure (>= 1.7.0+LibO3.3.0~beta3) ma la versione 1.6.1+OOo3.2.1-11+squeeze2 sta per essere installata
 libreoffice-base-core : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
                         Dipende: ure (>= 1.7.0) ma la versione 1.6.1+OOo3.2.1-11+squeeze2 sta per essere installata
 libreoffice-calc : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
                    Dipende: ure (>= 1.7.0) ma la versione 1.6.1+OOo3.2.1-11+squeeze2 sta per essere installata
 libreoffice-draw : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
                    Dipende: ure (>= 1.7.0) ma la versione 1.6.1+OOo3.2.1-11+squeeze2 sta per essere installata
 libreoffice-evolution : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
                         Dipende: ure (>= 1.7.0) ma la versione 1.6.1+OOo3.2.1-11+squeeze2 sta per essere installata
 libreoffice-filter-binfilter : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
                                Dipende: ure (>= 1.7.0) ma la versione 1.6.1+OOo3.2.1-11+squeeze2 sta per essere installata
 libreoffice-gcj : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
 libreoffice-gnome : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
 libreoffice-gtk : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
                   Dipende: ure (>= 1.7.0+LibO3.3.0~beta3) ma la versione 1.6.1+OOo3.2.1-11+squeeze2 sta per essere installata
 libreoffice-impress : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
 libreoffice-java-common : Dipende: libreoffice-common ma non sta per essere installato
 libreoffice-math : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
 libreoffice-officebean : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
 libreoffice-report-builder-bin : Dipende: ure (>= 1.7.0) ma la versione 1.6.1+OOo3.2.1-11+squeeze2 sta per essere installata
                                  Dipende: libreoffice-core ma non sta per essere installato
 libreoffice-style-andromeda : Dipende: libreoffice-core ma non sta per essere installato
 libreoffice-style-crystal : Dipende: libreoffice-core ma non sta per essere installato
 libreoffice-style-galaxy : Dipende: libreoffice-core ma non sta per essere installato
 libreoffice-style-hicontrast : Dipende: libreoffice-core ma non sta per essere installato
 libreoffice-style-oxygen : Dipende: libreoffice-core ma non sta per essere installato
 libreoffice-style-tango : Dipende: libreoffice-core ma non sta per essere installato
 openoffice.org-common : Dipende: libreoffice-common (>= 1:3.3.0~rc4-2) ma non sta per essere installato
 openoffice.org-writer : Dipende: libreoffice-writer ma non sta per essere installato
 python-uno : Dipende: libreoffice-core (= 1:3.3.2-2) ma non sta per essere installato
              Dipende: ure (>= 1.7.0+LibO3.3.0~beta3) ma la versione 1.6.1+OOo3.2.1-11+squeeze2 sta per essere installata
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
 
Done!

Ovviamente "apt-get -f install" continua a non risolvermi il problema.

Ho controllato in Debian Packages, i linux headers 2.6.32 in wheeze non sono più presenti, però ci sono in squeeze. Ho provato a scaricarli da lì, ma ovviamente non posso installarli perchè ricevo l'errore che ho riportato sopra Sad .

Insomma, fino a quando non risolvo queste maledette dipendenze di libreoffice, mi ritrovo con le mani legate! Bella fregatura! Phbbbbt!

.theShort At Wits End

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 391

Mhhh, in questa situazione eviterei di fare un downgrade degli headers e tenterei invece di risolvere ogni cosa, anche poco per volta.
Caso mai reinstalla gli originali ...

Hai detto che non monta più OpenOffice e/o LibreOffice. Hai provato a disinstallare Libre Office? Forse ti permetterà di reinstallare OpenOffice e da là magari correggerà altro (dipendenze varie collegate)...

Strano però che ti abbia fatto l'aggiornamento a Wheezy, perché ho provato giorni fa anche io ma non aggiorna un tubo. Vuole che inserisca in sources.list i vari percorsi, al che mi sono fermato dopo aver letto qualche "critica" di utente che ha avuto il pc in crash dopo tale upgrade...

Per la tua questione potresti anche provare con il DVD live di Debian 6.0 e vedere se per caso riesca a correggere ciò che è fallato. Non ti dico che funzionerà, ma a questo punto proverei...

Una domanda: per la Nvidia intendi server xserver-xorg-video-nv che corrisponde alla scheda?

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 595

ciao fareyes,
scusami, ma avrei dovuto specificare meglio la mia posizione e lo farò ora:
io sono un regolare utente Debian testing, a causa di problemi dell'installazione di plymouth (poi abbandonata) mi sono giocato i driver nvidia. Ho provato a reinstallarli tramite module-assistant (Debian way) ma ho scoperto che i linux-headers per il mio attuale kernel (2.6.32) non sono più presenti nel repo di wheeze, rimpiazzati da quelli per il 2.6.38.
Per cercare di ripristinare il tutto, ho optato per un "dist-upgrade", in questo modo avrei aggiornato la mia wheeze all'ultimo kernel disponibile, per poi rimontare i driver nvidia.
Il problema è degenerato per via del fatto che l'aggiornamento prevede di sostituire openoffice con libreoffice e questo passaggio non è andato a buon fine, creandomi un disastro.

Non posso rimuovere libreoffece per il semplice fatto che non viene rilevato come installato e per ironia della sorte anche openoffice non viene più rilevato come installato.

Io vorrei tanto poter installare e rimuovere qualcosa, ma non posso perchè i processi vengono bloccati per via dell'errore che ho riportato sopra, errore che si riconduce proprio alle dipendenze non soddisfatte nel passaggio tra openoffice e libreoffice. E questo succede anche se mi scarico a mano pacchetti .deb e l'installo tramite gdebi o dpkg.

Grazie per avermi fatto notare di non aver specificato la mia scheda grafica, è una Asus ENGTX275 e i driver che montavo (e che teoricamente dovrei avere ancora ma non mi funzionano più) sono gli nvidia-glx. Spero sia questo quello che mi chiedi...

Per ora provo come mi di ci tu, ripristinare tramite un DVD live.
Altra cosa che potrei fare è cancellare a mano tutte le cartelle openoffice e libreoffice che trovo.

Per il momento grazie e ci aggiorniamo poi Wink

.theShort At Wits End

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 595

Ok, finalmente ho risolto tutto!!! Party

Non riuscendo più a fare nulla tramite apt, per installare l'immagine del nuovo kernel (2.6.38) ho usato aptitude, che ha obbedito al mio ordine infischiandosene di dipendenze non risolte e conflitti tra pacchetti Smile. Inoltre nella manovra è stato pure tanto gentile da eliminare tutto ciò che era rimasto di openoffice e libreoffice, riabilitando di conseguenza apt.
Infine ho potuto reinstallare i driver nvidia e in più, ho deciso di continuare ad usare openoffice e ho lanciato il comando:

apt-get install openoffice.org

Indovinate cosa mi sono ritrovato installato? LIBREOFFICE!!!! Surprise
Ok, va bene... se Debian così ha deciso, da oggi sarò un nuovo utente libreoffice Smile .
Curioso questo modo di promuovere (ma diciamo anche forzare) l'utilizzo di libreoffice da parte di Debian.

L'unica nota dolente è che il sistema ora mi sembra un po' più lento drispetto a prima... indagherò.

Comunque, grazie fareyes per esserti interessato al mio caso! Wink

Tutto è bene quel che finisce bene! Bye!

.theShort Big Grin

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Quindi d'ora in poi userai solo più aptitude, giusto? Smile

Scherzi a parte, dopo una sessione di (dis)installazione selvaggia di pacchetti come la tua, chissà quanti file di configurazione "spuri" ti ritrovi sul tuo file system. Ti propongo questa procedura per dare una ripulita:

# aptitude purge '~c'

Volendo usare l'interfaccia grafica invece fai così.

  1. Lancia aptitude da root.
  2. Premi il tasto "L" per impostare un filtro personalizzato e scrivi "~c".
  3. Vedrai l'elenco di tutti i pacchetti attualmente rimossi ma non purgati: vuol dire che hanno ancora file di configurazione installati da qualche parte.
  4. Scegli quali vuoi purgare usando il tasto underscore.
  5. Premi il tasto "G" due volte per eseguire.
  6. Una volta finito il tutto, ricordati di premere di nuovo "L" e cancellare il filtro se vuoi ancora lavorare con aptitude.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Scusate, ho fatto casini e ho inviato due volte. Darò la colpa al browser: sarà credibile visto che è un prodotto MS!! Wink

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 595

mcortese ha scritto:


Quindi d'ora in poi userai solo più aptitude, giusto? Smile


Eheheh!!! Se Debian consiglia l'utilizzo di aptitude, un motivo ci sarà... Smile

Comunque ieri sera ho lanciato un # apt-get autoremove e successivamente ho fatto un upgrade. Con questo la situazione è migliorata, sono ritornato ad avere un sistema abbastanza performante.

Ora purgo anche come dici tu, che tanto male non gli fa. Grazie della dritta! Wink

.theShort Big Grin