Accesso utente root Debian Squeeze

13 risposte [Ultimo contenuto]
Ritratto di wallnas
wallnas
(Newbie)
Offline
Newbie
Iscritto: 26/12/2010
Messaggi: 4

Salve a tutti,

ho problemi nell'accesso a debian squeeze come utente root, dopo aver inserito utente root e password mi da come errore "authentication failure"

ho modificato file /etc/gdm3/daemon.conf

inserendo alla label [security] AllowRoot=true

ho riavviato il computer ma il problema permane:

come posso fare ?

Grazie a tutti

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Ciao, mi chiedo quali necessità tu abbia per loggardi come root in debian... E' una cosa decisamente sconsigliata.
Ti basterebbe loggarti normalmente come utente e diventare superutente diginatto "su" da terminale e inserendo la password.

.theShort Big Grin

Ritratto di ferretti75
ferretti75
(Guru)
Offline
Guru
Iscritto: 08/07/2005
Messaggi: 526

in effetti quello che dice theShort ha senso ... mi domando : stai tentando di accedere al login (gdm o kdm) come root ? potrebbe essere disabilitato !! Prova come dice theShort : se funziona allora sai che l'utente root non è abilitato al login. Nel caso non funzioni ho paura che tu abbia dimenticato la password di root .

--marco

apt-get -a beer

Ritratto di wallnas
wallnas
(Newbie)
Offline
Newbie
Iscritto: 26/12/2010
Messaggi: 4

Intanto grazie,

il login come root probabilmente è disabilitato ed io per questo sono andato in /etc/gdm3/daemon.conf e alla label security ho inserito allowroot=true come funzionava per la versione di lenny

Ho provato ad entrare come utente normale: digitando su e password va tutto ok.
In effetti come dice theshort utilizzando i comandi standard non ci sono problemi, ma nella versione lenny l'accesso come utente root va perchè in squeeze non va ?

ci deve essere qualcos'altro da fare .

Grazie per l'aiuto

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Ciao, se proprio vuoi loggarti come root prova a postare il tuo daemon.conf.

.theShort Big Grin

Ritratto di wallnas
wallnas
(Newbie)
Offline
Newbie
Iscritto: 26/12/2010
Messaggi: 4

theShort ha scritto:

Ciao, se proprio vuoi loggarti come root prova a postare il tuo daemon.conf.

.theShort Big Grin

Non ho trovato opzione per allegare il file, posto il contenuto:

# GDM configuration storage
#
# See /usr/share/gdm/gdm.schemas for a list of available options.
# Some settings can also be configured using the gdmsetup tool.
 
[daemon]
# AutomaticLoginEnable = false
# AutomaticLogin = 
 
[security]
AllowRoot=true
 
[xdmcp]
 
[greeter]
 
[chooser]
 
[debug]

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Ciao,
mi basta vedere cosa ci sia scritto in daemon.conf, non mi serve il file Smile.
Cmq per postare codice puoi utilizzare il tasto "<>", il quarto da destra.

Prova a sostitutire "AllowRoot=true" con "AllowRemoteRoot=true".
Hai provato a loggarti come root senza inserire nessuna password?

Ciao ciao.

.theShort Big Grin

Ritratto di wallnas
wallnas
(Newbie)
Offline
Newbie
Iscritto: 26/12/2010
Messaggi: 4

theShort ha scritto:

Ciao,
mi basta vedere cosa ci sia scritto in daemon.conf, non mi serve il file Smile.
Cmq per postare codice puoi utilizzare il tasto "<>", il quarto da destra.

Prova a sostitutire "AllowRoot=true" con "AllowRemoteRoot=true".
Hai provato a loggarti come root senza inserire nessuna password?

Ciao ciao.

.theShort Big Grin

Effettuato il cambio in "AllowRemoteRoot=true" non riesco ad accedere come root

Fatta prova digitando user root senza password: non accede.

Il messaggio comune è "Authentification Failure"

Ciao

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

AllowRoot è stato eliminato dalla versione 2.24 (più o meno). Ora tutta la gestione della sicurezza è affidata a PAM, in particolare /etc/pam.d/gdm.
Questo per rispondere alla domanda "perché in squeeze non va?".
Invece la risposta al quesito originario "come posso fare per accedere come root?" è: non farlo. Non c'è alcun motivo per volere una cosa del genere. Entra come utente normale, poi lancia solo i comandi che vuoi come root usando su, sudo, gksu, ecc.

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Eggià... lo scopro solo ora...

Per maggiori informazioni puoi leggere quì

.theShort Big Grin

Ritratto di ferretti75
ferretti75
(Guru)
Offline
Guru
Iscritto: 08/07/2005
Messaggi: 526

grazie dell'info !! questa mi era proprio sfuggita !

apt-get -a beer