Wordpress: è per caso cambiato qualcosa?

4 risposte [Ultimo contenuto]
Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 411

Sto ancora appresso a wordpress che neppure a farlo apposta mi sta tirando matto. Installato correttamente XAMPP, copiato la cartella wordpress espansa in /opt/lampp/htdocs, sistemati i vari files e permessi dopo fatto il primo database in PhpMyadmin. Il problema è sempre quando vado a tentare di aggiornare plugin o scaricare temi: non lo permette e continua a chiedere utenti e password che non ho o non conosco perché mai inseriti. Da tenere presente che i vari permessi a XAMPP li ha già messi l'installazione. Se in httpd.conf cambio nome utente e gruppo, non mi fa entrare. La parte negativa è che ho in httpd.conf di default Utente daemon e Gruppo daemon...
Worpdress, XAMPP, PhpMyadmin funzionano, ma Proftpd pure se caricato da XAMPP, non permette di collegarsi al sito e scaricare.

Faccio presente che serve installazione ed uso in locale, e vorrei evitare il download di pacchetti da dover poi copiare nelle varie dir.

Ho sentito in rete altri utenti lamentarsi dello stesso problema e uno ha dscritto che sembra ci sia un bug nella versione 4.0 di wordpress che non permetterebbe di collegarsi in ftp (ma mi sembra assurdo).

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 411

Faccio un'aggiunta.
Nel mio wp-config.php non esiste la voce menzionata sul sito di wp-org relativa alla lingua.
Nel mio file ho solo

define('DB_NAME', 'XXX_db');
 
/** MySQL database username */
define('DB_USER', 'YYY');
 
/** MySQL database password */
define('DB_PASSWORD', 'ZZZ');
 
/** MySQL hostname */
define('DB_HOST', 'localhost');
 
/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8');
 
/** The Database Collate type. Don't change this if in doubt. */
define('DB_COLLATE', '');

Ecco un esempio di come siano mal fatte le guide per WP! Non si può in un sito scrivere una cosa e in altri variare e riportare differente!!!
Per fortuna vogliono espanderlo!

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 411

Chiudo il thread perché girando in rete non ci sono (almeno non ne ho trovate) risposte possibili. Ho disinstallato tutto e vedrò in seguito se installare a nuovo.
Grazie comunque.

Ritratto di lollix01
lollix01
(Monster)
Offline
Monster
Iscritto: 22/02/2014
Messaggi: 411

Insisto per farti provare il comunissimo, famossissimo, standardissimo, usatissimo, serverissimo, tuttissimo, issimo e qualsiasi cosa sia un serber per wordpress: LAMP!!! È facilissimo, e da come dimostrato molto, ma molto più semplice di XAMPP! (vsftp è megliooo!).

We are MicroSoft. You will be assimilated. Resistance is futile.
-- Attributed to B.G., Gill Bates

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 411

Dopo chiuso il thread ho disinstallato tutto. Non essendo mio pc (ma di un amico) volevo dargli qualcosa di semplice epulito da usare, senza dover fare altro che le sue pagine.
L'ultimo tentativo l'ho fatto installando xampp e quel wordpress dato da Bitnami che è molto più leggero di wp originale. Non ci crederai ma nonostante dicano che è facilissimo ed automatizzato (in quanto ritenuto modulo) è stata un'altra battaglia. Non dicono che hanno bloccato alcune cose e il path per i plugins e temi è cambiato. Il modulo WP installa in "/opt/lampp/apps/wordpress/htdocs" che nulla ha a che fare con l'originale "/opt/lampp/htdocs/wordpress". Se questo non è una svista, non so che dire! In genere quando si installa Wordpress in xampp, lo si mette in "/opt/lampp/htdocs", mentre qui hanno letteralmente variato il percorso dando seguito ad una serie di messaggi di errore che saltano fuori di volta in volta e del tipo "Scarico plugins e temi impossibile; percorso non trovato..." oppure altro che comunque segnala errore. Le impostazioni sono quelle di default (per cui consigliate) e funziona così? Cioè se compro l'auto nuova poi magari manca il serbatoio?
Vediamo di essere realisti e linuxiani.

Non è pasticciare, questo? Uno che si avvicina per la prima volta a Linux, come si può pensare che ritenga tale roba facile? E dato che sto "allevando" un amico all'uso di Linux, non intendo passare l'inferno o farlo passare a lui che deve iniziare..! La mia intenzione era di dargli il pc e farlo iniziare ad usare wordpress, ma a queste condizioni non ci sto. Non posso ricevere poi telefoinate in continuazione perché ci sono errori che non è in grado di eliminare..! Quando faranno WP in modo serio come sostengono in Bitnami ("è facile basta installare il modulo wp.run...") allora proverò.
Ho già una certa difficoltà io con la mia versione, figuriamoci lui cosa dovrebbe fare. Meglio un corso accelerato come funambolo al circo!
Lollix01 non te la prendere, ma per il momento lascio stare... gli do il pc così come è,senza WP. Gli lascio fare un po' la mano e spero che nel frattempo facciano qualcosa di più malleabile.
Grazie comunque Wink