Wine: non riesco a installarlo

3 risposte [Ultimo contenuto]
Ritratto di xlepws
xlepws
(Newbie)
Offline
Newbie
Iscritto: 16/03/2020
Messaggi: 2

Ciao a tutti, ho seguito questa guida per installare Wine: https://tecadmin.net/install-wine-on-debian-10-buster/

-----
root@debian02:/home/manu# apt-get install --install-recommends winehq-stable
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
winehq-stable : Dipende: wine-stable (= 3.0.4~sid)
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
-----

Come mi consigliate di procedere? Anche senza mettere --install-recommends l'errore è lo stesso
Se provo a installare wine-stable, mi dice "wine-stable : Dipende: wine-stable-i386 (= 3.0.4~sid)".
Se provo a installare wine-stable-i386, mi saltano fuori un sacco di altre dipendenze:

-----
I seguenti pacchetti hanno dipendenze non soddisfatte:
wine-stable-i386:i386 : Dipende: libasound2:i386 (>= 1.0.16)
Dipende: libc6:i386 (>= 2.28) ma non sta per essere installato
Dipende: libglib2.0-0:i386 (>= 2.12.0) ma non sta per essere installato
Dipende: libgphoto2-6:i386 (>= 2.5.10) ma non sta per essere installato
Dipende: libgphoto2-port12:i386 (>= 2.5.10) ma non sta per essere installato
Dipende: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) ma non sta per essere installato
Dipende: libgstreamer1.0-0:i386 (>= 1.4.0) ma non sta per essere installato
Dipende: liblcms2-2:i386 (>= 2.2+git20110628) ma non sta per essere installato
Dipende: libldap-2.4-2:i386 (>= 2.4.7) ma non sta per essere installato
Dipende: libmpg123-0:i386 (>= 1.13.7) ma non sta per essere installato
Dipende: libopenal1:i386 (>= 1.14) ma non sta per essere installato
Dipende: libpcap0.8:i386 (>= 0.9.8) ma non sta per essere installato
Dipende: libpulse0:i386 (>= 0.99.1) ma non sta per essere installato
Dipende: libudev1:i386 (>= 183) ma non sta per essere installato
Dipende: libx11-6:i386 ma non sta per essere installato
Dipende: libxext6:i386 ma non sta per essere installato
Dipende: libxml2:i386 (>= 2.9.0) ma non sta per essere installato
Dipende: zlib1g:i386 (>= 1:1.1.4) ma non sta per essere installato
Dipende: libasound2-plugins:i386 ma non sta per essere installato
Dipende: libncurses5:i386 ma non sta per essere installato
Raccomanda: libcapi20-3:i386 ma non sta per essere installato
Raccomanda: libcups2:i386 (>= 1.4.0) ma non sta per essere installato
Raccomanda: libdbus-1-3:i386 (>= 1.9.14) ma non sta per essere installato
Raccomanda: libfontconfig1:i386 (>= 2.12.6) ma non sta per essere installato
Raccomanda: libfreetype6:i386 (>= 2.2.1) ma non sta per essere installato
Raccomanda: libglu1-mesa:i386 ma non sta per essere installato oppure
libglu1:i386
Raccomanda: libgnutls30:i386 (>= 3.5.0) ma non sta per essere installato
Raccomanda: libgsm1:i386 (>= 1.0.13) ma non sta per essere installato
Raccomanda: libjpeg62-turbo:i386 (>= 1.3.1) ma non sta per essere installato
Raccomanda: libkrb5-3:i386 (>= 1.6.dfsg.2) ma non sta per essere installato
Raccomanda: libncurses6:i386 (>= 6) ma non sta per essere installato
Raccomanda: libodbc1:i386 (>= 2.3.1) ma non sta per essere installato
Raccomanda: libosmesa6:i386 (>= 10.2~) ma non sta per essere installato
Raccomanda: libpng16-16:i386 (>= 1.6.2-1) ma non sta per essere installato
Raccomanda: libsane:i386 (>= 1.0.24) ma non sta per essere installato
Raccomanda: libtiff5:i386 (>= 4.0.3) ma non sta per essere installato
Raccomanda: libv4l-0:i386 (>= 0.5.0) ma non sta per essere installato
Raccomanda: libxcomposite1:i386 (>= 1:0.3-1) ma non sta per essere installato
Raccomanda: libxcursor1:i386 (> 1.1.2) ma non sta per essere installato
Raccomanda: libxfixes3:i386 ma non sta per essere installato
Raccomanda: libxi6:i386 ma non sta per essere installato
Raccomanda: libxinerama1:i386 ma non sta per essere installato
Raccomanda: libxrandr2:i386 ma non sta per essere installato
Raccomanda: libxrender1:i386 ma non sta per essere installato
Raccomanda: libxslt1.1:i386 (>= 1.1.25) ma non sta per essere installato
Raccomanda: libxxf86vm1:i386 ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

..aiuto!

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1431

Credo che tu non abbia configurato il multiarch per i386

Ritratto di xlepws
xlepws
(Newbie)
Offline
Newbie
Iscritto: 16/03/2020
Messaggi: 2

Ciao, è abilitato

dpkg --add-architecture i386

ho seguito anche le istruzioni qui: https://wiki.debian.org/Wine, ma niente da fare

Ritratto di Geppe
Geppe
(Junior)
Offline
Junior
Iscritto: 20/08/2019
Messaggi: 13

Buongiorno

Ho constatato che con debian 10.3 il programma di posta "Evolution" non è possibile stampare le mail, ossia viene avviata la stampante, sul monitor compare la scritta "Stampa completata" ma non viene stampato niente; non viene segnalato alcun errore. Premetto che con tutti gli altri programmi non c'è alcun problema di stampa.

Potete aiutarmi a capire il motivo e come può essere risolto?

Grazie