Vncserver al boot

3 risposte [Ultimo contenuto]
Ritratto di Pipperss
Pipperss
(Junior)
Offline
Junior
Iscritto: 15/08/2014
Messaggi: 25

Ciao a tutti,
molto probabilmente è una cavolata ma non riesco ad uscirne.
Sul serverino c'è wheezy + lxde devo far partire un server vnc per potermi connettere da remoto (ma cmq sempre nella mia rete locale), via ssh se digito
tightvncserver :1 -geometry 1000x600
va tutto bene e da remoto mi connetto, non riesco a far partire il server vnc al boot, mi parte solo se fisicamente con tastiera e mouse e monitor attaccati al serverino faccio il login utente.
Ho editato senza esiti:
/etc/rc.local aggiungendo sudo -u utente tightvncserver :1 -geometry 1000x600
~/.config/autostart aggiungendo @tightvncserver :1 -geometry 1000x600
~/.config/lxsession/ aggiungendo sempre @tightvncserver :1 -geometry 1000x600
/etc/xdg/lxsession/LXDE/autostart sempre con @tightvncserver :1 -geometry 1000x600

Dove sbaglio ?

Saluti,
pipperssss

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Ciao,
non vorrei dire un'eresia ma credo che VNC server per funzionare deve avere già un desktop attivo, quindi devi per forza prima fare il login sul server.
Non sono sicuro al 100% anche perchè secondo me ci sono soluzioni di gran lunga migliori a VNC, io opterei per SSH e X11 forwarding in questo modo ti colleghi al server con SSH e poi esegui il programma che ti serve e la relativa interfaccia grafica verrà visualizzata sul client che si connette, per assurdo puoi eseguire l'intero ambiente DE.
Se la macchina client è linux non ti serve nulla di più, se il cient da cui ti connetti è Windows devi installare anche un server X, mobaXterm è un programma gratuito che fornisce sia un client SSH che un server X, Xming è un'altra valida alternativa.

Ritratto di Pipperss
Pipperss
(Junior)
Offline
Junior
Iscritto: 15/08/2014
Messaggi: 25

Ciao badroot, e grazie per la solerte risposta, Big Grin

Citazione:


quindi devi per forza prima fare il login sul server.

Ho aggirato il problema facendo fare il login automatico al mio utente, così il server vnc parte regolarmente; ho scoperto però che nel file /etc/lightdm/lightdm.conf c'è una sezione dedicata a VNC commentata di default e farò delle prove disabilitando il login automatico e decommentando la sezione relativa a VNC.

Citazione:


ci sono soluzioni di gran lunga migliori a VNC, io opterei per SSH e X11 forwarding in questo modo ti colleghi al server con SSH e poi esegui il programma che ti serve e la relativa interfaccia grafica verrà visualizzata sul client che si connette, per assurdo puoi eseguire l'intero ambiente DE.

In casa non ho nessuma macchina windows, cmq ti riferisci a una roba tipo ssh -X utente@ip_server per poi avviare l'applicazione da usare, vero ?
Ecco, l'avevo considerata, ma mi pare comodo anche un serverVNC, anche perchè non devo proprio collegarmi in questa maniera molto frequentemente al server di casa.
Cmq quel serverino dovrebbe servire anche a scopi didattici, in qualche serata che andrò a fare dalle mie parti.

Ciao e grazie,
pipperss

Ritratto di Pipperss
Pipperss
(Junior)
Offline
Junior
Iscritto: 15/08/2014
Messaggi: 25

Ecco qua il risultato della prova che avevo promesso

Citazione:


ho scoperto però che nel file /etc/lightdm/lightdm.conf c'è una sezione dedicata a VNC commentata di default e farò delle prove disabilitando il login automatico e decommentando la sezione relativa a VNC.

Ho disabilitato il login automatico dell'utente e in fondo ho attivato nella sezione [VNCServer] i parametri, tipo
enabled=true
port=5900
width=1000
height=600
depth=16

riavviato e il server VNC parte.
Con questo metodo quando avvio da locale il client VNC mi viene richiesto utente e password per loggarmi sul pc remoto, mentre prima no in quanto il server VNC partiva dopo il login utente.

Saaaluti,
pippersss