SAMBA, utente root, permessi fallati !!!!

15 risposte [Ultimo contenuto]
Ritratto di mayers81
mayers81
(Junior)
Offline
Junior
Iscritto: 18/12/2015
Messaggi: 24

Si è corretto la riga valid users nega l'accesso se non sei root a adm.

Domanda il sistema prova ad effettuare single sign on e ti restituisce errore

Oppure

il sistema prova ad effettuare single sign on e ti compare schermata con nome utente e password?

Il server ed il client sono nello stesso Workgroup?

il client prova ad accedere al server mezzo nome dell server \\server o mezzo ip \\192.168.X.X?

In merito all'ultima domanda verifica che l'ora del server sia corretta

Ritratto di itaTheSpeedGhost
itaTheSpeedGhost
(Junior)
Offline
Junior
Iscritto: 02/10/2015
Messaggi: 22

Intanto vi ringrazio per non esservi arresi Smile

Il client ed il server sono nello stesso Workgroup.

Il client (Un Windows) accedendo chiede id e pw, ora non più siccome ho memorizzato le credenziali in:
Windows->Pannello di controllo\Account utente e protezione famiglia\Gestione credenziali\
Come credenziali sto usando quelle di root, che risultano accettate siccome le altre condivisioni (share) funzionano.

Ho provato ad accedere sia tramite \\nome_server che \\ip_server

La data del server è corretta e pure quella del client.

Provo ad esprimere meglio il comportamento, una volta effettuato l'accesso al livello di \\nome_server oppure \\ip_server, vengono visualizzate tutte le varie share (sotto forma di cartella), tra cui "Radice".
Accendendo alla cartella "Radice" il comando viene preso positivamente, ed ho visuale di tutti i file e di tutte le cartelle al percorso "\" del server. Il problema risiede da qui in poi: anche essendo loggato come root, ho solo i permessi di creare nuovi file e cartelle, non posso ne leggere o modificare o eliminare file ed stessa cosa per le cartelle, posso solo creare nuovi file o cartelle, se provo anche solo a rinominarle salta fuori l'errore.
Descrivo l'errore al meglio che posso: a seconda di come e cosa provo ad aprire o modificare l'errore cambia (il cambiamento credo sia dovuto solo ad un cambio dell'interfaccia grafica che mi stampa l'errore) ad esempio:
1)accedo ad una cartella tramite "Explorer" e mi viene "Impossibile accedere" ecc ecc molto generico (in qualche risposta prima l'ho specificato)
2) accedo ad un file tramite "notepad", "Accesso negato"
3)rinomino o elimino un file o cartella "Per eseguire l'operazione è necessaria l'autorizzazione"

Non trovo una soluzione, non capisco dove sia la falla, siccome l'utente root deve avere qui permessi, non credo che si possano creare due utenti diversi con nomi identici neanche volendo, quindi l'utente root con cui loggo è il root vero e proprio.

Ripeto tutto ciò funzionava fin che non ho reinstallato a distanza di 3 mesi dalla prima installazione il sistema, secondo me è un cambiamento nel processo samba di debian.

Qualche idea?

Ritratto di mayers81
mayers81
(Junior)
Offline
Junior
Iscritto: 18/12/2015
Messaggi: 24

Usi samba 4 ???

Se crei un condivisa tipo in /home funziona senza problema?

Ritratto di itaTheSpeedGhost
itaTheSpeedGhost
(Junior)
Offline
Junior
Iscritto: 02/10/2015
Messaggi: 22

Esattamente, gli share in nuove cartelle funzionano ed ho appena creato uno share per la cartella /home/ e funziona perfettamente.

Si uso samba 4, confermato con il comando: smbstatus

Samba version 4.1.17-Debian
PID     Username      Group         Machine
-------------------------------------------------------------------
 
Service      pid     machine       Connected at
-------------------------------------------------------
 
No locked files

Ritratto di mayers81
mayers81
(Junior)
Offline
Junior
Iscritto: 18/12/2015
Messaggi: 24

Attivando il log di samba

https://wiki.samba.org/index.php/Client_specific_logging

ti da qualche info in più ?????

Cmq ho googolando ho visto che non sei l'unico che segnala questa cosa nella condivisione di root.

Alternativa Winscp

https://winscp.net/eng/download.php