Pidgin 2.4->2.6 su stable.

4 risposte [Ultimo contenuto]
Ritratto di Rinion
Rinion
(Junior)
Offline
Junior
Iscritto: 08/12/2008
Messaggi: 22

Salve.
Ho una versione Debian lenny stable e vorrei aggiornare pidgin da 2.4 a 2.6.
Ho seguito diverse guide tra cui:
web-zine anno 2009- Debianizzati.org

Riguarda il pinning che applicato a pidgin come spiegato non funziona!
Le mie domande sono:
1)E' possibile, dopo aver installato una versione stabile del sistema operativo debian, aggiornare o installare solo i software che ci interessano anche se questi fanno parte della testing o della unstable?
2)Se si può fare, facciamo l'esempio con pidgin il quale è un software che fa parte del pacchetto gnome?
Grazie a tutti.

Rino.

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Ciao, mi pare che la guida che hai seguito ti spieghi gia' qualcosa, poi, rispondendoti da solo, la parola chiave e' pinning...e anche in questo forum e' stato discusso parecchie volte l'argomento!

Ciao

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di francescodl
francescodl
(Junior)
Offline
Junior
Iscritto: 16/07/2007
Messaggi: 26

Secondo me, se usi una stable non conviene sporcarla con pacchetti di altre versioni. Se usi una stable è perchè, forse, cerchi la tranquillità alla novità assoluta. Comunque Debian, attraverso la sezione backports (lenny-backports), dà la possibilità di aggiornare, se previsti, alcuni pacchetti della versione stabile senza creare inutili casini. A questo indirizzo
http://packages.debian.org/lenny-backports/
ti trovi nella pagina degli aggiornamenti, o meglio dei backports, per Lenny. Questi pacchetti devono essere usati comunque con CAUTELA. Mi sembra che ci sia anche Pidgin ultima versione, oltre a tanti altri. Se nemmeno la sezione backport fà al caso tuo, allora sarà meglio che passi direttamente alla testing.

Ritratto di Rinion
Rinion
(Junior)
Offline
Junior
Iscritto: 08/12/2008
Messaggi: 22

Ciao.
Grazie per la risposta, ho risolto attraverso la soluzione backports (lenny-backports).
Era la soluzione che cercavo, dato che dopo aver configurato l'hardware e i programmi base che mi servono ho avuto la necessità di aggiornare solo pidgin a causa di una incompatibilità con il protocollo di msn risolta nella 2.6.
Per il pinning ho detto di aver letto varie guide ma non sono riuscito ad applicare il sistema a pidgin, forse non l'ho capito bene, e comunque è troppo complicato per un novellino!
Riguardo i backports ho seguito queste instruzioni:
http://www.backports.org/dokuwiki/doku.php?id=instructions
Ho aggiornato pidgin ed è andato a buon fine.
Grazie mille per l'aiuto.

Rino.

Ritratto di palmux
palmux
(Newbie)
Offline
Newbie
Iscritto: 20/01/2006
Messaggi: 4

Mi accodo all'orgomento perchè ho una domanda in tema. Ho insallato anche io Pidgin attraverso i backports e tutto funziona senza problemi, l'unica cosa che non riesco proprio a far funzionare, nonostate i plurimi tentativi, è la comunicazione audio (e il video) che nel sistema funzionano e sono perfettamente configurati. Ho cercato qua e la in google, ma la quasi totalità degli esempi sono riferiti a Ubuntu.  Per inciso su una 9.04 riesco a far funzionare senza problemi anche la comunicazione audio e video, ovvio utilizzando il protocollo appropriato (gtalk).
Avete avuto un'esperienza similare e/o siete riusciti a "telefonare" o "videotelefonare" (notate le virgolette) con Pidgin su Debian (Lenny)?
Spero di essermi spiegato e per ora vi saluto.
Palmux