non riesco ad installare gdebi

13 risposte [Ultimo contenuto]
Ritratto di malordi
malordi
(Junior)
Offline
Junior
Iscritto: 01/01/2017
Messaggi: 16

Salve a tutti,
premetto che sono poco pratico del mondo linux,però mi piacerebbe staccarmi del tutto da windows (ci sto pensando da tempo), per iniziare con la migrazione da win ho iniziato con ubuntu 12.04, però non mi ha soddisfatto, l'UI unity non mi piace. Poi ho scoperto che ubuntu è una derivata di Debian, così ho deciso di provare con Debian.
Ho una macchina PPC (iBook G4), e dato che c'è anche una versione per PPC ho deciso di installare la distro.
Ho scaricatol'immagine .iso (dal sito ufficiale " debian-8.6.0-powerpc-DVD-1.iso") e poi ho installato il sistema operativo sul mio iBook.
A parte qualche difficoltà ci sono riuscito ad installare Debian 8 con l'interfaccia MATE e XFCE, (credo che la mia maccina non gradisca GNOME 3 in quanto non partiva e mi dava errore irreversibile), ovviamente adesso manca qualche driver per far funzionare la mia macchina per bene, facendo varie ricerche sono riuscito a individuare il corretto firware per la mia scheda wifi "Broadcom Chip 4318" e trovo anche le istruzioni per installare

Citazione:

sudo apt-get install firmware-b43-installer

e scopro che da terminale non lo trovo.
Aggiorno la lista dei repository /etc/apt/sources.list:

all'inizio leggo "L'interfaccia gtk ha bisogno di python-gtk2 e python-glade2"
quindi provo ad installare questi pacchetti, ma mi rendo conto che non si procede con l'installazione e mi dava praticamente gli stessi errori: /var/cache/apt/archives/..........

digito apt-get autoclean, riprovo... niente
a questo punto mi arrendo, prendo atto della mia poco conoscenza del mondo linux e chiedo aiuto a chi sicuramente ne capisce qualcosa di più....
scusate la "lungaggine" però ho ritenuto opportuno darvi quante più informazioni possibili, anzi se mi illustrate come darvene di più ancora meglio.
Grazie e buon anno a TUTTI

EDIT
credo che mancano alcune citazioni degli errori che ho messo.
Come risolvo?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Ciao,
hai scritto un sacco di cose ma poi alla fine non dici cosa hai fatto con il sources.list, sicuro di aver aggiunto le voci contrib e non-free ?
Un consiglio per il futuro, riporta gli errori come esattamente appaiono a terminale in modo che sia chiaro a tutti l'errore riscontrato.

Ritratto di malordi
malordi
(Junior)
Offline
Junior
Iscritto: 01/01/2017
Messaggi: 16

Salve, si in effetti manca tutta la parte del mio post dove indicavo la sources.list e gli errori che mi dava il terminale, e il perchè di GDEBI.

Allora, la sources.list:

deb http://ftp.de.debian.org/debian/ jessie main
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://httpredir.debian.org/debian/ jessie main
deb http://ftp.it.debian.org/debian/ jessie non-free e contrib main
# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official powerpc DVD Binary-1 20$
deb http://ftp.it.debian.org/debian/ jessie-updates non-free contrib main
deb-src http://ftp.it.debian.org/debian/ jessie-updates main
deb http://ftp.deb-multimedia.org jessie main non-free

dopo aver aggiornato la sources.list scopro che ancora non trova il pacchetto del firmware della scheda wifi.
A questo punto faccio delle ricerche su internet e riesco a scovare i pacchetti .deb, scarico i file e con il terminale mi porto sulla posizione dei pacchetti scaricati e do il comando:
sudo dpkg -i firmware-b43-installer_019-2_all.deb

con il seguente errore:
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio firmware-b43-installer_019-2_all.deb (--install):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
Si sono verificati degli errori nell'elaborazione:
firmware-b43-installer_019-2_all.deb

Credo che i pacchetti sono danneggiati ma voglio provare lo stesso con GDEBI,

apro Synaptic e cerco il pacchetto di gdebi, seleziono i pacchetti necessari e accetto la modifica,
scopro che la procedura non va a buon fine,
di seguito gli errori che mi da il terminale:

(synaptic:2647): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
L'interfaccia gtk ha bisogno di python-gtk2 e python-glade2.
Non è possibile trovare questi moduli; verrà usata pager.
L'errore è: No module named glade
Estrazione dei template dai pacchetti: 100%
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libunistring0_0.9.3-5.2+b1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libgettextpo0_0.19.3-2_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/autopoint_0.19.3-2_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/binutils_2.25-5_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/diffstat_1.58-1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/python3-apt_0.9.3.12_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/python3-pkg-resources_5.5.1-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/python3-chardet_2.3.0-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/python3-six_1.8.0-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/python3-debian_0.1.27_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/gdebi-core_0.9.5.5+nmu1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/gir1.2-vte-2.90_1%3a0.36.3-1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/gksu_2.0.2-9_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/gdebi_0.9.5.5+nmu1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/gettext_0.19.3-2_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/make_4.0-8.1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/hardening-includes_2.6_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/intltool-debian_0.35.0+20060710.1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libapt-pkg-perl_0.1.29+b2_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libarchive-zip-perl_1.39-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libasprintf-dev_0.19.3-2_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libclone-perl_0.37-1+b1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libdigest-hmac-perl_1.03+dfsg-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libdpkg-perl_1.17.27_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libsocket6-perl_0.25-1+b1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libio-socket-inet6-perl_2.72-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnet-ip-perl_1.26-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnet-dns-perl_0.81-2+deb8u1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnet-domain-tld-perl_1.72-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libemail-valid-perl_1.195-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libfile-fcntllock-perl_0.22-1+b1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libgettextpo-dev_0.19.3-2_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libio-pty-perl_1%3a1.08-1+b4_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libipc-run-perl_0.92-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/liblist-moreutils-perl_0.33-2+b1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libperlio-gzip-perl_0.18-3+b1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libtext-levenshtein-perl_0.11-1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/patchutils_0.3.3-1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/t1utils_1.38-4_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/lintian_2.5.30+deb8u4_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
Si sono verificati degli errori nell'elaborazione:
/var/cache/apt/archives/libunistring0_0.9.3-5.2+b1_powerpc.deb
/var/cache/apt/archives/libgettextpo0_0.19.3-2_powerpc.deb
/var/cache/apt/archives/autopoint_0.19.3-2_all.deb
/var/cache/apt/archives/binutils_2.25-5_powerpc.deb
/var/cache/apt/archives/diffstat_1.58-1_powerpc.deb
/var/cache/apt/archives/python3-apt_0.9.3.12_powerpc.deb
/var/cache/apt/archives/python3-pkg-resources_5.5.1-1_all.deb
/var/cache/apt/archives/python3-chardet_2.3.0-1_all.deb
/var/cache/apt/archives/python3-six_1.8.0-1_all.deb
/var/cache/apt/archives/python3-debian_0.1.27_all.deb
/var/cache/apt/archives/gdebi-core_0.9.5.5+nmu1_all.deb
/var/cache/apt/archives/gir1.2-vte-2.90_1%3a0.36.3-1_powerpc.deb
/var/cache/apt/archives/gksu_2.0.2-9_powerpc.deb
/var/cache/apt/archives/gdebi_0.9.5.5+nmu1_all.deb
/var/cache/apt/archives/gettext_0.19.3-2_powerpc.deb
/var/cache/apt/archives/make_4.0-8.1_powerpc.deb
/var/cache/apt/archives/hardening-includes_2.6_all.deb
/var/cache/apt/archives/intltool-debian_0.35.0+20060710.1_all.deb
/var/cache/apt/archives/libapt-pkg-perl_0.1.29+b2_powerpc.deb
/var/cache/apt/archives/libarchive-zip-perl_1.39-1_all.deb
/var/cache/apt/archives/libasprintf-dev_0.19.3-2_powerpc.deb
/var/cache/apt/archives/libclone-perl_0.37-1+b1_powerpc.deb
/var/cache/apt/archives/libdigest-hmac-perl_1.03+dfsg-1_all.deb
/var/cache/apt/archives/libdpkg-perl_1.17.27_all.deb
/var/cache/apt/archives/libsocket6-perl_0.25-1+b1_powerpc.deb
/var/cache/apt/archives/libio-socket-inet6-perl_2.72-1_all.deb
/var/cache/apt/archives/libnet-ip-perl_1.26-1_all.deb
/var/cache/apt/archives/libnet-dns-perl_0.81-2+deb8u1_powerpc.deb
/var/cache/apt/archives/libnet-domain-tld-perl_1.72-1_all.deb
/var/cache/apt/archives/libemail-valid-perl_1.195-1_all.deb
/var/cache/apt/archives/libfile-fcntllock-perl_0.22-1+b1_powerpc.deb
/var/cache/apt/archives/libgettextpo-dev_0.19.3-2_powerpc.deb
/var/cache/apt/archives/libio-pty-perl_1%3a1.08-1+b4_powerpc.deb
/var/cache/apt/archives/libipc-run-perl_0.92-1_all.deb
/var/cache/apt/archives/liblist-moreutils-perl_0.33-2+b1_powerpc.deb
/var/cache/apt/archives/libperlio-gzip-perl_0.18-3+b1_powerpc.deb
/var/cache/apt/archives/libtext-levenshtein-perl_0.11-1_all.deb
/var/cache/apt/archives/patchutils_0.3.3-1_powerpc.deb
/var/cache/apt/archives/t1utils_1.38-4_powerpc.deb
/var/cache/apt/archives/lintian_2.5.30+deb8u4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Installazione di un pacchetto non riuscita. Tentativo di ripristino:

Vedo che all'inizio c'è scritto "(synaptic:2647): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
L'interfaccia gtk ha bisogno di python-gtk2 e python-glade2.
Non è possibile trovare questi moduli; verrà usata pager.
L'errore è: No module named glade
"

quindi provo ad installare questi pacchetti (sempre con Synaptic), ma mi rendo conto che non si procede con l'installazione e mi dava praticamente gli stessi errori: /var/cache/apt/archives/..........
praticamente errori di cache credo,

digito apt-get autoclean, riprovo... niente
Ecco la procedura che ho seguito, spero che tu mi illustri i passaggi che sbaglio
Ciao e grazie

P.S. la citazione si inserisce con le virgolette (") che sono in alto al fianco delle faccine?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Per prima cosa sistema imposta correttamente la sources.list che nel tuo caso contiene inutili doppioni.

deb http://ftp.it.debian.org/debian/ jessie main contrib non-free
deb http://ftp.it.debian.org/debian/ jessie-updates main contrib  non-free 
deb http://security.debian.org/debian-security jessie/updates main contrib non-free
deb http://ftp.deb-multimedia.org jessie main non-free

a questo da terminale e come utente root esegui :

apt-get clean
apt-get update
apt-get upgrade
apt-get dist-upgrade

riporta eventuali messaggi di errore, se non ce ne sono prova a installare, sempre da root, il pacchetto gdebi con :

apt-get install gdebi

e vediamo cosa viene fuori.

Ritratto di malordi
malordi
(Junior)
Offline
Junior
Iscritto: 01/01/2017
Messaggi: 16

Ciao ho aggiornato la lista,
digitato
apt-get clean
apt-get update
apt-get upgrate

a questo punto l'errore

dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
Traceback (most recent call last):
File "/usr/bin/apt-listchanges", line 250, in
main()
File "/usr/bin/apt-listchanges", line 108, in main
pkg = DebianFiles.Package(deb)
File "/usr/share/apt-listchanges/DebianFiles.py", line 134, in __init__
self.binary = pkgdata.Package
AttributeError: ControlStanza instance has no attribute 'Package'
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libaacs0_0.8.1-dmo1+deb8u1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libavutil54_10%3a2.6.9-dmo1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libavresample2_10%3a2.6.9-dmo1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libbasicusageenvironment0_2%3a2015.03.19-dmo1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libbluray1_2%3a0.7.0-dmo1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libdca0_0.0.5-dmo2+deb8u1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libdvbpsi9_1.2.0-dmo1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libebml4_1.3.1-dmo2_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libgd3_2.1.0-5+deb8u8_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libmatroska6_1.4.2-dmo3_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libmp3lame0_1%3a3.99.5-dmo4_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libswscale3_10%3a2.6.9-dmo1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libxvidcore4_3%3a1.3.3-dmo1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/librtmp1_2%3a2.4~20150315.gita107cef9b-dmo1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/ffmpegthumbnailer_2.0.8-dmo7_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/gstreamer1.0-libav_1%3a1.4.5-dmo1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libvlccore8_1%3a2.2.1-dmo3+deb8u1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/vlc-data_1%3a2.2.1-dmo3+deb8u1_all.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
dpkg-deb: errore: il sottoprocesso tar è stato terminato dal segnale (Errore di bus)
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libvlc5_1%3a2.2.1-dmo3+deb8u1_powerpc.deb (--unpack):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
Si sono verificati degli errori nell'elaborazione:
/var/cache/apt/archives/libaacs0_0.8.1-dmo1+deb8u1_powerpc.deb
/var/cache/apt/archives/libavutil54_10%3a2.6.9-dmo1_powerpc.deb
/var/cache/apt/archives/libavresample2_10%3a2.6.9-dmo1_powerpc.deb
/var/cache/apt/archives/libbasicusageenvironment0_2%3a2015.03.19-dmo1_powerpc.deb
/var/cache/apt/archives/libbluray1_2%3a0.7.0-dmo1_powerpc.deb
/var/cache/apt/archives/libdca0_0.0.5-dmo2+deb8u1_powerpc.deb
/var/cache/apt/archives/libdvbpsi9_1.2.0-dmo1_powerpc.deb
/var/cache/apt/archives/libebml4_1.3.1-dmo2_powerpc.deb
/var/cache/apt/archives/libgd3_2.1.0-5+deb8u8_powerpc.deb
/var/cache/apt/archives/libmatroska6_1.4.2-dmo3_powerpc.deb
/var/cache/apt/archives/libmp3lame0_1%3a3.99.5-dmo4_powerpc.deb
/var/cache/apt/archives/libswscale3_10%3a2.6.9-dmo1_powerpc.deb
/var/cache/apt/archives/libxvidcore4_3%3a1.3.3-dmo1_powerpc.deb
/var/cache/apt/archives/librtmp1_2%3a2.4~20150315.gita107cef9b-dmo1_powerpc.deb
/var/cache/apt/archives/ffmpegthumbnailer_2.0.8-dmo7_powerpc.deb
/var/cache/apt/archives/gstreamer1.0-libav_1%3a1.4.5-dmo1_powerpc.deb
/var/cache/apt/archives/libvlccore8_1%3a2.2.1-dmo3+deb8u1_powerpc.deb
/var/cache/apt/archives/vlc-data_1%3a2.2.1-dmo3+deb8u1_all.deb
/var/cache/apt/archives/libvlc5_1%3a2.2.1-dmo3+deb8u1_powerpc.debE: Sub-process /usr/bin/dpkg returned an error code (1)

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Fammi capire, dopo aver eseguito il clean la cartella /var/cache/apt/archives/ risulta essere vuota ?

Il comando tar è installato ?

tar --help

prova anche :

apt-get install -f

Ritratto di malordi
malordi
(Junior)
Offline
Junior
Iscritto: 01/01/2017
Messaggi: 16

tar --help

Errore di bus

apt-get install -f

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Il seguente pacchetto è stato installato automaticamente e non è più richiesto:
librecode0
Usare "apt-get autoremove" per rimuoverlo.
0 aggiornati, 0 installati, 0 da rimuovere e 29 non aggiornati.

apt-get clean
non dice nulla

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

malordi ha scritto:

tar --help

Errore di bus

Questo no buono .... ora non so se questa tua macchina sia fresca fresca di installazione o meno ma sembra che alcuni file siano "rovinati" e forse sarebbe meglio procedere con una reinstallazione pulita.

Giusto per curiosità riporta l'output di :

file /bin/tar
ldd /bin/tar

Ritratto di malordi
malordi
(Junior)
Offline
Junior
Iscritto: 01/01/2017
Messaggi: 16

Ho praticamente installato il SO l'altro ieri

file/bin/tar
/bin/tar: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV), dynamically linked, interpreter /lib/ld.so.1, for GNU/Linux 2.6.32, BuildID[sha1]=39ebe9905400e6f413d4d05d269934751a8ef4a7, stripped

ldd /bin/tar
linux-vdso32.so.1 (0x00100000)
libacl.so.1 => /lib/powerpc-linux-gnu/libacl.so.1 (0x0ffd7000)
libselinux.so.1 => /lib/powerpc-linux-gnu/libselinux.so.1 (0x0ff90000)
libc.so.6 => /lib/powerpc-linux-gnu/libc.so.6 (0x0fdee000)
libattr.so.1 => /lib/powerpc-linux-gnu/libattr.so.1 (0x0fdc8000)
libpcre.so.3 => /lib/powerpc-linux-gnu/libpcre.so.3 (0x0fd43000)
libdl.so.2 => /lib/powerpc-linux-gnu/libdl.so.2 (0x0fd1f000)
/lib/ld.so.1 (0x2069f000)
libpthread.so.0 => /lib/powerpc-linux-gnu/libpthread.so.0 (0x0fce4000)

Se faccio apt-get autoremove?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Guarda io proverei a reinstallare tutto .... volendo puoi vedere se dal CD che hai usato per l'installazione puoi copiarti il programma tar e vedere se il problema è solo quello, cosa sulla quale non posso essere certo al 100%.

Magari prima controlla che la ISO che hai scaricato e masterizzato abbia l'md5 corretto.md5

Ritratto di malordi
malordi
(Junior)
Offline
Junior
Iscritto: 01/01/2017
Messaggi: 16

badroot ha scritto:

Magari prima controlla che la ISO che hai scaricato e masterizzato abbia l'md5 corretto.md5

scusa come devo fare?

ho inserito il dvd di installazione e ho trovato un file md5sum.txt

come faccio a copiare tar?
rifare l'installazione? sai son un bel po di giorni che reinstallo perchè c'era qualcosache non andava,
wheezy, mint 11(il quale andava), lubuntu,
farlo di nuovo mi scoccia un po