Mancata installazione forzata dei pacchetti

2 risposte [Ultimo contenuto]
Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1097

Salve,
sto nella seguente situazione. Ci sono alcuni pacchetti che non vengono installati da apt perché romperebbero delle dipendenze neppure facendo l'installazione forzata.
COme ci si comporta in questi casi?

# apt --fix-broken install -y
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libdns169 libisc166 linux-headers-4.14.0-3-amd64 linux-headers-4.14.0-3-common
Usare "apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  gstreamer1.0-gl gstreamer1.0-plugins-base libgstreamer-gl1.0-0
I seguenti pacchetti NUOVI saranno installati:
  gstreamer1.0-gl libgstreamer-gl1.0-0
I seguenti pacchetti saranno aggiornati:
  gstreamer1.0-plugins-base
1 aggiornati, 2 installati, 0 da rimuovere e 199 non aggiornati.
322 non completamente installati o rimossi.
È necessario scaricare 0 B/4.392 kB di archivi.
Dopo quest'operazione, verranno occupati 3.452 kB di spazio su disco.
apt-listchanges: Lettura dei changelog...
(Lettura del database... 474288 file e directory attualmente installati.)
Preparativi per estrarre .../libgstreamer-gl1.0-0_1.14.0-2_amd64.deb...
Estrazione di libgstreamer-gl1.0-0:amd64 (1.14.0-2)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.0-2_amd64.deb (--unpack):
 tentata sovrascrittura di "/usr/lib/x86_64-linux-gnu/libgstgl-1.0.so.0" presente anche nel pacchetto libgstreamer-plugins-bad1.0-0:amd64 1:1.12.2-dmo1
Preparativi per estrarre .../gstreamer1.0-plugins-base_1.14.0-2_amd64.deb...
Estrazione di gstreamer1.0-plugins-base:amd64 (1.14.0-2) su (1.12.4-1)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/gstreamer1.0-plugins-base_1.14.0-2_amd64.deb (--unpack):
 tentata sovrascrittura di "/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaudiomixer.so" presente anche nel pacchetto gstreamer1.0-plugins-bad:amd64 1:1.12.2-dmo1
dpkg-deb: errore: paste subprocess was killed by signal (Pipe interrotta)
Preparativi per estrarre .../gstreamer1.0-gl_1.14.0-2_amd64.deb...
Estrazione di gstreamer1.0-gl:amd64 (1.14.0-2)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/gstreamer1.0-gl_1.14.0-2_amd64.deb (--unpack):
 tentata sovrascrittura di "/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstopengl.so" presente anche nel pacchetto gstreamer1.0-plugins-bad:amd64 1:1.12.2-dmo1
dpkg-deb: errore: paste subprocess was killed by signal (Pipe interrotta)
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.0-2_amd64.deb
 /var/cache/apt/archives/gstreamer1.0-plugins-base_1.14.0-2_amd64.deb
 /var/cache/apt/archives/gstreamer1.0-gl_1.14.0-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 26/02/2018
Messaggi: 55

io rimuoverei gstreamer1.0-plugins-bad, aggiornerei e reinstallerei gstreamer1.0-plugins-bad

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1097

Non sono stato in grado di reinstallare i pacchetti rimossi che, alla fine, si sono rivelati i seguenti

# apt remove --purge libgstreamer-plugins-bad1.0-0 gir1.2-gst-plugins-base-1.0 gstreamer1.0-plugins* gstreamer1.0-plugins-base:i386 gir1.2-clutter-gst-2.0 libevview3-3 gir1.2-evince-3.0

ma fino a quando non avrò problemi, andrò avanti.
Grazie

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde