java per tutti gli utenti?

11 risposte [Ultimo contenuto]
Ritratto di darkstar
darkstar
(Junior)
Offline
Junior
Iscritto: 09/10/2007
Messaggi: 41

Salve ragazzi,
scrivo poco su questo grande forum...perchè la etch è così grande e stabile che davvero mi dà rari problemini Big Grin
davvero una gran distro!!!

il mio problemino attuale è che se vado su un sito in cui c'è un applet java da utilizzare per (es.) giocare on-line...l'applet non va!
se apro invece ff da root...invece tutto funziona tranquillamente, come faccio a sistemare? credo sia una questione di permessi...

saluti a tutti Wink

Ritratto di kalos
kalos
(Collaboratore)
Offline
Collaboratore
Iscritto: 26/01/2005
Messaggi: 710

hai installato
sun-java6- plugin ?

If you haven't tried Debian lately, this would be a good time.

deb lenny/sid
linux user 384443 http://counter.li.org/
linux nelle scuole, firma la petizione

Ritratto di darkstar
darkstar
(Junior)
Offline
Junior
Iscritto: 09/10/2007
Messaggi: 41

sì, ho controllato ed è regolarmente installato...penso che sia un problema di permessi perchè con l'utente comune non va mentre da root funziona....
Thinking

Ritratto di sette70
sette70
(Geek)
Offline
Geek
Iscritto: 14/01/2005
Messaggi: 116

Ciao,anche io ho avuto un problema simile,in effetti dipendeva dai permessi mi si era tolto il permesso di lettura dalla directory /usr/lib/mozilla.Controlla se anche tu hai lo stesso problema.

Ritratto di darkstar
darkstar
(Junior)
Offline
Junior
Iscritto: 09/10/2007
Messaggi: 41

allora ho controllato ma i permessi di lettura a /usr/lib/mozilla sono attivi, per ora lancio ff da root se devo usare un applet java, ma se qualcuno ha qualche idea per risolvere è ben accetta Wink

Ritratto di gabry
gabry
(Monster)
Offline
Monster
Iscritto: 29/10/2006
Messaggi: 395

prova a seguire questa guida...è un pò vecchiotta, ma a parte le versioni del java dovrebbe funzionare correttamente.

ciao ciao

"Non e' la legge che decide cosa e' giusto e cosa e' sbagliato"
R. Stallman

Ritratto di ferretti75
ferretti75
(Guru)
Offline
Guru
Iscritto: 08/07/2005
Messaggi: 526

Ciao,

scusa la domanda scema ma non capisco come lanci ff ... fai sudo firefox, su - c "firefox" oppure ti logghi come root ?

Hai controllato che in ~/.mozilla/plugins o in /usr/lib/mozilla-firefox/plugins ci sia il plugin ( il link ) ?

facci sapere

Marco

apt-get -a beer

Ritratto di darkstar
darkstar
(Junior)
Offline
Junior
Iscritto: 09/10/2007
Messaggi: 41

divento root e lancio ff e poi ho controllato la dir /usr/lib/mozilla-firefox/plugins e i link ci sono:
libjavaplugins.so libflashplayer.so libvlcplugin.so
quindi sembra tutto a posto ma da utente non funziona Thinking
forse potrei provare ad aggiornare il pacchetto java? installando l'ultima versione, non saprei......

saluti a tutti Big Grin

Ritratto di ferretti75
ferretti75
(Guru)
Offline
Guru
Iscritto: 08/07/2005
Messaggi: 526

ok.

quindi hai il plugin nella tua home . i permessi ?? ( ls -l )

ciao

Marco

apt-get -a beer

Ritratto di darkstar
darkstar
(Junior)
Offline
Junior
Iscritto: 09/10/2007
Messaggi: 41

allora...ricapitoliamo, nella dir /usr/lib/mozilla-firefox/plugins i files ci sono però, controllando meglio, libjavaplugins.so è linkato a /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so mentre nella mia home in ./mozilla/plugins in realtà c'è solo il file libflasher.so....quindi penso che il plugin per la home in realtà sia mancante? che dici creo il link per la mia home:

ln -s /usr/lib/mozilla-firefox/plugins/libjavaplugins.so ./mozilla/plugins/libjavaplugins.so

saluti e grazie per l'aiuto Big Grin

Ritratto di Rinion
Rinion
(Junior)
Offline
Junior
Iscritto: 08/12/2008
Messaggi: 22

Salve.
Ho installato l'ultima versione di java scaricata dal sito ufficiale ed ho seguito tutte le istruzioni.
http://java.com/it/download/help/5000010500.xml#selfextracting
Ho eseguito il test come descritto nella guida con iceweasel ma non è andato a buon fine.
dopo che ho creato il collegamento al file "/usr/java/libjavaplugin_oji.so" (sempre come descritto nella guida)
sia nella cartella /usr/lib/mozilla/plugins e sia nella cartella
/usr/lib/iceweasel/plugins del plugin, sono andato in queste cartelle ed ho visto che sul file del collegamento ci sono due piccole icone una di divieto ed un lucchetto, ed andando nelle proprietà del file ho notato che c'è scritto "Tipo:Collegamento(interrotto)".
Spero che ci sia qualcuno che mi possa aiutare!