Installazione xrdp Debian GNU/Linux 8 (jessie)

3 risposte [Ultimo contenuto]
Ritratto di condor_uk
condor_uk
(Newbie)
Offline
Newbie
Iscritto: 15/03/2015
Messaggi: 5

Un saluto a tutta la community,
su una vps ho installato questa versione di debian:

PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
NAME="Debian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=debian
HOME_URL="http://www.debian.org/"
SUPPORT_URL="http://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

avendo esigenza di collegarmi alla macchina in tramite desktop remoto, volevo installare xrdp, ma
all'atto dell'installazione ricevo questo errore:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 vdpau-va-driver:i386 : Depends: libvdpau1:i386 (>= 0.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Mi dareste una mano, inutile dire che sono nuovo del mondo unix/linux

Grazie in anticipo Smile

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1254

Impartisci il comando indicato:
apt-get -f install

Ritratto di condor_uk
condor_uk
(Newbie)
Offline
Newbie
Iscritto: 15/03/2015
Messaggi: 5

Ciao,
nel ringraziarti per la risposta, ti comunico che avevo provato il comando da te gentilmente suggerito,
ma mi viene restituito questo errore.

apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libvdpau1:i386
Suggested packages:
  nvidia-vdpau-driver:i386 vdpau-driver:i386
The following NEW packages will be installed:
  libvdpau1:i386
0 upgraded, 1 newly installed, 0 to remove and 58 not upgraded.
2 not fully installed or removed.
Need to get 0 B/32.3 kB of archives.
After this operation, 89.1 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 88282 files and directories currently installed.)
Preparing to unpack .../libvdpau1_0.8-3+deb8u2_i386.deb ...
Unpacking libvdpau1:i386 (0.8-3+deb8u2) ...
dpkg: error processing archive /var/cache/apt/archives/libvdpau1_0.8-3+deb8u2_i3          86.deb (--unpack):
 trying to overwrite shared '/etc/vdpau_wrapper.cfg', which is different from ot          her instances of package libvdpau1:i386
Errors were encountered while processing:
 /var/cache/apt/archives/libvdpau1_0.8-3+deb8u2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1254

Dal log che hai inviato nel precedente messaggio, risulta:

dpkg: error processing archive /var/cache/apt/archives/libvdpau1_0.8-3+deb8u2_i3          86.deb (--unpack):
 trying to overwrite shared '/etc/vdpau_wrapper.cfg', which is different from ot          her instances of package libvdpau1:i386

Il pacchetto non viene installato in quanto sovrascrive il file /etc/vdpau_wrapper.cfg che sembrerebbe essere condiviso tra più pacchetti (nota: in Debian è fornito solo dal pacchetto libvdpau1).

Per superare questo errore, dovresti poter impartire i seguenti comandi:

mv /etc/vdpau_wrapper.cfg /etc/vdpau_wrapper.cfg.old
apt-get -f install