installazione Wine

15 risposte [Ultimo contenuto]
Ritratto di gianliuc
gianliuc
(Geek)
Offline
Geek
Iscritto: 06/04/2014
Messaggi: 64

un saluto a tutti.....

devo dire che non riesco a settare wine con debian jessie...
ho installato tutti i pacchetti per jessie hò sistemato le dipendenze ma non si visualizza sul menù l'icona di wine mi compare solo q4wine.
Non riesco a capire. Qualcuno può aiutarmi ad installare wine?
ringrazio in anticipo.

Ritratto di apofis
apofis
(Monster)
Offline
Monster
Iscritto: 19/09/2007
Messaggi: 309

Ciao,
purtroppo questo non è un forum di stregoni ed indovini.
Capisci che se scrivi quello che scrivi nessuno può aiutarti?

Ad ogni modo ti riassumo come si apre un 3d:

  1. Spiega COSA hai fatto.
  2. MOSTRA i risultato delle tue azioni.
  3. Chedi il tipo di aiuto DESIDERATO.
C'è almeno un punto nel tuo precedente post? No.
A presto

I@ legge Apo-genetica: chini nascia tunnu un ci mora quatratu.
II@ legge Apo-genetica: munnu e munnu un s'incontranu mai, ma cristiani e cristiani sì
III@ legge Apo-genetica: si vidi nu ghiegghiu e nu lupu, ammazza 'u ghiegghiu!

Ritratto di lollix01
lollix01
(Monster)
Offline
Monster
Iscritto: 22/02/2014
Messaggi: 411

Io invece non riesco ad installarlo:
Faccio:

sudo apt-get install wine

E mi dice che devo mettere il multiarch allora dò:
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install wine-bin:i386

E come output mi dà:
 wine-bin:i386 : Depends: libc6:i386 (>= 2.4) but it is not going to be installed
                 Depends: libwine-bin:i386 (= 1.4.1-4) but it is not going to be installed

Devo per forza aspettare che risolvano questi problemi? O devo risolverli Io pacchettizzandomi le dipendenze?
Come faccio ad installare wine?
Ho una Debian Wheezy (Stable) Amd64, su un PC x86_64.
Ciao! Smile

We are MicroSoft. You will be assimilated. Resistance is futile.
-- Attributed to B.G., Gill Bates

Ritratto di apofis
apofis
(Monster)
Offline
Monster
Iscritto: 19/09/2007
Messaggi: 309

lollix01 ha scritto:

Io invece non riesco ad installarlo:
Faccio:

sudo apt-get install wine


Mi fai vedere cosa ti dice dopo questo comando??
lollix01 ha scritto:


E come output mi dà:

 wine-bin:i386 : Depends: libc6:i386 (>= 2.4) but it is not going to be installed
                 Depends: libwine-bin:i386 (= 1.4.1-4) but it is not going to be installed

Devo per forza aspettare che risolvano questi problemi? O devo risolverli Io pacchettizzandomi le dipendenze?


Devi avere qualcosa tu di sbagliato (repo apt not conventional??), per cui presumo che tu stia installando wine non dai repo ufficiali.
Le dipendenze che ho sul mio os:
Package: wine-bin:i386
Versions: 
1.4.1-4 (/var/lib/apt/lists/debian.fastweb.it_debian_dists_stable_main_binary-i386_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/debian.fastweb.it_debian_dists_stable_main_binary-i386_Packages
                  MD5: f09d09aa11405aafb5cd4a5d18f9336c
 Description Language: en
                 File: /var/lib/apt/lists/debian.fastweb.it_debian_dists_stable_main_i18n_Translation-en
                  MD5: f09d09aa11405aafb5cd4a5d18f9336c
 Description Language: it
                 File: /var/lib/apt/lists/debian.fastweb.it_debian_dists_stable_main_i18n_Translation-it
                  MD5: f09d09aa11405aafb5cd4a5d18f9336c
 
 
Reverse Depends: 
  q4wine:i386,wine-bin:i386
  wine:i386,wine-bin:i386 1.4.1-4
  libwine-bin:i386,wine-bin:i386 1.4-4
  q4wine:i386,wine-bin:i386
  lmms:i386,wine-bin:i386
  wine64-bin,wine-bin:i386
Dependencies: 
1.4.1-4 - debconf:i386 (18 0.5) debconf-2.0:i386 (0 (null)) libc6:i386 (2 2.4) libwine-bin:i386 (5 1.4.1-4) x11-utils:i386 (16 (null)) xbase-clients:i386 (18 4.0) xcontrib:i386 (0 (null)) libwine-gecko-1.4:i386 (0 (null)) libwine-print:i386 (0 (null)) libwine-gl:i386 (0 (null)) binfmt-support (3 1.1.2) binfmt-support:i386 (3 1.1.2) wine64-bin (0 (null)) wine64-bin:i386 (0 (null)) libwine (3 0.0.20010216) libwine:i386 (3 0.0.20010216) wine (3 0.9.35) wine:i386 (3 0.9.35) wine-gecko-1.0.0 (0 (null)) wine-gecko-1.0.0:i386 (0 (null)) wine-utils (3 1.1.25-1) wine-utils:i386 (3 1.1.25-1) 
Provides: 
1.4.1-4 - wine-bin 

Nota che dice libc6:i386 (2 2.4), ma se vado a vedere quella che risulta installata è:
libc6:i386:
  Installed: 2.13-38+deb7u1
  Candidate: 2.13-38+deb7u1
  Version table:
 *** 2.13-38+deb7u1 0
        500 http://debian.fastweb.it/debian/ stable/main i386 Packages
        100 /var/lib/dpkg/status

A questo punto posta il tuo source.list ed il contenuto della dir /etc/apt/source.list.d/ così vediamo perchè ti forza quella versione.

[OT]
Io ho dovuto installarlo per via di playonlinux Wink Usa wine, ma è più amichevole:

wget -q "http://deb.playonlinux.com/public.gpg" -O- | apt-key add -
wget http://deb.playonlinux.com/playonlinux_wheezy.list -O /etc/apt/sources.list.d/playonlinux.list
apt-get update
apt-get purge wine --remove
apt-get install wine
apt-get install playonlinux

[/OT]

I@ legge Apo-genetica: chini nascia tunnu un ci mora quatratu.
II@ legge Apo-genetica: munnu e munnu un s'incontranu mai, ma cristiani e cristiani sì
III@ legge Apo-genetica: si vidi nu ghiegghiu e nu lupu, ammazza 'u ghiegghiu!

Ritratto di lollix01
lollix01
(Monster)
Offline
Monster
Iscritto: 22/02/2014
Messaggi: 411

sudo ls -a /etc/apt/sources.list.d

Vuota come il mio Portafoglio! Wink
#                                                                                                                                                                                               
 
# deb cdrom:[Debian GNU/Linux 7.4.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140208-13:45]/ wheezy main                                                                                     
 
# deb cdrom:[Debian GNU/Linux 7.4.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140208-13:45]/ wheezy main                                                                                     
 
# Line commented out by installer because it failed to verify:                                                                                                                                  
#deb http://security.debian.org/ wheezy/updates main                                                                                                                                            
# Line commented out by installer because failed to verify                                                                                                                                 
# deb-src http://security.debian.org/ wheezy/updates main
 
# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
 
# MY Local Repository!!!
deb http://lollix01-pc/debian/ binary/
deb-src http://lollix01-pc/debian/ source/
 
# Repository for Packages Related at "Wheezy"
deb http://http.debian.net/debian stable main
deb-src http://http.debian.net/debian stable main 
 
# Reccomended Packages Updates for "Wheezy"
deb http://http.debian.net/debian stable-updates main
# deb-src http://http.debian.net/debian wheezy-updates
 
# Security Updates For "Wheezy"
deb http://security.debian.org/ stable/updates main contrib non-free
deb-src http://security.debian.org/ stable/updates main
 
# BackPorts
deb http://http.debian.net/debian/ wheezy-backports main
deb-src http://http.debian.net/debian/ wheezy-backports main
 
# Deb-Multimedia
# deb http://www.deb-multimedia.org stable main
 
## Liquorix kernel
# deb http://liquorix.net/debian sid main past
 
## Main (MATE) Wheezy Repository
# deb http://repo.mate-desktop.org/debian wheezy main
 
# MATE Wheezy Repository
# deb http://packages.mate-desktop.org/repo/debian wheezy main
# deb http://mirror1.mate-desktop.org/debian wheezy main

apofis ha scritto:


/etc/apt/source.list.d/


/etc/apt/sources.list.d/
Ciao! Smile

We are MicroSoft. You will be assimilated. Resistance is futile.
-- Attributed to B.G., Gill Bates

Ritratto di gianliuc
gianliuc
(Geek)
Offline
Geek
Iscritto: 06/04/2014
Messaggi: 64

Risolto così:

Citazione:

Io ho dovuto installarlo per via di playonlinux Wink Usa wine, ma è più amichevole:
wget -q "http://deb.playonlinux.com/public.gpg" -O- | apt-key add -
wget http://deb.playonlinux.com/playonlinux_wheezy.list -O /etc/apt/sources.list.d/playonlinux.list
apt-get update
apt-get purge wine --remove
apt-get install wine
apt-get install playonlinux

Grazie.

Ritratto di lollix01
lollix01
(Monster)
Offline
Monster
Iscritto: 22/02/2014
Messaggi: 411

Non ho risolto Io invece.
Ciao! Smile

We are MicroSoft. You will be assimilated. Resistance is futile.
-- Attributed to B.G., Gill Bates

Ritratto di Pirata129
Pirata129
(Newbie)
Offline
Newbie
Iscritto: 26/04/2006
Messaggi: 2

Un Saluto a tutti.

Confermo che PlayonLinux ti risolve tante menate relative a Wine.

Va alla grande su mIRC ed uTorrent..

Su altri programmi non so!

Uso Debian Sid e Mate 1.8 su Notebook Hp Pavilion DV6000

:-P

Ritratto di gianliuc
gianliuc
(Geek)
Offline
Geek
Iscritto: 06/04/2014
Messaggi: 64

Pirata129 ha scritto:

Un Saluto a tutti.

Confermo che PlayonLinux ti risolve tante menate relative a Wine.

Va alla grande su mIRC ed uTorrent..

Su altri programmi non so!

Uso Debian Sid e Mate 1.8 su Notebook Hp Pavilion DV6000

Ma nooo per xdcc si và da terminale...!! In estate bisogna stare in pesoforma..Wink

Ritratto di gianliuc
gianliuc
(Geek)
Offline
Geek
Iscritto: 06/04/2014
Messaggi: 64

gianliuc ha scritto:

Risolto così:

Citazione:

Io ho dovuto installarlo per via di playonlinux Wink Usa wine, ma è più amichevole:
wget -q "http://deb.playonlinux.com/public.gpg" -O- | apt-key add -
wget http://deb.playonlinux.com/playonlinux_wheezy.list -O /etc/apt/sources.list.d/playonlinux.list
apt-get update
apt-get purge wine --remove
apt-get install wine
apt-get install playonlinux

Grazie.

Ma mi manca una cosa un bicchier di chianti..Wink

Ritratto di gianliuc
gianliuc
(Geek)
Offline
Geek
Iscritto: 06/04/2014
Messaggi: 64

lollix01 ha scritto:

Non ho risolto Io invece.
Ciao! Smile

Guarda fai così apri il gestore di pacchetti synaptic cerchi wine e togli tutto....poi da terminale uno alla volta naturalmente:

lollix01 ha scritto:

Quote:
Io ho dovuto installarlo per via di playonlinux Wink Usa wine, ma è più amichevole:
wget -q "http://deb.playonlinux.com/public.gpg" -O- | apt-key add -
wget http://deb.playonlinux.com/playonlinux_wheezy.list -O /etc/apt/sources.list.d/playonlinux.list
apt-get update
apt-get purge wine --remove
apt-get install wine
apt-get install playonlinux

poi ti mancherà un bicchier di chianti ma mi sembra che ci sia nella lista dei pacchetti sulla guida....Wink