Installazione skype 4.3.0.37

17 risposte [Ultimo contenuto]
Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1106

Scusa, pensavo di aver già risposto.
ho cercato di installare il primo pacchetto di ogni elenco che mi viene riportato

root@debian-acer:/home/claudio# apt-get install libasound2-plugins:i386
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libasound2-plugins:i386 : Dipende: libavcodec55:i386 (>= 6:10~beta1~) ma non sta per essere installato oppure
                                    libavcodec-extra-55:i386 (>= 6:10.1) ma non sta per essere installato
                           Dipende: libavresample1:i386 (>= 6:10~beta1~) ma non sta per essere installato
                           Dipende: libavutil53:i386 (>= 6:10~beta1~) ma non sta per essere installato
                           Dipende: libjack-jackd2-0:i386 (>= 1.9.5~dfsg-14) ma non sta per essere installato oppure
                                    libjack-0.116:i386
                           Dipende: libsamplerate0:i386 (>= 0.1.7) ma non sta per essere installato
                           Dipende: libspeexdsp1:i386 (>= 1.2~beta3.2-1) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
root@debian-acer:/home/claudio# apt-get install libavcodec55:i386
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libavcodec55:i386 : Dipende: libavutil53:i386 (>= 6:10~beta1~) ma non sta per essere installato
                     Dipende: libgsm1:i386 (>= 1.0.13) ma non sta per essere installato
                     Dipende: libmp3lame0:i386 ma non sta per essere installato
                     Dipende: libopenjpeg5:i386 (>= 1.3+dfsg) ma non sta per essere installato
                     Dipende: libopus0:i386 (>= 1.1) ma non sta per essere installato
                     Dipende: libschroedinger-1.0-0:i386 (>= 1.0.7) ma non sta per essere installato
                     Dipende: libspeex1:i386 (>= 1.2~beta3-1) ma non sta per essere installato
                     Dipende: libtheora0:i386 (>= 1.0) ma non sta per essere installato
                     Dipende: libva1:i386 (> 1.3.0~) ma non sta per essere installato
                     Dipende: libvpx1:i386 (>= 1.3.0) ma non sta per essere installato
                     Dipende: libx264-142:i386 ma non sta per essere installato
                     Dipende: libxvidcore4:i386 (>= 1.2.2) ma non sta per essere installato
 skype:i386 : Dipende: libasound2-plugins:i386 ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
root@debian-acer:/home/claudio# apt-get install libavutil53:i386
Lettura elenco dei pacchetti... Fatto                                                                                                                                                           
Generazione albero delle dipendenze                                                                                                                                                             
Lettura informazioni sullo stato... Fatto                                                                                                                                                       
È utile eseguire "apt-get -f install" per correggere questi problemi:                                                                                                                           
I seguenti pacchetti hanno dipendenze non soddisfatte:                                                                                                                                          
 skype:i386 : Dipende: libasound2-plugins:i386 ma non sta per essere installato                                                                                                                 
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di apofis
apofis
(Monster)
Offline
Monster
Iscritto: 19/09/2007
Messaggi: 309

Non capisco io non ce l'ho installato:

# dpkg -s libavcodec55:i386
dpkg-query: package 'libavcodec55' is not installed and no information is available

anche perchè basta la versione 53:
# dpkg -s libasound2-plugins:i386
Package: libasound2-plugins
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 281
Maintainer: Debian ALSA Maintainers <pkg-alsa-devel@lists.alioth.debian.org>
Architecture: i386
Multi-Arch: same
Source: alsa-plugins
Version: 1.0.25-2
Depends: libasound2 (>= 1.0.25), libavcodec53 (>= 6:0.8.2-2) | libavcodec-extra-53 (>= 6:0.8.2-2), libavutil51 (>= 6:0.8.2-2), libc6 (>= 2.7), libjack-jackd2-0 (>= 1.9.5~dfsg-14) | libjack-0.116, libpulse0 (>= 0.99.1), libsamplerate0 (>= 0.1.7), libspeexdsp1 (>= 1.2~beta3.2-1)
Pre-Depends: multiarch-support

Prova ad eliminarla ed installare libavcodec53:i386

I@ legge Apo-genetica: chini nascia tunnu un ci mora quatratu.
II@ legge Apo-genetica: munnu e munnu un s'incontranu mai, ma cristiani e cristiani sì
III@ legge Apo-genetica: si vidi nu ghiegghiu e nu lupu, ammazza 'u ghiegghiu!

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1106

Ma io libavcodec55:i386. Cosa disinstallo? Ho capito male?
In ogni caso:

root@debian-acer:/home/claudio# apt-get install libavcodec53:i386
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto libavcodec53

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

È evidente che avete due rilasci diversi di Debian: Wheezy è ferma alla 53, mentre Jessie è già alla 55.

In teoria (anzi: per definizione) apt-get dovrebbe installare, insieme al pacchetto specificato sulla riga di comando, anche tutti i pacchetti da cui esso dipende. L'unico motivo che mi viene in mente per cui in questo caso sembra non fare quello per cui è stato progettato è che sia confuso dall'indicazione :i386. Prova piuttosto la sintassi esplicita:

apt-get -a=i386 install libasound2-plugins
In questo modo la direttiva -a=i386 viene distribuita a tutte le elaborazioni a valle, mentre il suffisso :i386 si applica solo al singolo pacchetto.

Questo è quello che mi sembra di aver capito circa il funzionamento di apt-get (che, tra l'altro, non uso mai perché trovo aptitude infinitamente più potente).

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1106

apt-get -a=i386 install libasound2-plugins
E: Opzione a riga di comando "a" [da -a=i386] sconosciuta.

Se non ti trovi con apt, dammi il comando di aptitude, non ti preoccupare. Io non lo so usare, ma in fin dei conti devo solo mandarlo in esecuzione Big Grin

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Strano: l'opzione -a è citata nella man page.

No, non basta lanciare aptitude: è un programma interattivo. In genere è molto abile a risolvere le dipendenze più intricate e se non ti soddisfa la soluzione che ha trovato, puoi andare a selezionare a mano uno per uno i pacchetti che ti interessano. Non ho però idea di come funzioni in presenza di più architetture, non l'ho mai potuto approfondire semplicemente perché tutte le mie installazioni sono i386.

Comunque, nel tuo caso, ti consiglio di fare a mano il lavoro che dovrebbe fare apt-get in automatico. Più precisamente: provare a installare libasound2-plugins:i386 e, al messaggio di errore, annotarsi i pacchetti da cui dipende e interrompere l'installazione. Poi provare a installare uno a uno i pacchetti annotati, avendo cura di aggiungere sempre :i386 al nome del pacchetto. E così via.

Ritratto di gennargiu
gennargiu
(Guru)
Offline
Guru
Iscritto: 23/11/2011
Messaggi: 622

io stamattina ho eseguito alla lettera la guida del wiki di debian fino ai comandi del fix....tutto è andato perfettamente facendomi installare l'ultima versione di skype 4.3.7 su debian wheezy 7.6 con de gnome 3,ciao

gennaro

https://wiki.debian.org/skype

HP ELite 8200 i3 quad core 3,1 Ghz 16 Giga Ram - Hd 2 terabyte - Debian Buster RC1-64 bit desktop mate-xfce-Lxde-lxqt-E22