Impossibile installare pacchetto gksudo

15 risposte [Ultimo contenuto]
Ritratto di ale.a
ale.a
(Geek)
Offline
Geek
Iscritto: 12/03/2017
Messaggi: 80

Salve a tutti, sto avendo il problema in oggetto, quando do il comando

sudo apt-get install gksu

ricevo questo output

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 gksu : Dipende: libgksu2-0 (>= 2.0.8) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

Ho provato a seguire dei consigli trovati online tipo

sudo dpkg --configure -a
sudo apt-get install -f

Ma niente.

Ho provato ricorsivamente ad installare i pacchetti richiesti a partire da libgksu2-0 fino ad arrivare a gconf-service ma ricevo il seguente output:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
gconf-service è già alla versione più recente (3.2.6-4.1).
È stato impostato gconf-service per l'installazione manuale.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

Se provo a rimuovere questo pacchetto per poi reinstallarlo mi dice che verrebbe eliminato il pacchetto sugar-browse-activity, può avere qualche collegamento col fatto che se vado nell'elenco applicazioni e cerco di avviare l'applicazione Naviga in Istruzione non avviene nulla?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Ciao,
gksudo e relative dipendenze sono tutte disponibile nei repository standard di debian, controlla qui se hai dubbi.

Hai già provato ad aggiornare i repository ?

sudo apt-get update

Non è che ci hai messo mano, e magari pasticciato, per aggiungerne di altri ?
In tal caso controlla il contenuto di /etc/apt/sources.list e l'eventuale presenza di files in /etc/apt/sources.list.d.

Ritratto di ale.a
ale.a
(Geek)
Offline
Geek
Iscritto: 12/03/2017
Messaggi: 80

Ciao, grazie per la risposta, ovviamente ho provato ad aggiornare i repository ma niente, il filsources.list è il seguente:

# 
 
# deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official amd64 NETINST 20171209$
 
#deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official amd64 NETINST 20171209-$
 
deb http://ftp.it.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.it.debian.org/debian/ stretch main contrib non-free
 
deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main
 
# stretch-updates, previously known as 'volatile'
deb http://ftp.it.debian.org/debian/ stretch-updates main
deb-src http://ftp.it.debian.org/debian/ stretch-updates main

A parte l'aggiunta di contrib e non-free non ho fatto nulla.
Nell'altro path che mi hai dato non c'è nulla.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Strano, ho provato a rimuovere e reinstallare gksu e libgksu2-0 e poi lo ho reinstallato senza problemi.
Che errori ti da se provi a installare prima libgksu2-0 ?

Ritratto di ale.a
ale.a
(Geek)
Offline
Geek
Iscritto: 12/03/2017
Messaggi: 80

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libgksu2-0 : Dipende: gconf2 (>= 2.28.1-2) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

Ho provato anche a continuare tentando di installare gconf2, fino ad arrivare alla situazione che ho descritto alla fine del primo post.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Scusa se insisto ma sei sicuro che apt-get update sia andato a buon fine ?

Ritratto di ale.a
ale.a
(Geek)
Offline
Geek
Iscritto: 12/03/2017
Messaggi: 80

Sì, a parte l'unica stranezza che rimane qualche secondo di troppo in [0% in lavorazione] nonostante la connessione sia perfetta, non mi da alcun errore...

EDIT: dopo un riavvio ora il comando mi restituisce

Ignorato:1 http://ftp.it.debian.org/debian stretch InRelease            
Trovato:2 http://ftp.it.debian.org/debian stretch-updates InRelease     
Trovato:3 http://security.debian.org/debian-security stretch/updates InRelease 
Trovato:4 http://ftp.it.debian.org/debian stretch Release                      
Lettura elenco dei pacchetti... Fatto 

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Scusa, ma prima che output ti dava prima ? Perchè quello che hai postato è ciò che restituisce sempre l'update .... quando funziona senza problemi.
Hai riprovato quindi a installare il pacchetto ?

Ritratto di ale.a
ale.a
(Geek)
Offline
Geek
Iscritto: 12/03/2017
Messaggi: 80

Quando funzionava correttamente non mi dava "Ignorato" alla prima riga.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Ma non credo sia quello il problema.
Il file InRelease non c'è nella struttura del repository stretch ed è per quello che viene ignorato, ma alla riga 4 trova il file Release e il suo compare Release.gpg, anche se non te lo dice, quindi dovrebbe scaricare e aggiornare l'indice dei pacchetti.

In merito a questo leggi qui per i dettagli.

Ancora però non hai detto se adesso riesci o meno a installare il pacchetto, eventualmente puoi confermare che è solo quel pacchetto che ti da problemi o è una cosa generale, cioè se provi a installare qualche altra applicazione hai lo stesso problema con dipendenze che non si risolvono ?

Ritratto di ale.a
ale.a
(Geek)
Offline
Geek
Iscritto: 12/03/2017
Messaggi: 80

Non ricordavo che l'output fosse sempre quello, comunque era sottinteso che il problema non era risolto, ho provato ad installare aptitude e mi ritrovo un output che mi sembra anomalo, poi magari mi sbaglio

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  ant ant-optional bluetooth bluez ca-certificates-java coinor-libcbc3
  coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5 coinor-libcoinutils3v5
  coinor-libosi1v5 crda debian-reference-common debian-reference-it
  default-java-plugin default-jre default-jre-headless distro-info-data
  dns-root-data dnsmasq-base docbook-xml exfalso firebird3.0-common
  firebird3.0-common-doc firebird3.0-server-core firebird3.0-utils
  fonts-crosextra-caladea fonts-crosextra-carlito fonts-dejavu
  fonts-dejavu-extra fonts-font-awesome fonts-freefont-ttf fonts-lato
  fonts-liberation2 fonts-linuxlibertine fonts-noto-hinted fonts-opensymbol
  fonts-sil-gentium fonts-sil-gentium-basic fortune-mod fortunes-it freepats
  gdal-data gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0
  gir1.2-gtksource-3.0 gir1.2-keybinder-3.0 gir1.2-wnck-3.0 gnome-orca
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly hp-ppd hyphen-en-us
  ibverbs-providers icedtea-8-plugin icedtea-netx icedtea-netx-common
  iputils-arping iw java-common javascript-common liba52-0.7.4 libabw-0.1-1
  libaec0 libao-common libao4 libapache-poi-java libapache-pom-java
  libaribb24-0 libarmadillo8 libarpack2 libass9 libatk-adaptor
  libatk-wrapper-java libatk-wrapper-java-jni libaudio2 libbase-java
  libbasicusageenvironment1 libbcmail-java libbcpkix-java libbcprov-java
  libbluetooth3 libboost-chrono1.62.0 libboost-date-time1.62.0
  libboost-locale1.62.0 libboost-thread1.62.0 libbrlapi0.6 libbs2b0
  libbsh-java libcddb2 libcdio17 libcdr-0.1-1 libcharls1
  libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5
  libcommons-codec-java libcommons-collections3-java libcommons-logging-java
  libcommons-parent-java libcurl3-gnutls libdap25 libdapclient6v5
  libdapserver7v5 libdc1394-22 libdca0 libde265-0 libdom4j-java libdotconf0
  libdouble-conversion1 libdvbpsi10 libdvdnav4 libdvdread4 libdw1
  libe-book-0.1-1 libebml4v5 libehcache-java libeot0 libepsilon1 libept1.5.0
  libepubgen-0.1-1 libetonyek-0.1-1 libexttextcat-2.0-0 libexttextcat-data
  libfaad2 libfabric1 libfbclient2 libflite1 libfluidsynth1 libflute-java
  libfonts-java libformula-java libfreehand-0.1-1 libfreexl1 libfyba0
  libgdal20 libgdcm2.8 libgeos-3.6.2 libgeos-c1v5 libgeotiff2 libgif7
  libgl2ps1.4 libgles2 libgpgmepp6 libgpod-common libgpod4 libgroupsock8
  libgtksourceview-3.0-1 libgtksourceview-3.0-common libhdf4-0-alt libhdf5-100
  libhdf5-openmpi-100 libhsqldb1.8.0-java libhwloc-plugins libhwloc5
  libib-util libibverbs1 libisorelax-java libitext-java libiw30 libjaxen-java
  libjcommon-java libjdom1-java libjs-jquery libjs-modernizr libjs-sphinxdoc
  libjs-underscore libkate1 libkmlbase1 libkmlconvenience1 libkmldom1
  libkmlengine1 libkmlregionator1 libkmlxsd1 liblangtag-common liblangtag1
  liblayout-java liblept5 liblilv-0-0 liblirc-client0 liblivemedia61
  libloader-java liblog4j1.2-java liblua5.2-0 libmad0 libmail-java
  libmariadbclient18 libmatroska6v5 libmbim-glib4 libmbim-proxy libmhash2
  libmicrodns0 libminizip1 libmjpegutils-2.1-0 libmm-glib0 libmms0 libmodplug1
  libmpcdec6 libmpeg2-4 libmpeg2encpp-2.1-0 libmplex2-2.1-0 libmspub-0.1-1
  libmsv-java libmtp-common libmtp-runtime libmtp9 libmwaw-0.3-3
  libmythes-1.2-0 libndp0 libneon27-gnutls libnetcdf-c++4 libnetcdf13 libnfs8
  libnghttp2-14 libnl-3-200 libnl-genl-3-200 libnl-route-3-200 libnma0
  libodbc1 libodfgen-0.1-1 libofa0 libogdi3.2 libopenal-data libopenal1
  libopencore-amrnb0 libopencore-amrwb0 libopencv-calib3d3.2
  libopencv-contrib3.2 libopencv-features2d3.2 libopencv-flann3.2
  libopencv-highgui3.2 libopencv-imgcodecs3.2 libopencv-imgproc3.2
  libopencv-ml3.2 libopencv-objdetect3.2 libopencv-photo3.2 libopencv-shape3.2
  libopencv-stitching3.2 libopencv-superres3.2 libopencv-video3.2
  libopencv-videoio3.2 libopencv-videostab3.2 libopencv-viz3.2 libopenmpi2
  libopenmpt-modplug1 liborcus-0.13-0 libpagemaker-0.0-0 libpcre2-16-0
  libpcsclite1 libpentaho-reporting-flow-engine-java libpixie-java libplacebo2
  libpostproc54 libpq5 libproj12 libprotobuf-lite10 libproxy-tools
  libpsm-infinipath1 libpython3.6 libqhull7 libqmi-glib5 libqmi-proxy
  libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5svg5 libqt5widgets5
  libqt5x11extras5 libqxp-0.0-0 libraptor2-0 librarian0 librasqal3 librdf0
  librdmacm1 librecode0 librelaxng-datatype-java libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
  libreoffice-base-drivers libreoffice-calc libreoffice-common
  libreoffice-core libreoffice-draw libreoffice-gtk2 libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-librelogo
  libreoffice-math libreoffice-nlpsolver libreoffice-ogltrans
  libreoffice-report-builder libreoffice-report-builder-bin
  libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-sdbc-firebird
  libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer
  librepository-java libresid-builder0c2a librevenge-0.0-0 librtmp1
  libsac-java libsaxonhe-java libsbc1 libsdl-image1.2 libserd-0-0
  libserializer-java libservlet3.1-java libsgutils2-2 libsidplay1v5
  libsidplay2 libsndio6.1 libsocket++1 libsord-0-0 libsoundtouch1 libspandsp2
  libspatialite7 libspeechd2 libsratom-0-0 libsrtp0 libssh2-1
  libstaroffice-0.0-0 libsuperlu5 libsz2 libteamdctl0 libtesseract4 libtidy5
  libtommath1 libupnp6 liburiparser1 libusageenvironment3 libva-wayland2
  libvisio-0.1-1 libvlc-bin libvlc5 libvlccore9 libvo-aacenc0 libvo-amrwbenc0
  libvtk6.3 libvulkan1 libwildmidi-config libwildmidi2 libwpd-0.10-10
  libwpg-0.3-3 libwps-0.4-4 libxcb-icccm4 libxcb-image0 libxcb-keysyms1
  libxcb-randr0 libxcb-render-util0 libxcb-xinerama0 libxcb-xkb1 libxcb-xv0
  libxerces-c3.2 libxerces2-java libxkbcommon-x11-0
  libxml-commons-external-java libxml-commons-resolver1.1-java libxml-java
  libxmlbeans-java libxmlsec1 libxmlsec1-nss libxom-java libxpp2-java
  libxpp3-java libyajl2 libzbar0 libzmf-0.0-0 lp-solve lsb-release
  maint-guide-it manpages-it media-player-info mobile-broadband-provider-info
  modemmanager mysql-common mythes-en-us network-manager network-manager-gnome
  ocl-icd-libopencl1 odbcinst odbcinst1debian2 openjdk-8-jre
  openjdk-8-jre-headless openmpi-bin openmpi-common orca policykit-1-gnome
  powertop proj-bin proj-data python-apt-common python-chardet
  python-concurrent.futures python-faulthandler python-feedparser
  python-libxml2 python-musicbrainzngs python-mutagen python-pkg-resources
  python-pyinotify python-utidylib python3-apt python3-brlapi python3-debconf
  python3-debian python3-debianbts python3-httplib2 python3-louis
  python3-pyatspi python3-pycurl python3-pysimplesoap python3-speechd
  python3-uno python3-xdg qt5-gtk-platformtheme qttranslations5-l10n quodlibet
  rarian-compat sgml-base sgml-data sound-icons speech-dispatcher
  speech-dispatcher-audio-plugins speech-dispatcher-espeak-ng
  sphinx-rtd-theme-common synaptic uno-libs3 ure vlc vlc-bin vlc-data vlc-l10n
  vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba
  vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter
  vlc-plugin-visualization wireless-regdb wireless-tools wpasupplicant xbrlapi
  xml-core xsane xsane-common
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  aptitude-common libcwidget3v5
Pacchetti suggeriti:
  aptitude-doc-en | aptitude-doc apt-xapian-index debtags tasksel
  libcwidget-dev
Pacchetti raccomandati:
  libparse-debianchangelog-perl
I seguenti pacchetti saranno RIMOSSI:
  apt apt-listchanges apt-utils python3-reportbug reportbug task-desktop
  task-italian task-laptop task-print-server task-xfce-desktop tasksel
  tasksel-data
I seguenti pacchetti NUOVI saranno installati:
  aptitude aptitude-common libcwidget3v5
ATTENZIONE: i seguenti pacchetti essenziali stanno per essere rimossi.
Questo non dovrebbe essere fatto a meno che non si sappia esattamente cosa si sta facendo.
  apt
0 aggiornati, 3 installati, 12 da rimuovere e 0 non aggiornati.
È necessario scaricare 3.383 kB di archivi.
Dopo quest'operazione, verranno occupati 8.747 kB di spazio su disco.
Si sta per compiere un'azione potenzialmente pericolosa.
Per continuare scrivere la frase "Sì, esegui come da richiesta."
 ?] n
Interrotto.

Poi ho provato ad installare chromium e non mi da problemi...