Iceweasel non vuole funzionare come prima

17 risposte [Ultimo contenuto]
Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Ciao a tutti. Avevo ripreso un vecchio thread di mcortese, ma ora ne ho dovuto aprire un altro perché mi sono accorto (dopo varie prove) che non è vlc a non funzionare, bensì iceweasel con flash plugin. Ho anche provato con chromium e poi con chrome, ma il risultato è sempre quello o quasi. In Iceweasel mi era saltato fuori l'avviso che era troppo vecchio (3.XX) e quindi l'ho aggiornato alla 17.0 e poi oggi alla 18.0.

Vado su youtube e non mostra più i filamti, Idem in altri siti. Allora pulisco dal plugin e lo reisntallo. Niente da fare. Provo a reinstallare Iceweasel e ancora con nuovo plugin, ma ancora non mostra i filmati, bensì al loro posto un quadrato nero che lampeggia per poi divenire bianco e non dare alcun segnale, questo anche provando col tasto destro per eventuale menu di flash. In sezione componenti aggiuntivi dice che è correttamente installato. Installo Chromium e mi fa lo stesso scherzo, pure mettendo il plugin flashPepper. Disisntallo Chromium e al suo posto provo allora con Google Chrome.

Questa volta dice che non può caricare il plugin di flash. Lo disattivo da Iceweasel e riprovo su youtube. Nulla. Faccio anche partire Iceweasel senza plugins (--safe-mode) niente da fare perché richiede il plugin flash. Prima pensavo fosse stata forse la versione 17.0 che però sino a metà dicembre ha sempre funzionato e vedevo ogni filmato, ora non mostra i filmati e si è rallentato non poco nella sezione segnalibri (a scatti e lento)...c'è però da dire che se disattivo flasplugin riesco a vedere i filmati fatti in html5. Ho fatto una prova sull'altro mio pc con windows e vede tutto correttamente senza dover disattivare alcun plugin o estensione ed anche là ho la 18.0 ma di Firefox.

Possibile che sia Iceweasel ad avere danneggiato qualcosa? Su questa debian non uso programmi particolari, o programmazioone pesante etc, per cui mi sembra assurdo che da un momento all'altro abbia smesso di girare correttamente. Ho provato a fare un po' di pulizia, ma ancora non si riprende...Sto usando la Debian 6.0.6 a 32 bit
aggiornata via backport per via di Iceweasel che era detto vecchio da vari siti in rete (Linux debian 3.2.0-0.bpo.4-686-pae #1 SMP Debian 3.2.35-2~bpo60+1 i686 GNU/Linux su processore AMD 2200+). So che i backports possono avere bugs, ma qui che non funziona è solo la visualizzazione filmati in rete, perché il resto non ha alcun problema...se lancio un filmato da pc lo vedo benissimo, idem per eventuale musica.

Qualcuno ha qualche idea?

Grazie in anticipo per qualsiasi commento/aiuto

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Quando parli del plugin, intendi la versione 11.2, giusto? Non è che i siti che visiti richiedono una versione successiva (su Windows sono arrivati alla 11.5)?

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Sì, ed è quella che ho installato e che via pagina verifica conferma ho installato correttamente (11.2 r202). E' però molto, troppo strano che dopo installato Google Chrome, disabilitato (come suggerito su sito Mozilla) il plugin flash in Iceweasel e lanciato Crome, ancora abbia problemi, tanto da arrivare a rispondere che "non è possibile caricare il plugin di flash"...so che Chrome ha sempre problemi ed anche se lo danno per stabile, è un po' una ciofeca, però ciò non toglie che dovrebbe essere funzionante...

Per completezza d'informaziione: ho provato a visualizzare i filmati youtube via VLC e Mplayer, ma quando inserito il link, esce un avviso che dice che è impossibile visualizzare il file txt perché non trova il percorso... file che è poi quello dei robot usati per instradare

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Non capisco bene il passaggio relativo al suggerimento trovato sul sito di Mozilla...

Io ho sempre usato il pacchetto flashplugin-nonfree che scarica l'ultima versione del plugin dal sito e lo installa nella directory giusta. Sia Iceweasel sia Chromium (parlo ovviamente delle versioni pacchettizzate in Debian) lo vedono subito.

Devo ammettere, comunque, che la mia esperienza con siti infestati da flash è molto limitata, per fortuna!

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Giusta la tua osservazione circa i pacchetti in Synaptic, però mi trovai nella situazione per cui su youtube mi venne specificatamente richiesto l'aggiornamento all'ultima versione di flash e quello non era supportato (aleno così mi rispse il sistema) da Iceweasel 3.0.6. Così decisi di aggiornare uno (Iceweasel) e l'altro (flash). Fatto ciò tutto funzionava. Tempo dopo, verso metà dicembre, ha cominciato a non mostrare più i filmati in rete e così è ad oggi. Ho pprovato cn flashplugin-nonfree e non va e così ho scaricato dal sito ufficiale di Adobe e seguito le istruzioni là riportate, ma ancora non va. Poi i passaggi seguenti, che mi hanno dimostrato che anche con altri browsers non funziona più. Ad esempio ho dovuto cxopiare a mano in /usr/lib/mozilla/plugins il file libflashplayer.so... intanto ecco un'immagine di ricerca di flashplugin come installato via Synaptic.
Difficilissimo (impossibile) che installi da siti terzi...anzi me ne guardo bene dopo la scorsa esperienza di un filtro windows-firefox che si insinuò sul pc linux e da me MAI richiesto, cosa che mi portò a resettare tutto Icedove...

A me che preoccupa è il fatto che mi ritrovi nei filtri anche roba per Mac, che però mai ho chiesto dato che non uso apple e neppure cellulari con sistema apple. Uso SO Android sul mio cell (HTC), ma il tutto è su altro pc... per cui non capisco come saltino su questo pc.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Forse sarebbe meglio avere qualche dettaglio "oggettivo" in più: che versione di Firefox, Chrome e del plugin usi al momento, nonché l'URL di alcune pagine del Web in cui si verifica l'errore.

In questo modo ciascuno dei frequentatori del forum può provare se installazioni diverse producono effetti diversi. Altrimenti sarà un dialogo tipo «a me non funziona»; «strano: a me sì». Big Grin

Ritratto di apofis
apofis
(Monster)
Offline
Monster
Iscritto: 19/09/2007
Messaggi: 309

Ciao,
ma dopo aver installato tutti questi "flash", almeno hai cancellato i vecchi??
Niente di più facile che vadano in conflitto fra di loro.

Allegaci uno screen dei plugin installati da Firefox, tipo questo:

p.s.
il plugin flash di Adobe non va copiato sotto la cartella plugin ma va fatto un link simbolico ^_^

I@ legge Apo-genetica: chini nascia tunnu un ci mora quatratu.
II@ legge Apo-genetica: munnu e munnu un s'incontranu mai, ma cristiani e cristiani sì
III@ legge Apo-genetica: si vidi nu ghiegghiu e nu lupu, ammazza 'u ghiegghiu!

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Ho dovuto rimpicciolire la pagina altrimenti non sarei riuscito a inserrirli tutti, e inoltre non capisco perché ci sia anche DivX se MAI l'ho caricato come pure roba per Mac (formati MOV) se come detto non uso cose tipo mac, iPhone etc...

comunque ecco lo screen

Iceweasel è la 18.0. Dimenticavo: quando ho fatto il link a flash, perché continuava a dirmi che era collegamento interrotto? Al che ho seguito la guida originale Adobe (copiare il file intero).

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Mi sbaglio o il tuo processore è un po' datato?
A partire dalla versione 11.2, mi pare, i plugin flash per il loro funzionamento richiedono istruzioni SSE2 per le cpu. Probabilmente il tuo processore è troppo vecchio per far girare gli ultimi plugin flash.
Prova a controllare lanciando da terminale un:

#lshw -C cpu

Se così fosse, non ti rimarrebbe altro che installare un plugin meno recente, tipo l'11.1.

.theShort Big Grin

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Sicuro? Guarda che avevo già installato l'ultimo plugin e cioè quello che hai visto, e tutto girava alla perfezione... inoltre penso che me ne sarei accorto dopo averlo disinstallato. Come detto in precedenza anche con altri browsers mi fa lo stesso scherzo prò tutto è iniziato da Iceweasel.

Ho anche un vecchio pc con windows xp che è un AMD 1700+ e anche là c'è l'ultimo flash. Come mai essendo più che datato viaggia come una scheggia? L'altro pc con un amd 2800+ pure fa quello scherzo, ma solo da ora... però non mi interessa perché a breve dovrò formattarlo per adibirlo ad altro...

lshw non è presente su questo pc...

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Questo thread sta diventando sempre più confuso. Perché non rispondi a poche semplici domande, così iniziamo a delimitare il campo d'azione?

  1. Quale URL non funziona?
  2. Qual è stato il momento in cui questo URL ha smesso di funzionare? Al passaggio da Iceweasel 17 a 18 o già prima?
  3. Puoi confermare (l'immagine che hai mandato è davvero illeggibile) che stiamo parlando di Iceweasel 18.0 e flash 11.2r202?
  4. Perché hai voluto o dovuto installare Iceweasel 18, una versione che in Debian non è nemmeno in Sid, ma addirittura in experimental?