iceweasel non apre nuovi tab

2 risposte [Ultimo contenuto]
Ritratto di paco_deb
paco_deb
(Geek)
Offline
Geek
Iscritto: 25/10/2007
Messaggi: 152

ciao a tutti.
è da qualche giorno che riscontro un noioso problema con iceweasel.
In pratica se quest'ultimo è in esecuzione non mi è possibile aprirne una seconda istanza; viene infatti visualizzato il messaggio "firefox is already running, ...."

Il problema è presente anche se qualche altra applicazione (tipo il notifier della posta) tenta di aprire un nuovo tab del browser.

Come posso fare per risolvere il problema?capita ancje a voi?

PS: su internet ho visto che la causa è riconducibile a due file di controllo (lock e .parentlock) creati da firefox all'avvio infatti cancellandoli il problema non sussiste ma si ripresenta in quanto tali file vengono ricreati ad ogni avvio di ogni istanza

PPS: per firefox intendo iceweasel ma suppongo siano mutuabili

Ritratto di fortAlamo
fortAlamo
(Junior)
Offline
Junior
Iscritto: 04/07/2005
Messaggi: 23

se vuoi mantenere la versione 3.0.3-1 , la soluzione *dovrebbe* essere questa

Fix is simple. In /usr/lib/iceweasel/iceweasel find :

Code:
# OK, here's where all the real work gets done

# parse command line
APPLICATION_ID=firefox
VERBOSE=
DEBUG=0
DEBUGGER=

and change "firefox" to "iceweasel"

credits qui
Laughing

altrimenti aggiorna e passa alla 3.0.3-2

Sidux, & Debian Lenny su V3510; kde4;
Arch & BT su AcerAspireOne

Ritratto di paco_deb
paco_deb
(Geek)
Offline
Geek
Iscritto: 25/10/2007
Messaggi: 152

Mi era del tutto sfuggito l'aggiornamento!
problema risolto.
grazie mille