Cups e aggiunta utente amministratore

14 risposte [Ultimo contenuto]
Ritratto di Fabio Berti
Fabio Berti
(Junior)
Offline
Junior
Iscritto: 12/10/2014
Messaggi: 34

Ciao per favore come si fa ad aggiungere un utente a cups? Ogni volta che provo ad aggiungere la stampante mi appare la schermata di login.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Ciao,
quando aggiungi una stampante in CUPS è sufficiente indicare utente root e relativa password, se invece vuoi usare il tuo utente e la tua password bisogna prima che aggiungi il tuo utente al gruppo lpadmin.
Per prima cosa controlla l'output del comando :

groups

se risulta anche lpadmin sei già a posto, in caso contrario :

sudo usermod -a -G lpadmin mioutente

poi fai il logout e di nuovo il login per aggiornare, ovviamente al posto di mioutente devi indicare il tuo utente.

Ritratto di Fabio Berti
Fabio Berti
(Junior)
Offline
Junior
Iscritto: 12/10/2014
Messaggi: 34

lpadmin è presente, la cosa che mi sorprende è che se mi logo a cups con le mie credenziale mi riappare sempre la schermata di login.

Ritratto di Black Bart
Black Bart
(Monster)
Offline
Monster
Iscritto: 18/10/2011
Messaggi: 308

Ci si deve loggare come "root" oppure per usare il tuo utente credo che devi far parte del gruppo "wheel" oppure "sys".Quest'ultimo però credo che su debian non esista,io lo uso con slackware.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Fabio Berti ha scritto:

lpadmin è presente, la cosa che mi sorprende è che se mi logo a cups con le mie credenziale mi riappare sempre la schermata di login.

Molto strano, leggendo qui l'unica nota di rilievo è in relazione alla lunghezza della password, che da problemi con CUPS se superiore ai 32 caratteri, solo per la versione specificata però.
Prova a controllare che non sia questo il problema, in ogni caso puoi sempre usare root, oppure anche qui hai problemi di login ?
Ultima cosa, che magari mi è sfuggita, tu usi l'interfaccia di CUPS in locale ( http://localhost:631 ) oppure ti colleghi ad un altro server, in questo caso utente/password devono essere di un utente presente sul server remoto e presente nel gruppo lpadmin.

Ritratto di Fabio Berti
Fabio Berti
(Junior)
Offline
Junior
Iscritto: 12/10/2014
Messaggi: 34

Black mi connetto a cups come root la password è corretta ma non mi permette l'accesso.
Bad la password è lunga 14 caratteri e include simboli come @ e €. Mi collego al server indicato come root mi basterebbe solamente aggiungere la stampante per il resto ho installato tutto sia le dipendenze sia le librerie a 32 bit sia il driver.
Allora cambiando la password di root usando solo caratteri numerici e lettere, riesco ad accedere a cups, quindi forse cups non accetta password con caratteri tipo @ e €, provato a lanciare le stampe di test i lavori compaiono sui job ma non stampa.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Fabio Berti ha scritto:

Allora cambiando la password di root usando solo caratteri numerici e lettere, riesco ad accedere a cups, quindi forse cups non accetta password con caratteri tipo @ e €, provato a lanciare le stampe di test i lavori compaiono sui job ma non stampa.

Per i caratteri della password di sicuro la @ non crea problemi perchè la uso anche io, non saprei per il simbolo € ma mi sembrerebbe strano.

Per la stampante invece dovresti darci più dettagli, marca/modello/tipo connessione ecc.

Ritratto di Fabio Berti
Fabio Berti
(Junior)
Offline
Junior
Iscritto: 12/10/2014
Messaggi: 34

la stampante è una epson aculaser c1100, ho provato a installare i driver sperimentali ma quando lancio la stampa appare il job ma LA STAMPA NON AVVIENE, il collegamento è usb, il sistema è un debian a 64 bit stabile versione 7.8

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Scusa se faccio il pignolo ma puoi darci il link a questi driver sperimentali che hai installato ? arrivano dal sito EPSON ?

Ritratto di Fabio Berti
Fabio Berti
(Junior)
Offline
Junior
Iscritto: 12/10/2014
Messaggi: 34

http://translate.google.it/translate?hl=it&sl=en&u=https://lists.debian.org/debian-printing/2014/01/msg00011.html&prev=search
ecco il link qui dice che il file ppd dovrebbe stare in un altro percorso secondo te è ragionevole la cosa e se si come si fa a portare il file ppd in quel percorso?
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install ia32-libs
con questo installo le libreire a 32 bit e la stampante stampa tranne in fronte retro. Come posso modificare il file di configurazione e dove lo trovo per forzare il fronte retro sul lato lungo di stampa?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Ricapitolando la stampante allora funziona, è che non fa il fronte retro giusto ?
Mi pare di aver capito che è un modello piuttosto vecchio e potrebbe anche essere che il driver/file PPD non preveda questa funzionalità, in questo caso dubito molto che ci si possa porre rimedio.
Il file PPD dovrebbe in ogni caso essere nella cartella /usr/share/ppd, qui dovresti avere una cartella, potrebbe chiamarsi anche EPSON, con dentro i PPD dei vari modelli supportati dal driver installato.
Io ho una SAMSUNG e i driver sono in /usr/share/ppd/uld-samsung, beh in realtà è un link ma non importa, nel file PPD dovrebbe esserci qualche riferimento al duplex se c'è il supporto al fronte/retro.
Altro non saprei proprio dirti.