Avviare solo chrome all'avvio del sistema in modalità kiosk

6 risposte [Ultimo contenuto]
Ritratto di maudit
maudit
(Junior)
Offline
Junior
Iscritto: 08/09/2017
Messaggi: 11

Salve a tutti ragazzi, sono nuovo del forum vi leggo da tanto tempo ed ho trovato in passato molte soluzioni ai miei svariati e bizzarri problemi Smile
Purtroppo questa volta non sono riuscito a venire a capo a questo problema:

Ho una macchina con Debian 9 installato;
volevo fare una cosa simile a quella presente a questo vecchio link ma purtroppo non mi sta riuscendo, in pratica ho installato sul pc xorg e ho questa riga di comando che ho provato sia da terminale che da uno script e mi avvia il browser in modalità kiosk, purtoppo non so dove inserire il comando, per far partire all'avvio solo il browser in modalità kiosk.

Scusate se la domanda è stupida e grazie in anticipo a tutti

Ritratto di compact
compact
(Geek)
Offline
Geek
Iscritto: 11/12/2004
Messaggi: 115

prova questo:

https://superuser.com/questions/613645/run-firefox-in-kiosk-mode

Ritratto di maudit
maudit
(Junior)
Offline
Junior
Iscritto: 08/09/2017
Messaggi: 11

Ti ringrazio infinitamente per la risposta, purtroppo nodm mi sta dando qualche problema, io non riesco a trovare una documentazione adeguata sul suo utilizzo, in ogni caso non sono riuscito a risolvere il problema come faccio ad eseguire un script all'avvio di debian 9?

Io ho fatto così ed il mio problema è questo:

root@debian:nano /etc/init.d/browser.sh
il contenuto è il seguente
----------------------------------------

#!/bin/bash
### BEGIN INIT INFO
# Provides: browser.sh
# Required-Start: hal
# Required-Stop:
# Should-Start:
# Should-Stop:
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
#Short-Description:start chrome in kiosk mode...
### END INIT INFO

/usr/bin/google-chrome --kiosk http://google.it

----------------------------------------------------------
root@debian:/home/a2# chmod +x /etc/init.d/browser.sh

root@debian:/home/a2# systemctl enable browser.sh
browser.sh.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable browser.sh
root@debian:/home/a2# update-rc.d browser.sh defaults

ma non si avvia nulla all'avvio

se faccio:
root@debian:/home/a2# systemctl status browser
ottengo:
● browser.service - LSB: start chrome in kiosk mode...
Loaded: loaded (/etc/init.d/browser.sh; generated; vendor preset: enabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)

cosa sbaglio??
grazie ancora a tutti.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2754

La fonte d'errore sta nella confusione tra cosa fa o può fare il sistema e cosa l'utente. Il primo non può lanciare un browser perché non ha una sessione grafica tutta sua.

Non ho una soluzione "chiavi in mano", ma a grandi linee dovresti creare un utente senza password, poi impostare il Desktop Manager (il gestore del login grafico) per entrare direttamente con quell'utente senza alcun input manuale, infine aggiungere Chrome in modalità kiosk alle applicazioni da far partire all'inizio della sessione grafica (autostart).

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 1944

maudit ha scritto:

... purtoppo non so dove inserire il comando ...

Ciao,
ma il link che hai postato riporta chiaramente che devi inserire i comandi nel file .Xsession della home directory dell'utente, anche se forse é .xsession con la x minuscola, ma forse é indifferente.
Non mi é pertanto chiaro perché tu abbia questo dubbio, oppure hai fatto cosí e non funziona ?

Per quanto riguarda lo script che hai fatto é ovvio che non funzioni perché non rispetta in nessun modo lo standard degli initscript ne quello di systemd, ma in ogni caso non sarebbe la via corretta da seguire in quanto tu devi avviare un browser e non un servizio.

Ritratto di maudit
maudit
(Junior)
Offline
Junior
Iscritto: 08/09/2017
Messaggi: 11

Perfetto ragazzi, vi ringrazio per le risposte, il problema è proprio quello di far avviare chrome all'avvio, in debian 9 con xfce non c'è alcun file .xsession solo un .xsession-error, c'è un altro file che ha xsession nel nome, potrebbe essere quello??
quindi non devo usare http://guide.debianizzati.org/index.php/Gestione_e_creazione_di_servizi_in_Debian questo link per avviare il browser

Ritratto di maudit
maudit
(Junior)
Offline
Junior
Iscritto: 08/09/2017
Messaggi: 11

Rettifico ragazzi!!!
Ci sono riuscito!
Dovevo creare il file .xsession ho aggiunto la riga per avviare chrome scritta qualche post sopra e funge.
Ora sto compilando e configurando un softphone e voglio far avviare anche questo all'avvio. Vi tengo aggiornati sugli sviluppi!!