alsa-volumeicon non si avvia automaticamente al login

23 risposte [Ultimo contenuto]
Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

e da terminale?

Ritratto di Robert Lang
Robert Lang
(Junior)
Offline
Junior
Iscritto: 06/09/2014
Messaggi: 14

Si, da terminale funziona. Infatti a ogni avvio devo eseguire il comando "volumeicon" da "Menu-->Esegui programma". Era questo passaggio che volevo automatizzare.

Notebook:Acer Aspire 5930G; proc.: Intel DualCore T5800 2GHz: RAM:3GB, HDD:250GB Scheda Video:NVidia GeForce 9600M GT TurboCache
Sistema Operativo: Debian Jessie (Xfce 4.10)

Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

Giusto per dirne un'altra...di stupidaggine Smile
hai provato a metterlo in avvio automatico con un ritardo, che so di 3/5 secondi

Ritratto di Robert Lang
Robert Lang
(Junior)
Offline
Junior
Iscritto: 06/09/2014
Messaggi: 14

No, non so nemmeno come si fa. Thinking

Notebook:Acer Aspire 5930G; proc.: Intel DualCore T5800 2GHz: RAM:3GB, HDD:250GB Scheda Video:NVidia GeForce 9600M GT TurboCache
Sistema Operativo: Debian Jessie (Xfce 4.10)

Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

l'ho copiata da una vecchia configurazione di docky (me l'avevano suggerito per non creare un intoppo all'avvio)

Dovrebbe essere:

in comand (in avvio automatico)
bash -c "sleep 3 ; volumeicon"

Ritratto di Robert Lang
Robert Lang
(Junior)
Offline
Junior
Iscritto: 06/09/2014
Messaggi: 14

Niente da fare purtroppo.

Notebook:Acer Aspire 5930G; proc.: Intel DualCore T5800 2GHz: RAM:3GB, HDD:250GB Scheda Video:NVidia GeForce 9600M GT TurboCache
Sistema Operativo: Debian Jessie (Xfce 4.10)

Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

Farei qualche altro tentativo:
1) lanciare volumeicon da terminale, non da esegui programma, da shell, sperando ci lasci qualche indizio.
2) Hai controllato tutte le dipendenze, anche quelle consigliate?
https://packages.debian.org/stable/sound/volumeicon-alsa
3) volumeicon funziona, tanto è che se lo lanci parte. Hai provato a creare un altro avvio automatico, uno qualsiasi, e vedere se parte. Fosse lì il problema.

Ho esaurito le poche idee. Smile

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 411

Ho avuto lo stesso problema sul pc di un amico. Ho risolto andando nei Servizi all'avvio e abilitando alsa al login: Sistema --> Preferenze --> Applicazioni d'avvio ove dovrsti vedere la voce alsa-XXX. Se non ci fosse dovrai inserirla tu usando questo comando /usr/bin/volumeicon. Al prossimo avvo sentirai il suono al login, sempre che tu abbia anche impostato qualche suono da sentire... Wink

Ritratto di Robert Lang
Robert Lang
(Junior)
Offline
Junior
Iscritto: 06/09/2014
Messaggi: 14

andr3a ha scritto:

Farei qualche altro tentativo:
1) lanciare volumeicon da terminale, non da esegui programma, da shell, sperando ci lasci qualche indizio.
2) Hai controllato tutte le dipendenze, anche quelle consigliate?
https://packages.debian.org/stable/sound/volumeicon-alsa
3) volumeicon funziona, tanto è che se lo lanci parte. Hai provato a creare un altro avvio automatico, uno qualsiasi, e vedere se parte. Fosse lì il problema.

Ho esaurito le poche idee. Smile

1) lanciandolo da terminale viene eseguito normalmente senza errori;
2)le dipendenze sono tutte soddisfatte;
3)gli altri servizi in avvio automatico (es. psensor) funzionano senza problemi.
Grazie mille per i consigli e per l'aiuto; ulteriori consigli sono sempre ben accetti. Smile

fareyes ha scritto:

Ho avuto lo stesso problema sul pc di un amico. Ho risolto andando nei Servizi all'avvio e abilitando alsa al login: Sistema --> Preferenze --> Applicazioni d'avvio ove dovrsti vedere la voce alsa-XXX. Se non ci fosse dovrai inserirla tu usando questo comando /usr/bin/volumeicon. Al prossimo avvo sentirai il suono al login, sempre che tu abbia anche impostato qualche suono da sentire... Wink

é proprio questo il mio problema, nonostante l'abbia settato in Avvio automatico, non si avvia al primo login; lo fa solo se esco dalla sessione e poi rientro. Grazie comunque per l'aiuto. Smile

Notebook:Acer Aspire 5930G; proc.: Intel DualCore T5800 2GHz: RAM:3GB, HDD:250GB Scheda Video:NVidia GeForce 9600M GT TurboCache
Sistema Operativo: Debian Jessie (Xfce 4.10)

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 411

Permessi/privilegi all'utente o ad alsa (Sistema-->Amministrazione-->Utenti e gruppi usa dispositivi audio) hai provato a vedere anche quelli? Installa anche alsa-utils. (Io sto usando MATE per cui non so se per caso ci sia uno gnome-volumeicon-alsa apposito, perché per MATE c'è).
Aggiunto dopo:
se ti può essere utile ecco il mio volumeicon.desktop che si trova in /home/mioutente/.config/autostart

[Desktop Entry]
Type=Application
Exec=/usr/bin/volumeicon
Hidden=false
X-MATE-Autostart-enabled=true
Name[it_IT]=volumeicon
Name=Avvio volume ALSA
Comment[it_IT]=avvia l'icona del volume nella tray
Comment=avvia l'icona del volume nella tray

Devi preparare un file vuoto con dentro lo scritto sopra inserito. Quando salvi gli dai solo il nome del file volumeicon perché l'estensione .desktop la mette lui. Poi lo sposti in /home/utente/.config/autostart e fai reboot del pc