Wireless e WPA non riesco a connettermi...

10 risposte [Ultimo contenuto]
Ritratto di pepo80
pepo80
(Junior)
Offline
Junior
Iscritto: 22/10/2007
Messaggi: 18

Salve a tutti...

utilizzo una distribuzione basata su Debian Etch (Elive, nativa con e17), dopo una settimana di ricerche sono riuscito a configurare la mia scheda wireless Broadcom 1390 mini-wlan ed a trovare un programma grafico che mi permettesse di fare la connessione (avrei scelto wicd ma ho provato anche wifi-wiz ed avevo gli stessi problemi)

Il mio sistema vede la scheda di rete grazie a ndiswrapper, tramite wicd trovo la mia rete wifi, ho configurato il WPA in wicd, uso ip statici, ma quando premo CONNETTI la rete non viene collegata. Premetto che gli ip sono esatti, e la chiave wpa anche.

Mi trovo un po spaesato perchè a questo punto proprio non so nemmeno dove potrebbe stare il problema... (ndiswrapper e wpa-sulliant sono stati aggiornati all'ultima versone stabile)

Non ho installato ne Gnome ne Kde, (il portatile è un po vissuto...) quindi non posso installare network-manager basati su questi d.e. ...

Grazie a tutti e Saluti.

Ritratto di neural_iso
neural_iso
(Newbie)
Offline
Newbie
Iscritto: 21/10/2007
Messaggi: 4

ciao
prima prova iwconfig SchedaX mode managed poi
prova+ semplicemente da linea di comando
iwconfig eth0 essid Nome_essid channel Canale enc passwd

poi dhclient schedaX in teoria dovrebbe andare o se non hai il dhcp attivo con ifconfig metti l'ip
ifconfig schedaX ip.ip.ip.ip up

route add default gw ip-gateway

Ritratto di pepo80
pepo80
(Junior)
Offline
Junior
Iscritto: 22/10/2007
Messaggi: 18

Ciao,

ti ringrazio della risposta, pechè già questami tira un po su il morale.

Ho tentato la strada proposta ma quando scrivo:

<br />iwconfig wlan0 essid &quot;nome-rete&quot; channel 11 enc tutta-la-chiave<br />

ottengo un errore del tipo: "...enc invalid argument ..."

mi sono letto il man di iwconfig e mi è sembrato di capire che se vuoi inserire la chiave devi usare per default i valori esadecimali... io ho un alice adsl e la chiave è in formato ascii , sul man di iwconfig dice di usare il prefisso s: ... ho provato a mettere esp s:tutta-la-chiave oppure esp s:"tutta-la-chiave" ma ottengo sempre l'errore

<br />Error for wireless request &quot;set encode&quot; (8B2A)<br />SET failed on device wlan0: Invalid argument<br />

ho anche provato a sostituire enc con key, ma ho lo stesso errore... bè cmq adesso posso cercare qualcosa di nuovo su internet !!! Laughing se hai qualche suggerimento sono in ascolto...

Grazie e Ciao

Ritratto di paolo
paolo
(Webmaster)
Offline
Webmaster
Iscritto: 04/10/2004
Messaggi: 1277

Il Wpa da terminale è un po rognoso, ti consiglio di installare Network-manager, ti semplificherà la vità non poco e le configurazioni delle reti cripate è molto veloce.

Ricordati però di abilitare da Gnome (usi Gnome?) le schede in modalità Roaming per far si che vengano gestite da Network-manager.

Un apt-get install network-manager dovrebbe installarti tutto quello che serve, magari si tira giu anche le dipendenze come wpa-supplicant.

Facci sapere

Paolo Mainardi
CTO Twinbit http://www.twinbit.it
Vice Presidente -- ILDN - Italian Linux DIstro Network

Ritratto di pepo80
pepo80
(Junior)
Offline
Junior
Iscritto: 22/10/2007
Messaggi: 18

Quote:

paolo ha scritto:
Ricordati però di abilitare da Gnome (usi Gnome?) le schede in modalità Roaming per far si che vengano gestite da Network-manager.

il problema sta proprio qui: uso e17... il pc non è abbastanza carozzato da tenermi su distribuzioni gnome ... ho provato con buoni risultati Xcfe, ma quello che gira in assoluto meglio &egrave; e17... (la distro sarebbe Elive)

Graficamente ho provato wifi-wiz (creato da uno del team elive) e wicd scritto in phyton... entrambi rilevano l'essid della rete, entrambi mi chiedono la chiave WPA, entrambi configurati con ip statici, entrambi NON si connettono...
Mi pare inoltre di aver capito che il WPA è in qualche modo agganciato ai driver usati per la scheda??? (quando da entrambi i programmi indichi la sicurezza WPA chiede che tipo di driver usare... io ho messo ndiswrapper, il demone che uso per far funzionare la scheda...)

Mi sto perdendo di nuovo... Grazie ancora delle risposte. Saluti.

Ritratto di Mark2
Mark2
(Junior)
Offline
Junior
Iscritto: 22/04/2005
Messaggi: 24

Quote:

(quando da entrambi i programmi indichi la sicurezza WPA chiede che tipo di driver usare... io ho messo ndiswrapper, il demone che uso per far funzionare la scheda...)

Se non sbaglio con gli ultimi wpasupplicant di debian per usare i driver ndiswrapper devi usare wext.

L'howto di mamma debian dice:

Quote:

Ndiswrapper NO LONGER SUPPORTS the 'ndiswrapper' driver backend as of version
1.16. Therefore, 'wext' must be used unless you use an antiquated ndiswrapper
release.

.
Fonte: http://svn.debian.org/wsvn/pkg-wpa/wpasupplicant/trunk/debian/README.modes?op=file&rev=0&sc=0

oppure se hai installato il package wpasupplicant (ma come sappiamo i docs compresi nei package non li legge nessuno Wink )

zcat /usr/share/doc/wpasupplicant/README.modes.gz

Ciao
Marco

Ritratto di pepo80
pepo80
(Junior)
Offline
Junior
Iscritto: 22/10/2007
Messaggi: 18

TOMBOLA !!!

Risolto: erano proprio i driver associati al WPA

Da WICD: Preferenze --> driver WPA --> Wext

Su wifi-wiz li avevo provati tutti, qui invece ammetto che mi ero fermato a quello che mi pareva più ovvio... non ho considerato la legge di Murpy Smile

Ringrazio tutti e chiudo il topic.
Saluti.

Ritratto di fortAlamo
fortAlamo
(Junior)
Offline
Junior
Iscritto: 04/07/2005
Messaggi: 23

Quote:

pepo80 ha scritto:
Da WICD: Preferenze --> driver WPA --> Wext

ho una broadcom BCM4318 , installata e configurata con bcm43xx-fwcutter

Riesco a connettermi alla wireless ( anche con wpa ) usando nm-applet, ma *devo* ogni volta dargli la pass a manina perche' nn la recupera da /etc/wpa_supplicant.conf

inoltre nn riesco connettermi qndo la mia rete e' in modalita' ssid "nascosto", mentre in feisty usando network manager si.

e' giusto cosi' o ho sbagliato qlcosa?

wicd invece "mantiene" la pass in memoria?
lo trovo in qlche repos o devo prenderlo da
http://downloads.sourceforge.net/wicd/wicd_1.3.1-all.deb

ps: e' una mia impressione o e' possibile che con ubuntu/feisty la stessa scheda wifi, installata e configurata sempre con bcm43xx-fwcutter sia piu' "performante" ?
con lenny iwlist scan mi da meno reti rispetto a feisty
a volte nn vedo nemmeno la mia!

Sidux, & Debian Lenny su V3510; kde4;
Arch & BT su AcerAspireOne

Ritratto di pepo80
pepo80
(Junior)
Offline
Junior
Iscritto: 22/10/2007
Messaggi: 18

Si, tiene in memoria le key ( o password).

Tiene in memoria le configurazioni di ogni singola rete (ip statici o dhcp, tipo di crittografia, chiave ...). Sinceramente è ben fatto graficamente e funzionalmente (scritto in phyton).

Sul sito che hai postato trovi l'installatore in formato .deb, oppure una guida che spiega come abilitarlo nei repository per chi ha ubuntu e derivate...

Prima utilizzavo Sabayon, con KDE e network-manager. Tra i due non ho notato differenze nel segnale... io ho una sola rete wifi in casa ed i miei vicini sembrano non usare il wireless...

Ritratto di fortAlamo
fortAlamo
(Junior)
Offline
Junior
Iscritto: 04/07/2005
Messaggi: 23

graze.
ho provato wicd, ma settando tutti i parametri nn riesco ad cmq ottenere un ip valido

rimane "un bel po'" in ricerca e poi ritorna alla fase iniziale ( quella che visualizza"tutte" le reti )

ho qndi rimesso network-manager , che - a parte l'arterio sulle pass Laughing - mi funziona egregiamente.

posso evitare di mettere a manina la chiave wpa?

Sidux, & Debian Lenny su V3510; kde4;
Arch & BT su AcerAspireOne

Ritratto di fortAlamo
fortAlamo
(Junior)
Offline
Junior
Iscritto: 04/07/2005
Messaggi: 23

ho "risolto" (o meglio aggirato il problema) utilizzando knetworkmanager

Sidux, & Debian Lenny su V3510; kde4;
Arch & BT su AcerAspireOne