wifi

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2059

Per piacere quando posti l'output di comandi usa il tag code e, magari é solo una mia impressione, mi sa che ti perdi parte dell'output, l'ultimo post non sembra completo.
Se l'output dei messaggi o comandi che riporti non é chiaramente leggibile o incompleto é difficile provare ad aiutarti.
Mi sembra di capire che vada sempre in timeout, confermi ?

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

ciao Badroot,ti posto quello che mi appare con iwlist scan:

root@debian:/home/marco# iwlist scan
lo        Interface doesn't support scanning.
 
wlan0     Scan completed :
          Cell 01 - Address: 64:D1:A3:11:3C:E2
                    Channel:10
                    Frequency:2.457 GHz (Channel 10)
                    Quality=60/70  Signal level=-50 dBm  
                    Encryption key:on
                    ESSID:"Sitecom113CE2"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000000f10d6142
                    Extra: Last beacon: 68ms ago
                    IE: Unknown: 000D53697465636F6D313133434532
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 03010A
                    IE: Unknown: 32040C183060
                    IE: Unknown: 33082001020304050607
                    IE: Unknown: 33082105060708090A0B
                    IE: Unknown: 0504020A0000
                    IE: Unknown: DD270050F204104A000100104400010210470010BC329E001DD811B2860164D1A3113CE2103C000101
                    IE: Unknown: 2A0104
                    IE: Unknown: 2D1AEE1117FFFF0000010000000000000000000000000C0000000000
                    IE: Unknown: 3D160A070600000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 0B0502000C127A
                    IE: Unknown: DD07000C4304000000
 
eth0      Interface doesn't support scanning.

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

Con dmesg ti posto il risultato dopo aver provato a connettermi:

se̐0008001̎HIDMou] on usb-0001:10:1b.0-1/input0
[  261.892828] usb 1-2: new high-speed USB device number 3 using ehci-pci
[  262.026632] usb 1-2: New USB device found, idVendor=0df6, idProduct=0077
[  262.026649] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  262.026656] usb 1-2: Product: 802.11n WLAN Adapter
[  262.026662] usb 1-2: Manufacturer: Realtek
[  262.026668] usb 1-2: SerialNumber: 00e04c000001
[  263.503300] rtl8192cu: Chip version 0x11
[  263.580687] rtl8192cu: MAC address: 64:d1:a3:31:8f:b9
[  263.580712] rtl8192cu: Board Type 0
[  263.582219] rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
[  263.582334] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
[  263.584342] usbcore: registered new interface driver rtl8192cu
[  263.635371] usb 1-2: firmware: direct-loading firmware rtlwifi/rtl8192cufw_TMSC.bin
[  263.781659] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[  263.793747] rtlwifi: wireless switch is on
[  264.224486] rtl8192cu: MAC auto ON okay!
[  264.269840] rtl8192cu: Tx queue select: 0x05
[  264.699129] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1017.108087] usb 1-2: USB disconnect, device number 3
[ 1017.112198] rtl_usb: reg 0x102, usbctrl_vendorreq TimeOut! status:0xffffffed value=0x62010000
[ 1017.112227] rtl_usb: reg 0x422, usbctrl_vendorreq TimeOut! status:0xffffffed value=0x81380000
[ 1017.112240] rtl_usb: reg 0x542, usbctrl_vendorreq TimeOut! status:0xffffffed value=0x40070800
[ 1017.112301] rtl_usb: reg 0x102, usbctrl_vendorreq TimeOut! status:0xffffffed value=0x40070808
[ 1021.373039] usb 1-2: new high-speed USB device number 4 using ehci-pci
[ 1021.506629] usb 1-2: New USB device found, idVendor=0df6, idProduct=0077
[ 1021.506646] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1021.506653] usb 1-2: Product: 802.11n WLAN Adapter
[ 1021.506658] usb 1-2: Manufacturer: Realtek
[ 1021.506664] usb 1-2: SerialNumber: 00e04c000001
[ 1021.517698] rtl8192cu: Chip version 0x11
[ 1021.600750] rtl8192cu: MAC address: 64:d1:a3:31:8f:b9
[ 1021.600777] rtl8192cu: Board Type 0
[ 1021.601992] rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
[ 1021.602113] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
[ 1021.611697] usb 1-2: firmware: direct-loading firmware rtlwifi/rtl8192cufw_TMSC.bin
[ 1021.612314] ieee80211 phy1: Selected rate control algorithm 'rtl_rc'
[ 1021.618893] rtlwifi: wireless switch is on
[ 1023.070535] rtl8192cu: MAC auto ON okay!
[ 1023.113028] rtl8192cu: Tx queue select: 0x05
[ 1023.498425] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1197.002901] rtl8192cu: MAC auto ON okay!
[ 1197.036411] rtl8192cu: Tx queue select: 0x05
[ 1197.410897] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1198.242479] wlan0: authenticate with 64:d1:a3:11:3c:e2
[ 1198.280416] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 1/3)
[ 1198.481240] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 2/3)
[ 1198.684894] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 3/3)
[ 1198.889045] wlan0: authentication with 64:d1:a3:11:3c:e2 timed out
[ 1199.866270] wlan0: authenticate with 64:d1:a3:11:3c:e2
[ 1199.921952] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 1/3)
[ 1200.124930] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 2/3)
[ 1200.329160] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 3/3)
[ 1200.533011] wlan0: authentication with 64:d1:a3:11:3c:e2 timed out
[ 1201.975363] wlan0: authenticate with 64:d1:a3:11:3c:e2
[ 1202.018900] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 1/3)
[ 1202.220842] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 2/3)
[ 1202.424881] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 3/3)
[ 1202.628877] wlan0: authentication with 64:d1:a3:11:3c:e2 timed out
[ 1204.516465] wlan0: authenticate with 64:d1:a3:11:3c:e2
[ 1204.545114] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 1/3)
[ 1204.751156] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 2/3)
[ 1204.952891] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 3/3)
[ 1205.156860] wlan0: authentication with 64:d1:a3:11:3c:e2 timed out
[ 1216.858410] wlan0: authenticate with 64:d1:a3:11:3c:e2
[ 1216.901501] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 1/3)
[ 1217.104908] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 2/3)
[ 1217.308898] wlan0: direct probe to 64:d1:a3:11:3c:e2 (try 3/3)
[ 1217.513211] wlan0: authentication with 64:d1:a3:11:3c:e2 timed out
root@debian:/home/marco# 

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

Ringrazio tutti in special modo Badroot per la pazienza che mi ha dimostrato e per tutto quello che ho imparato di nuovo.
Debian e' senza dubbio un bel sistema e tutti create una bella organizzazione.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2059

Ciao,
scusa se non ti ho più risposto prima ma è stata una settimana molto dura.
Se hai tempo e voglia potresti fare un ultimo tentativo, ti riporto i passi da seguire.
Apri un terminale e digita il seguente comando :

sudo /etc/init.d/network-manager stop

così leviamo di mezzo NetworkManager per prima cosa, poi :

wpa_passphrase Sitecom113CE2 wifipassword

ovviamente controlla e metti SSID e password della tua rete wifi.
Avrai un output simile a questo :

network={
	ssid="Sitecom113CE2"
	#psk="wifipassword"
	psk=187266d810d2fc298a39f6003b6519a34733cddb11ee916c99678e84794d0c21
}

Da root crea il file /etc/wpa_supplicant/wpa_supplicant.conf e inserisci queste istruzioni :

ctrl_interface=/run/wpa_supplicant
update_config=1
 
network={
 ssid="Sitecom113CE2"
 scan_ssid=1
 key_mgmt=WPA-PSK
 psk=187266d810d2fc298a39f6003b6519a34733cddb11ee916c99678e84794d0c21
}

Una volta salvato il file esegui questo comando :

sudo wpa_supplicant -Dwext -iwlan0 -dd -c /etc/wpa_supplicant/wpa_supplicant.conf

con l'opzione -dd avrai un sacco di messaggi di debug a video che potrebbero essere utili.
Se tutto va bene dovresti avere tra le ultime righe questo messaggio :

EAPOL authentication completed - result=SUCCESS

a questo punto da un altro terminale puoi dare :

sudo dhclient wlan0
/sbin/ifconfig wlan0

e se tutto è andato per il verso giusto la tua interfaccia wlan0 dovrebbe avere un IP e quindi dovresti poter navigare in rete.
Tutti i dettagli li trovi qui.
Purtroppo come già segnalato anche da pietro sembra che il driver per questa scheda di rete non sia per niente valido e quindi non è detto che ne venga fuori qualcosa.

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

Ciao Badroot,due domande, una volta che sospendo network maneger,la rete ethernet continuera' a funzionare?
la seconda domanda probabilmente un po piu'stupida, i comandi li posso copiare e incollare o li devo digitare,perche' le parentesi graffe sulla mia tastiera non le trovo.............

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2059

piui ha scritto:

Ciao Badroot,due domande, una volta che sospendo network maneger,la rete ethernet continuera' a funzionare?

Beh diciamo che dipende da come viene gestita la eth0, però è molto probabile che sia gestita da network manager e quindi smette di funzionare.

piui ha scritto:

la seconda domanda probabilmente un po piu'stupida, i comandi li posso copiare e incollare o li devo digitare,perche' le parentesi graffe sulla mia tastiera non le trovo.............

Devi per forza digitarli perchè devi indicare il tuo SSID e la tua password, io ho messo solo degli esempi quindi copiarli non serve a nulla.
Le parentesi graffe se non ci sono sulla tastiera dovresti ottenerle così :

SHIFT+FN+ALT+[ = {
SHIFT+FN+ALT+] = }

almeno così è sul mio PowerBook G4.

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

Ciao Badroot,quando richiedo la pskin questo modo

root@debian:/home/marco# wpa passphrase Sitecom113CE2 mia pass
bash: wpa: comando non trovato
mi risponde in questo modo,naturalmente ho volutamente ignorato la password di rete per postarti l'output.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2059

Il comando è :

wpa_passphrase Sitecom113CE2 mia pass

non

wpa passphrase Sitecom113CE2 mia pass

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

sicuramente non ho capito come creare il file/etc/wpa_supplicant/wpa_supplicant.confad ogni modo ti posto quello che ho fatto

root@debian:/home/marco# ctrl_interface=/run/wpa_supplicant
root@debian:/home/marco# update_config=1
root@debian:/home/marco# network={
root@debian:/home/marco# ssid="Sitecom113CE2"
root@debian:/home/marco# key_mgmt=WPA-PSK
root@debian:/home/marco#  psk=c654ab973cf946714431eefa396f55cb6026736dbbcc1e72790f3e4ad05e607d
root@debian:/home/marco# }
bash: errore di sintassi vicino al token non atteso "}"
root@debian:/home/marco#  psk=c654ab973cf946714431eefa396f55cb6026736dbbcc1e72790f3e4ad05e607d}
root@debian:/home/marco# wpa_supplicant -Dwext -iwlan0 -dd -c /etc/wpa_supplicant/wpa_supplicant.conf
wpa_supplicant v2.3
random: Trying to read entropy from /dev/random
Successfully initialized wpa_supplicant
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
Failed to open config file '/etc/wpa_supplicant/wpa_supplicant.conf', error: No such file or directory
Failed to read or parse configuration '/etc/wpa_supplicant/wpa_supplicant.conf'.
Failed to add interface wlan0
: Cancelling scan request
: Cancelling authentication timeout