Wifi non funziona, esiste una soluzione?

31 risposte [Ultimo contenuto]
Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Quindi anche al riavvio l'hostname non è più tornato il "tuo" ?
Non è che adesso è memorizzato in /etc/hostname ?
Purtroppo io questo connman non lo conosco, avevo trovato qui una nota che mi pareva legata al tuo problema, si parla di Arch però.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

dentro il file hostname c'è solo un'unica riga con scritto
computer. Aggiungo le 2 righe che mi hai postato prima?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Assolutamente no!!
Prova a eseguire il comando :

sudo hostname computer
hostname

e vedi cosa ti dice.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

davenz@dhcppc0:~$ sudo hostname computer
[sudo] password for davenz: 
davenz@dhcppc0:~$ hostname
computer
davenz@dhcppc0:~$ 

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Non è che in /var/lib/connman dove hai modificato il file settings ci sono altre directory per le varie interfacce di rete e in ogniuna di esse c'è un file settings che magari ha precedenza su quello modificato per cui devi mettere anche in questi le stesse modifiche ?
Stò tirando a indovinare, ma sono convinto che il problema è nella configurazione di questo programma.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

Te lo faccio sapere domani, ora devo staccare....ciao.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

IN /var/lib/connman/ethernet_5404a6e3db3e_cable/ c'è un'altro file "settings"

[ethernet_5404a6e3db3e_cable]
Name=Wired
AutoConnect=true
Modified=2016-01-15T16:57:56.285233Z
IPv4.method=dhcp
IPv4.DHCP.LastAddress=192.168.16.70
IPv6.method=auto
IPv6.privacy=disabled

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

Il wifi non funziona, ho provato a casa con lo smartphone di mia moglie.
A questo punto forse è meglio rimuovere "connman", magari così si aggiusta anche la questione dell'host.....che ne pensi?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Direi che è una buona idea, esegui :

sudo apt-get purge connman

così te lo levi di torno, poi io di solito uso o NetworkManager oppure direttamente wpa_supplicant, quest'ultimo è a mio avviso più comodo se devi effettivamente capire se ci sono problemi con la rete wireless o meno.
Anche io ho la stessa scheda e devo dire che da quando ho cambiato router va decisamente meglio, con quello precedente c'erano giornate in cui la connessione cadeva in continuazione tanto da dover ricorrere alla rete cablata.
Per quello che vale con l'altro portatile che monta una wireless Intel non ho mai avuto nessun problema nemmeno con il vecchio router.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

Usi NetworkManager con xfce?