Wifi non funziona, esiste una soluzione?

31 risposte [Ultimo contenuto]
Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

Salve a tutti e buon 2016 al forum.

Ho difficoltà ad usare il wifi con Debian8 (Jessie),cosa che invece faccio benissimo da ubuntu (che è in altra partizione), e vorrei capire come risolvere, perchè preferisco usare Jessie, quando posso, visto che è più leggero e veloce.
Il mio è un laptop ASUS, il mio DE è XFCE e la scheda di rete è la Qualcomm Atheros AR9285 Wireless Network Adapter, che sembra non abbia alcun firmware disponibile tra quelli scaricabili.
Durante un tentativo precedente ho installato CONNMAN, perchè credevo bastasse per far riconoscere il wifi, ma al lancio di tale programma da terminale ottengo questo:

root@computer:/home/davenz# connmanctl
connmanctl> 
connmanctl> scan wifi
Error /net/connman/technology/wifi: No carrier

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Ciao,
anche il mio portatile usa quella scheda wifi e con Jessie funziona senza problemi, e non richiede nessun firmware.
Dal tuo post non è chiaro, almeno a me, se i tuoi problemi sono in relazione alla configurazione della rete wireless o di tipo hardware.
Potresti, per iniziare, postare l'output dei seguenti comandi ?

lspci -k|grep -2 Atheros
/usr/sbin/rfkill list

per il comando rfkill installa il relativo pacchetto se non lo hai già.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

davenz@dhcppc0:~$ lspci -k|grep -2 Atheros
	Subsystem: ASUSTeK Computer Inc. Device 104c
	Kernel driver in use: r8169
04:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: Lite-On Communications Inc Device 6623
	Kernel driver in use: ath9k

davenz@dhcppc0:~$ /usr/sbin/rfkill list
0: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
2: asus-wlan: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
3: asus-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
davenz@dhcppc0:~$ 

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Cia,
come si evince dall'output di rfkill la scheda wireless e "bloccata".
Esegui questo comando da root, o con sudo, come preferisci.

/usr/sbin/rfkill unblock all

poi controlla con :

/usr/sbin/rfkill list

che le voci blocked siano a no, a questo puntopuoi usare il tuo gestore di rete per configurare il wireless.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

L'ho fatto e le voci sono tutte "NO".
Non capisco però perchè adesso ogni volta che apro il terminal ho sempre il nome utente seguito da @dhcppc0 e non più @computer come era prima Confused

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Quindi adesso il wifi funziona giusto ?
Per il nome computer presumo che tu abbia da qualche parte impostato che lo ottenga dal DHCP.
Hai per caso modificato il file /etc/dhcp/dhclient.conf ?
Oppure è qualche opzione che hai nel gestore della configurazione di rete che hai usato ? ( wicd, network-manager o altro ).
O forse è qualche opzione sul router ?
Scusa se non sono più preciso ma non mi è mai capitata una cosa del genere.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

Il wifi presumo che funzioni, ma potrò scoprirlo solo stasera quando a casa proverò a collegarmi allo smartphone di mia moglie.
Io non ho modificato alcun file, e l'unico gestore di rete che ho provato ad usare è connam, ma solo come ti ho esposto nei precedenti post.
Questo cambio di "utente" è avvenuto dopo che ho postato e inviato da terminale i tuoi 2 comandi: lspci -k|grep -2 Atheros
/usr/sbin/rfkill list

infatti se rileggi i post lo vedi anche tu che prima ero root@computer:/home/davenz#

Non so se è il caso di preoccuparmi.....

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Da quello che vedo già nel post #2 l'hostname è dhcppc0.
Il comando rfkill sblocca solo l'interfaccia in modo che possa essere usato il wifi o il bluetooth.
Il colpevole credo sia connman, prova a editare il file /etc/connman/main.conf, come root ovviamente, e aggiungi o modifica la seguente riga :

[General]
AllowHostnameUpdates=false

poi riavvia il servizio connman.

sudo /etc/init.d/connmanctl restart

per il riavvio del servizio ho tirato a indovinare, se non funzia, riavvia il PC Big Grin .

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

Da riga di comando apro con mousepad il file main.conf ma è completamente vuoto.
Inserisco le due righe che mi hai postato, ma non mi permette di salvarle perchè per lui è un file o directory inesistente.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Scusa hai ragione, su Debian in file di configurazione sembra essere in /var/lib/connman/settings, ti ho postato ciò che avevo trovato sul wiki di Arch e non ho controllato che fosse uguale anche per Debian.

PS : perchè connman poi ? solo per curiosità, fino ad oggi nemmeno sapevo della sua esistenza.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

il file setting è stato così modificato, ma non è cambiato nulla

[global]
OfflineMode=false
 
[Bluetooth]
Enable=false
Tethering=false
 
[WiFi]
Enable=false
Tethering=false
 
[Wired]
Enable=true
Tethering=false
 
[General]
AllowHostnameUpdates=false

Avevo optato per CONNMAN seguendo una guida che sconsigliava WICD per sconnessioni frequenti.