wifi continua a scollegarsi (ad intervalli casuali)

7 risposte [Ultimo contenuto]
Ritratto di johannesynt
johannesynt
(Junior)
Offline
Junior
Iscritto: 30/04/2014
Messaggi: 8

Ciao a tutti, ho appena installato debian 32 bit 7.5.0, e ho notato che ogni tot minuti il wifi si scollega. spesso mi richiede anche la password (nonostante sia poi giá inserita con i pallini neri, ed é corretta). Su questo stesso pc ho installato (negli ultimi 2 anni) ubuntu 12.04, 12.10. 13.04, mint 16 e non ho mai avuto questo problema. Tutti i sistemi elencati erano a 64bit, ho messo questa partizione debian a 32 bit per delle cose che non sto a spiegare.
Fatto sta che appunto é davvero fastidioso.

Grazie

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2061

Ciao,
onestamente come pensi che qualcuno possa aiutarti se non fornisci un minimo di informazioni ?
Per cominciare :

- scheda wireless usata, marca e modello
- come è configurato il wireless, WEP o WPA, IP dinamico o statico
- programma di gestione, NetworkManager, wicd oppure direttamente da /etc/network/interfaces
- eventuali messaggi che puoi vedere con dmesg nel momento in cui il wifi si scollega

magari con queste informazioni qualcuno potrà aiutarti o quanto meno darti qualche suggerimento.

Ritratto di johannesynt
johannesynt
(Junior)
Offline
Junior
Iscritto: 30/04/2014
Messaggi: 8

Scusate.

Allora per il modello dovrebbe essere questo comando che conoscevo: lspci | egrep -i --color 'wifi|wlan|wireless'

08:00.0 Network controller: Atheros Communications Inc. AR9462 Wireless Network Adapter (rev 01)

Riguardo alla rete é IP statico, chiave WPA2

Il programma di gestione é Network manager

Si é appena sconnesso, ho dato il comando dmesg, e tra tutto quello che viene fuori, quello di interesse penso potrebbe essere questo:

[ 1938.636742] wlan0: deauthenticating from 00:3a:99:48:b0:90 by local choice (reason=3)

Ritratto di apofis
apofis
(Monster)
Offline
Monster
Iscritto: 19/09/2007
Messaggi: 309

Hai un netgear come router?
Molti hanno problemi simili con questi router....

I@ legge Apo-genetica: chini nascia tunnu un ci mora quatratu.
II@ legge Apo-genetica: munnu e munnu un s'incontranu mai, ma cristiani e cristiani sì
III@ legge Apo-genetica: si vidi nu ghiegghiu e nu lupu, ammazza 'u ghiegghiu!

Ritratto di johannesynt
johannesynt
(Junior)
Offline
Junior
Iscritto: 30/04/2014
Messaggi: 8

apofis ha scritto:

Hai un netgear come router?
Molti hanno problemi simili con questi router....

No, ho quello di fastweb, ma mi da lo stesso problema anche con la rete dell'universitá. Mi hanno appena consigliato di provare a mettere wicd come manager

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2061

Io sul mio portatile ho una Atheros AR9285 e a mio modesto avviso non è il massimo come scheda, la velocità di connessione è sempre piuttosto bassa e ogni tanto ho lo stesso problema che segnali tu, si sconnette e si riconnette ..... in certe giornate la cosa rende impossibile l'uso del wireless e devo attaccare il cavo di ethernet per poter navigare.
Purtroppo non sono in grado di affermare che con Windows o altre distro il problema non esista in quanto anche con Debian, io uso Wheezy, non mi sembra che esista una logica e fortunatamente il più delle volte il wireless funziona ed è abbastanza stabile, anche se la velocità di connessione non è mai molto alta.
Io ho aggiunto questi parametri all'avvio del modulo ath9k che gestisce la scheda creando il file /etc/modprobe/ath9k.conf.

options ath9k nohwcrypt=1 blink=1 btcoex_enable=1

Non posso però dirti se e di quanto sia migliorata la situazione.
Per la cronaca il primo dovrebbe disabilitare il supporto hardware alla crittografia e il terzo abilitare la coesistenza con il bluetooth, il secondo dovrebbe servire solo per abilitare il led che visualizza il funzionamento della scheda wireless, sul mio PC non sembra avere effetto in quanto il led è sempre acceso e non lampeggia mai ad indicare l'attività della scheda.
Per rendere attive le modifiche o riavvi o rimuovi e ricarichi il modulo con :

sudo /sbin/modprobe -r ath9k
sudo /sbin/modporbe ath9k

Onestamente non so quanto questo possa aiutarti.

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1091

Io ho una atheros AR9287 e uso network manager.
Hai provato a installare il pacchetto firmware-atheros?
Guarda questa wiki di debian.
Ho inoltre trovato questa discussione che sembra ricalcare il tuo problema.

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di johannesynt
johannesynt
(Junior)
Offline
Junior
Iscritto: 30/04/2014
Messaggi: 8

Vi ringrazio entrambi. Per ora ho messo wicd ma sto usando il cavo perché devo fare delle cose importanti, piú tardi provo se ora il wifi funziona meglio, altrimenti proveró i vostri consigli

EDIT:

sembra che con wicd non ci siano piú problemi. Grazie cmq per l'aiuto

RE-EDIT:

confermo, dopo ulteriori ore di utilizzo, che con wicd non si scollega piú e funziona perfettamente.