wifi

43 risposte [Ultimo contenuto]
Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

root@debian:/home/marco# iwconfig--help
bash: iwconfig--help: command not found
root@debian:/home/marco# iwconfig
lo no wireless extensions.
wlan6 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:off
eth0 no wireless extensions.

sul mio ibook g4 ppc ho installato un adattatore usb wifi sitecom, poi grazie alla collaborazione del forum ho installato i driver realtek ed ora il computer rileva la chiavetta usb ma tento di rilevare la rete e non la trova,poi sempre leggendo sui forum ho trovato qualche cosa ma credo che mi manchi qualcosa per associare il modem router con l'adattatore usb

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2059

Ciao,
perdonami ma non mi è affatto chiaro quello che hai fatto, o provato a fare, per connetterti alla rete wifi.
Qui il wiki ufficiale di Debian dove sono spiegate le varie modalità con le quali puoi connetterti alla tua rete wifi.
Dovrebbe essere tutto più che immediato, salvo eventuali problemi di driver, e quindi di semplice attuazione.
Eventualmente riporta dettagliatamente i passi che hai seguito e gli errori/probemi incontrati in modo che si possa provare a darti una mano.

PS : se usi uno dei classici DE di Debian e quindi NetworkManager la connessione wifi si dovrebbe limitare alla sola indicazione del SSID ( cioè il nome della tua rete wifi ) e delle caratteristiche della stessa ( WEP/WPA ) e relativa password di accesso.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2913

Mi sono permesso di modificare il messaggio originario che non faceva uso dei tag [code].

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

Ciao Badroot,ho inserito il network name(ssid)wpa2 e password il programma cerca la rete poi dopo di un po di attesa mi dice non collegato.
non so se devo inserire il bssid o compilare l'indirizzo ipv4 o ipv6.
Col comando iwconfig (riportato sopra) ESSID e' off,access point non associato,eth0 no wireless extension.
IO purtroppo sono un principiante,l'unica cosa che da queste indicazioni intuisco e'che ci sia qualcosa che non faccia comunicare l'adattatore usb con il modem router, la butto li senza nessuna conoscenza tecnica specifica.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2059

Ciao,
per prima cosa da terminale esegui questo comando :

/sbin/iwlist wlan6 scanning

e vedi se riporta anche la tua rete wireless nell'output, magari postalo, e controlla che sia proprio wlan6 come hai indicato nel primo post.
Altra cosa, come hai provato a connetterti ? con NetworkManager ? in questo caso quando dopo l'attesa ti dice che non è connesso puoi vedere, sempre da terminale, cosa riporta il comando dmesg, le ultime righe dovrebbero riferirsi al tentativo di connessione.
L'indirizzo IPv4 di solito non lo si indica in quanto nel 99,99% dei casi il router ha attivo il DHCP e assegna in automatico un indirizzo IP, per IPv6 lascia pure perdere.

Intanto vediamo se c'è qualche messaggio che può aiutarci a capire dove sta il problema, altrimenti proviamo a usare wpa_supplicant con le opzioni di debug.

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

uso networkmaneger,ilnuovo tentativo e'vlan7, dsmeg mi da una schermata con valori tutti a zero e timeout

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

ho esegito il comando/sbin/iwlist wlan7 scanning risponde no scan result, con wlan6 mi dice interface doesn't support scanning

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1123

Sei sicuro di aver installato correttamente il firmware per la tua chiavetta? Prova a levare la chiavetta, a rimetterla e posta le ultime rige del comando "dmesg" che riguardano l'inserimento della chiavetta.

Col comando "iwlist scan" dovresti almeno vedere le reti wifi in zona, se il comando dà "resource busy" riprovalo fino a quando non cambia qualcosa.

Debian. Be unique.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2059

Scusa piui non metto in dubbio le tue parole però posta l'output dei comandi che esegui perchè dove tu vedi tutti zero magari c'è qualcosa in più che può rivelarsi importante ai fini di una soluzione.
Poi come ha consigliato pietro controlla e posta l'output delle ultime righe di dmesg all'inserimento della chiavetta, è strano che l'interfaccia cambi nome in continuazione.

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

Ciao a tutti, questa sera provo a fare quello che m'indicate e poi le posto, per quanto riguarda l'installazione dei driver potrei aver fatto qualche errore in quanto prima di chiedere aiuto a badroot senza aver attivati i repository non free avevo installato i driver con un download col gestore dei file e poi successivamente l'ho ripetuto con il terminale,cosa ne pensate? Ho fatto un po di casino?

Ritratto di piui
piui
(Junior)
Offline
Junior
Iscritto: 19/04/2015
Messaggi: 35

m