In Server Wifi PCI non connette

12 risposte [Ultimo contenuto]
Ritratto di whitetiger
whitetiger
(Geek)
Offline
Geek
Iscritto: 15/12/2012
Messaggi: 88

Sono diventato scemo tutto sabato e tutta domenica; At Wits End
Prima dii buttare tutto dalla finestra chiedo aiuto qui.

Devo collegare una seconda scheda di rete al server e non avendo una NIC tra le mani sto usando una "vecchia" wifi PCI che sul PC è sempre andata bene.

Ho trovato i driver e li ho scaricati in /usr/local/lib/firmware.
Ho poi seguito le varie guide e sono riuscito ad attivarla tanto che con iwlist scan vedo le varie Wi-fi nei paraggi.

Ho poi inserito in /etc/network/interfaces le seguenti righe
# my wifi device
auto wlan0
iface wlan0 inet static
address 192.168.1.3
netmask 255.255.255.0
gateway 192.168.1.1
network 192.168.1.0
broadcast 192.168.1.255
wireless-essid MY-AP-1
wireless-mode ad-hoc
wpa-ssid MY-AP-1
wpa-psk My Secret Passphrase

Il mio primo problema è che al riavvio del server la scheda non è ancora riconosciuta e devo tirarla su a mano, quindi forse manca ancora qualcosa.
Adesso digito:
modprobe -r p54pci ; modprobe p54pci
ifup wlan0

La seconda cosa è che comunque non si connette e forse anche qui manca qualcosa.
Non vorrei che sia la passphrase che non va digitata nel file di configurazione come ho letto.
Oltre tutto in chiaro senza nessuna protezione? Compresi gli spazi? Mah!

Infine, preso dalla disperazione ho messo il CD e via... piallo tutto e gli faccio generare le configurazioni al momento di installare il server, ma arrivati alla schermata "Rilevare hardware di rete" si blocca tutto.
Nota a margine, in questo punto non c'è modo di bloccare l'installazione senza spegnere brutalmente il server.

Grazie in anticipo per l'aiuto.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Una rete ad-hoc con WPA... Sei sicuro che sia possibile?

Ritratto di whitetiger
whitetiger
(Geek)
Offline
Geek
Iscritto: 15/12/2012
Messaggi: 88

mcortese ha scritto:

Una rete ad-hoc con WPA... Sei sicuro che sia possibile?

Dici che è questo?
Che parametro dovrei mettere?

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Se vuoi una rete ad-hoc (cioè una connessione diretta tra due dispositivi wifi) entrambi devono essere settati in modalità "ad-hoc". Nessun tipo di autenticazione è possibile (WEP, WPA...) e i pacchetti sono cifrati usando una chiave ricavata dal nome della rete.

Se vuoi una rete tradizionale, ci dev'essere un nodo master chiamato Access Point (di solito un router) e una serie di nodi che vi si connettono. L'AP deve avere la scheda wifi in modalità "master" e ha anche il compito di autenticare (ad es. tramite WPA) i vari nodi che cercano di connettersi. Gli altri nodi devono avere la scheda wifi in modalità "managed".

Di solito, se hai un router o un modem ADSL con funzionalità wifi, quello è il tuo AP e tutti i PC che gli vuoi collegare vanno configurati di conseguenza.

Solo se hai due dispositivi che vuoi far dialogare insieme, senza metter su una vera rete multi-nodo (esempio classico: un PC e un tablet), allora li setti per un collegamneto ad-hoc.

Nel tuo caso, visto che il tuo ESSID si chiama "MY-AP-1", deduco che vuoi collegarti ad un AP. Quindi è il paramentro "wireless-mode ad-hoc" che stona.

Ritratto di whitetiger
whitetiger
(Geek)
Offline
Geek
Iscritto: 15/12/2012
Messaggi: 88

Infatti io mi devo collegare all'AP e se il parametro stona, qual'è? "managed" ?
Sul PC non vado a modificare il file interfaces perché faccio tutto dal network manager che sul server non ho installato.
La configurazione l'ho copiata e nei vari esempi era riportato "ad-hoc".

In ogni caso c'è anche il problema che segnalavo inizialmente, e cioè che la scheda non viene attivata in automatica e quindi devo fare ifup wlan0.

=====
Ho cambiato ad-hoc in managed
ho inserito wpa-key-mgmt WPA-PSK
Ho cambiato la passhfrase con la sua conversione in Hex tramite un tools

Nisba!
Iwconfig continua a riportarmi
wlan0 IEEE 802.11bg ESSID:"AP-1"
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Un problema per volta: prima trovare una configurazione che funziona, poi come renderla permanente. Mi sembra di capire che non abbiamo ancora risolto il primo. Sad

La modalità "managed" è quella predefinita, quindi di solito non è necessario specificarla.

Se vuoi usare Network Manager, togli la scheda wifi da /etc/network/interfaces, sennò NM non la gestisce (spiegazione ufficiale).

Inoltre, se il tuo AP lo permette, scegli una connessione DHCP: è più facile scovare i messaggi che si scambiano client e server nel log.

Ritratto di whitetiger
whitetiger
(Geek)
Offline
Geek
Iscritto: 15/12/2012
Messaggi: 88

Scusami, ma secondo me stiamo mettendo troppa carne al fuoco.

Il punto era:
-Come tiro su i driver della scheda al boot, visto che adesso lo devo fare a mano?
-Come l'attivo/connetto all'AP direttamente dalla configurazione?
-Cosa va messo nei file?

Ho comunque tentato anche i tuoi suggerimenti:
Il DHCP è attivo, ma lo uso per i PC.
Per un server preferivo dargli un indirizzo statico e non dover poi giocare con il lease o gli indirizzi riservati.
In ogni caso non lo prende.

Listening on LPF/wlan0/MioMACAddress
Sending on LPF/wlan0/MioMACAddress
Sending on Socket/fallback
Internet Systems Consortium DHCP Client 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/MioMACAddress
Sending on LPF/wlan0/MioMACAddress
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
done.

Anche il NetMan lo volevo evitare; installate le due schede nel server, poi non lo devo più configurare.
In ogni caso anche qui mi si inceppa perché quando lancio
apt-get install wicd
Poi ottengo una fila di errori.

dpkg: errore nell'elaborare wicd-daemon (--configure):
il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1
configured to not write apport reports
dpkg: problemi con le dipendenze impediscono la configurazione di wicd-gtk:
wicd-gtk dipende da wicd-daemon (= 1.7.0+ds1-5+squeeze3), ma:
Il pacchetto wicd-daemon non è ancora configurato.
dpkg: errore nell'elaborare wicd-gtk (--configure):
problemi con le dipendenze - lasciato non configurato
configured to not write apport reports
dpkg: problemi con le dipendenze impediscono la configurazione di wicd:
wicd dipende da wicd-daemon (= 1.7.0+ds1-5+squeeze3), ma:
Il pacchetto wicd-daemon non è ancora configurato.
wicd dipende da wicd-gtk (= 1.7.0+ds1-5+squeeze3) | wicd-curses (= 1.7.0+ds1-5+squeeze3) | wicd-cli (= 1.7.0+ds1-5+squeeze3) | wicd-client, ma:
Il pacchetto wicd-gtk non è ancora configurato.
Il pacchetto wicd-curses non è installato.
Il pacchetto wicd-cli non è installato.
Il pacchetto wicd-client non è installato.
Il pacchetto wicd-gtk che fornisce wicd-client non è ancora configurato.
dpkg: errore nell'elaborare wicd (--configure):
problemi con le dipendenze - lasciato non configurato
configured to not write apport reports
Si sono verificati degli errori nell'elaborazione:
wicd-daemon
wicd-gtk
wicd
E: Sub-process /usr/bin/dpkg returned an error code (1)

Secondo me va configurato wicd-daemon che però non ho capito come fare

Per mia cultura personale sono abituato a capire dove stanno i problemi e cercare di risolverli, quindi ne faccio una questione personale.

Ma quasi quasi prendo la macchina e vado a comprarmi una scheda di rete (ammesso che ce ne siano ancora PCI)

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

whitetiger ha scritto:

Scusami, ma secondo me stiamo mettendo troppa carne al fuoco.

Sono d'accordo. Visto che hai intitolato la discussione «wifi non connette», suggerisco di occuparci della connessione e di aprire altri thread specifici per gli altri problemi: wicd che non si installa, come rendere definitive le impostazioni che funzionano, ecc.

Parlando della connessione, non ho capito se usi Network Manager o ifup/ifdown. Citi il primo, ma poi chiedi informazioni su cosa mettere nei file (quali?): chi usa NM di solito usa la sua interfaccia grafica per configurare il tutto!

Comunque io partirei dalle basi: il driver e il firmware. Perché devi scaricare e ricaricare il modulo a ogni avvio? Il firmware è riconosciuto correttamente? Hai un dmesg e un syslog da spulciare?

Una piccola digressione sul DHCP. Sono d'accordo ad assegnare un IP fisso al server, ma credo che questa assegnazione debba farla il router (che, se ho capito bene, agisce da AP e da server DHCP) ad esempio legando univocamente l'IP al MAC. In questo modo il router è l'unico tenutario della configurazione della tua LAN, compresi DNS etc. Se un giorno dovessi cambiare DNS, o il range di IP, o l'IP stesso del router ecc. dovrai reimpostare solo il router e non le singole macchine con configurazione statica. Al contrario, se hai una LAN mista con alcuni IP statici (preimpostati nella configurazione degli host) e altri dinamici, come garantisci che il router non assegni a qualche PC uno degli IP statici?

Ritratto di whitetiger
whitetiger
(Geek)
Offline
Geek
Iscritto: 15/12/2012
Messaggi: 88

Partiamo dal fondo.
D'accordo con te al 100% e di solito configuro il DHCP per distribuire tutte le info.
ma qui ho soltanto un server e tre PC di servizio, preferivo configurare tutto a mano.
Tanto più che non pensavo di impiegarci una settimana.

Entrando nel merito
I driver non sono automaticamente riconosciuti, tanto è vero che con il CD di installazione di Debian si inceppa il processo (ne ho parlato in precedenza).

Seguendo delle guide, li ho perciò scaricati a mano e per lanciarli devo digitare
modprobe -r p54pci ; modprobe p54pci
ifup wlan0

(L'avevo scritto nel primo messaggio)

Quindi la prima richiesta è: come faccio a lanciarli al boot di Debian?

Poi una volta che la scheda è attiva e che con iwlist scan posso vedere gli Access Point, devo effettuare la connessione.
Come ti ho detto non vorrei usare un Network Manager e quindi vorrei avere la configurazione nei files in modo che la scheda si connetta da sola al momento del lancio del sistema operativo.

(La descrizione degli errori di wicd era perché ho seguito il tuo suggerimento circa l'uso di un N.M., ma come dicevo anche adesso preferisco non usarlo se ne posso fare a meno)

Grazie ancora per la pazienza

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

whitetiger ha scritto:

I driver non sono automaticamente riconosciuti, tanto è vero che con il CD di installazione di Debian si inceppa il processo (ne ho parlato in precedenza).

Seguendo delle guide, li ho perciò scaricati a mano e per lanciarli devo digitare
modprobe -r p54pci ; modprobe p54pci
ifup wlan0

(L'avevo scritto nel primo messaggio)

Credo che tu stia facendo confusione. Il "driver" o "modulo" è un file che si chiama p54pci.ko, è distribuito insieme al kernel e non puoi scaricarlo a mano (al limite potresti compilarlo). Il kernel se lo carica da solo: per averne conferma, usa lsmod.

Quello di cui parli, immagino, è il "firmware". Per ragioni di copyright, Debian non può distribuirlo e dunque lo devi scaricare a mano dal sito della Intersil e salvarlo in /usr/local/lib/firmware obbligatoriamente col nome isl3886pci. Non appena il kernel attiva il modulo p54pci, questo cerca un file con quel nome in quella directory e, se lo trova, lo carica.

Quindi all'avvio succede tutto in automatico.

Nota che il modulo cerca il firmware una sola volta, quando viene attivato dal kernel. Quindi se scarichi e salvi il firmware la prima volta, devi costringere il modulo (che è attualmente in esecuzione senza firmware perché non l'ha trovato all'avvio) a leggerlo. Da qui l'operazione "modprobe -r p54pci; modprobe p54pci" che di fatto lo disattiva e poi riattiva in rapida sequenza. Ai successivi boot non devi più fare nulla.

whitetiger ha scritto:

Quindi la prima richiesta è: come faccio a lanciarli al boot di Debian?

Non dovrebbe essere necessario. I casi in cui il kernel non carica il modulo o il modulo non carica il firmware sono patologici e prima di avventurarci in questo campo minato, preferirei avere conferma che è davvero così esaminando l'output di lsmod e dmesg all'avvio, cercando p54pci nel primo e tracce del caricamento (con successo o fallito) del firmware nel secondo.

whitetiger ha scritto:

Poi una volta che la scheda è attiva e che con iwlist scan posso vedere gli Access Point, devo effettuare la connessione.
Come ti ho detto non vorrei usare un Network Manager e quindi vorrei avere la configurazione nei files in modo che la scheda si connetta da sola al momento del lancio del sistema operativo.

Dopo aver installato wpasupplicant, una configurazione minimale dovrebbe essere:
iface wlan0 inet dhcp
  wpa-ssid MY-AP-1
  wpa-psk password
Se la password contiene spazi, usa le virgolette.

Se vuoi fare a meno del DHCP, sostituisci dhcp con static e aggiungi le varie opzioni address, netmask, ecc. Inoltre assicurati di avere DNS e gateway configurati a dovere (/etc/resolv.conf e simili).

Infine, dovresti tirare su la connessione con "ifup wlan0". Quando lo fai, controlla i log di sistema per vedere cosa succede o se ci sono messaggi di errore.

Ritratto di whitetiger
whitetiger
(Geek)
Offline
Geek
Iscritto: 15/12/2012
Messaggi: 88

Nel primo messaggio avevo detto che avevo seguito una guida e che avevo copiato i driver in firmware.
È vero, è il firmware, ciò non toglie che è quello: isl3886pci
Il problema segnalato, appunto, è che in automatico non tira su una beata cippa!
Tant'è che devo attivarlo con modprobe -r p54pci; modprobe p54pci

Non ho riportato tutti i passaggi, pensavo non servisse farlo.
Questo è ciò che ho fatto
aptitude install wireless-tools
mkdir /usr/local/lib/firmware
wget -O /usr/local/lib/firmware/isl3886pci http://daemonizer.de/prism54/prism54-fw/fw-softmac/2.13.25.0.arm

Anche wpasupplicant è stato installato ed ho dei dubbi che basti inserire la password con le virgolette, cosa che comunque avevo già provato a fare.
Il punto, a questo proposito, è che al solito in Internet si legge di tutto ed il contrario di tutto, ad esempio c'è chi dice che si debba inserire la chiave Hex, cosa che ho comunque inutilmente provato a fare.

Questo è l'output di lsmod (prima di attivare la scheda a mano).
Module Size Used by
...
p54common 20519 1 p54pci
led_class 2433 1 p54common
i6300esb 4247 0
e752x_edac 9393 0
mac80211 137372 2 p54pci,p54common
i2c_i801 7830 0
cfg80211 101496 2 p54common,mac80211
...

p54pci dunque è visibile.

dmesg produce una sbrodolata incredibile, te lo devo copiare tutto?
In ogni caso io vedo
[ 4.808610] p54pci 0000:04:01.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 4.808706] p54pci 0000:04:01.0: firmware: requesting isl3886pci
[ 4.840124] p54pci 0000:04:01.0: Cannot find firmware (isl3886pci)
[ 4.840187] p54pci 0000:04:01.0: firmware: requesting isl3886
[ 4.844491] p54pci 0000:04:01.0: PCI INT A disabled
Non saprei dire se devo cercare qualche altra cosa

Quali log devo controllare?
Comunque, come ho già scritto, ifup wlan0 funziona, tant'è che con lo scan vedo gli AP dei dintorni.
è il collegamento tra scheda ed il mio AP che non funziona.
(Oltre all'avvio automatico della scheda)