Problemi con il server DHCP

4 risposte [Ultimo contenuto]
Ritratto di inishmore
inishmore
(Junior)
Offline
Junior
Iscritto: 23/11/2006
Messaggi: 15

Salve a tutti, ho un problema con il server dhcp che non sto riuscendo a risolvere. Vi allego il mio file di configurazione...magari a me sta sfuggendo qualcosa :)p

# dhcpd.conf
#
# Sample configuration file for ISC dhcpd 3
#
# option definitions common to all supported networks...

option domain-name "iscvalesium.lan";
default-lease-time 36000;
max-lease-time 86400;

# DDNS - aggiornamento dinamico dei file dns

ddns-update-style interim;
ddns-updates on;
ddns-domainname "iscvalesium.lan.";
allow-client-updates;
authoritative;

# chiave per l'aggiornamento dinamico
key DHCP_UPDATER {
algorithm HMAC-MD5.SIG-ALG.REG.INT;
secret NmfU90eVsfpLk2Ht07R2IQ==;
};

zone iscvalesium.lan. {
primary 127.0.0.1;
key DHCP_UPDATER;
}

zone 1.168.192.in-addr.arpa. {
primary 127.0.0.1;
key DHCP_UPDATER;
}
#-------------------------------------------------------------------------------------
# spiegazione delle direttive:
# option netbios-name-servers = server wins, IP del server samba
# option routers = default gateway, IP del server firewall
# option domain-name-servers = server dns, IP del server firewall
#----------------------------------------------------------------------------------------

#--------------------------------------------------------
# Parametri per la mia rete
#--------------------------------------------------------
subnet 192.168.1.0 netmask 255.255.255.0 {
option netbios-name-servers 192.168.1.2;
option netbios-node-type 8;
option routers 192.168.1.1;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
option domain-name-servers 192.168.1.1;
ddns-rev-domainname "1.168.192.in-addr.arpa.";
range dynamic-bootp 192.168.1.31 192.168.1.254;
}

Quindi faccio ripartire il servizio...
/etc/init.d/dhcp3-server restart

e mi dice che il servizio non può essere avviato perchè c'è un errore e di controllare in syslog. Sono andato a controllare...e praticamente mi dice... cattiva associazione subnet mask, che poi si riferisce alla prima riga dopo l'ultimo commento. Francamente ho guardato il file un sacco di volte, ma non mi sembra che ci sia nulla di sbagliato. Ora però stavo pensando una cosa: io stavo configurando il server, ma il PC era staccato dalla rete. Forse è per questo che mi da errore quando provo ad avviare il servizio, perchè, magari, non essendo collegato alla rete non riesce a identificarla. Magari è una cavolata... spero che qualcuno possa aiutarmi.

Grazie anticipatamente Big Grin

Ritratto di ntropia
ntropia
(Collaboratore)
Offline
Collaboratore
Iscritto: 18/09/2004
Messaggi: 946

Non sono pratico, ma a occhio mi viene un'idea: perchè non provi a mettere a capo dopo subnetmask? Non mi piace proprio, scritto così.
Cioè:subnet 192.168.1.0 netmask 255.255.255.0 {
diventa:
subnet 192.168.1.0<br />netmask 255.255.255.0 {

Magari non risolve niente... e magari sì.
Prova e facci sapere.

eNjoy

Chi ha intendimento conti il numero della Bestia, perché è un numero d'uomo; e il suo numero è... rw-rw-rw-

Ritratto di inishmore
inishmore
(Junior)
Offline
Junior
Iscritto: 23/11/2006
Messaggi: 15

Guarda per quant'è strano il problema potrebbe anche funzionare. Cmq questo pomeriggio devo fare un salto in azienda per alcune cose...ne approfitterò per provare sia la tua idea che la mia. Poi vi farò sapere. Per il momento grazie mille

Wink

Ritratto di inishmore
inishmore
(Junior)
Offline
Junior
Iscritto: 23/11/2006
Messaggi: 15

Allora ragazzi, scusate il ritardo, ma in questi giorni non ho avuto nemeno due secondi liberi... cmq ci sbagliavamo entrambi sulla natura del problema. Sono andato a controllare direttamente sul manuale e la sintassi era corretta, e la mia idea centrava poco o niente. Cmq dopo due giorni di mangiamento di testa, e innumerevoli prove son riuscito a risolvere il problema: non ci crederete, ma un semplice spazio bianco dopo la prima linea di definizione dei parametri di rete, che poi sarebbe questa

subnet 192.168.1.0 netmask 255.255.255.0 {

era la causa di tutti i problemi. Francamente ancora non me lo spiego, ma l'importante è aver risolto. Grazie ancora per il tempestivo sostegno e alla prossima

Laughing Wink

Ritratto di ntropia
ntropia
(Collaboratore)
Offline
Collaboratore
Iscritto: 18/09/2004
Messaggi: 946

Non ricordo dove, ma mi era già successa una cosa del genere. Sono contento che abbia risolto, e che abbia apprezzato il sostegno!

eNjoy

Chi ha intendimento conti il numero della Bestia, perché è un numero d'uomo; e il suo numero è... rw-rw-rw-