Problemi col Wi-Fi

7 risposte [Ultimo contenuto]
Ritratto di Leone Tassinari
Leone Tassinari
(Junior)
Offline
Junior
Iscritto: 20/04/2017
Messaggi: 35

Salve a tutti.
Il mio pc si scollega dal wi-fi anche se il segnale è forte e chiaro. L'icona del wi-fi rimane illuminata e indica che sono collegato, anche se in realtà non riesco a navigare. Per risolvere il bug per ora mi sono limitato a spegnere e riaccendere il wi-fi ogni volta che si presenta il problema. Un'altra cosa strana è che quando spengo il wi-fi tramite il comando "Turn off" dell'interfaccia grafica, il comando viene eseguito solo dopo una trentina di secondi.
Penso che il problema sia del driver wi-fi della macchina. In passato ho già avuto problemi di driver non compatibili, perché il computer è abbastanza recente.

Ecco le specifiche della mia macchina (i driver della scheda grafica in realtà non sono quelli, ma non credo che importi):

System:    Host: leonovo Kernel: 4.9.0-3-amd64 x86_64 (64 bit)
           Desktop: Gnome 3.22.3 Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: laptop System: LENOVO product: 80TR v: Lenovo ideapad 110-15AST
           Mobo: LENOVO model: Nano 5B1 v: SDK0J40700WIN
           UEFI: LENOVO v: 3UCN15WW date: 08/24/2016
Battery    BAT0: charge: 24.8 Wh 99.8% condition: 24.8/23.8 Wh (105%)
CPU:       Dual core AMD A9-9400 RADEON R5 5 COMPUTE CORES 2C+3G (-MCP-) cache: 2048 KB 
           clock speeds: max: 2400 MHz 1: 2000 MHz 2: 2000 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 98e4
           Display Server: X.Org 1.19.2 drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Gallium 0.4 on AMD STONEY (DRM 3.8.0 / 4.9.0-3-amd64, LLVM 3.9.1)
           GLX Version: 3.0 Mesa 13.0.6
Audio:     Card-1 Advanced Micro Devices [AMD] Device 157a
           driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Device 15b3
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.0-3-amd64
Network:   Card-1: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
           driver: rtl8821ae
           IF: wlan0 state: up mac: 78:45:61:eb:9a:c1
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           IF: eth0 state: down mac: c8:5b:76:72:9a:ad
Drives:    HDD Total Size: 1000.2GB (4.1% used)
           ID-1: /dev/sda model: WDC_WD10JPCX size: 1000.2GB
Partition: ID-1: / size: 92G used: 20G (23%) fs: ext4 dev: /dev/sda8
           ID-2: /home size: 313G used: 12G (4%) fs: ext4 dev: /dev/sda10
           ID-3: swap-1 size: 7.94GB used: 0.00GB (0%) fs: swap dev: /dev/sda9
Sensors:   System Temperatures: cpu: No active sensors found. Have you configured your sensors yet? mobo: N/A gpu: 0.0
Info:      Processes: 183 Uptime: 17:11 Memory: 1146.4/7371.7MB
           Client: Shell (bash) inxi: 2.3.5 

Ritratto di Leone Tassinari
Leone Tassinari
(Junior)
Offline
Junior
Iscritto: 20/04/2017
Messaggi: 35

Cambiando distribuzione (da Debian 8 "Jessie" a Debian 9 "Stretch") il problema sembra essersi risolto. In compenso adesso è Firefox a fare le bizze Rolling Eyes

Ritratto di Leone Tassinari
Leone Tassinari
(Junior)
Offline
Junior
Iscritto: 20/04/2017
Messaggi: 35

Mi ero solo illuso che funzionasse di nuovo. Il problema è ancora lo stesso. Per ora sto usando un piccolo script in bash per aggirare il problema.

#!/bin/bash
 
while true;
do
echo "Controllo la connessione..."
x=`ping -c1 google.com 2>&1 | grep unknown`
if [ ! "$x" = "" ]; then
echo "Sei scollegato! Riavvio network-manager..."
service network-manager restart
fi
sleep 5s
done

Credo che finché non aggiorneranno i pacchetti realtek dovrò tenermelo così. A voi vengono idee migliori?

Ritratto di Leone Tassinari
Leone Tassinari
(Junior)
Offline
Junior
Iscritto: 20/04/2017
Messaggi: 35

Qualcuno sa interpretare questi messaggi che ho trovato in /var/log/daemon.log?

Jun 26 16:16:24 leonovo wpa_supplicant[605]: wlan0: CTRL-EVENT-DISCONNECTED bssid=98:fc:11:e4:8a:46 reason=4 locally_generated=1
Jun 26 16:16:24 leonovo wpa_supplicant[605]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
Jun 26 16:16:39 leonovo dbus[480]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
Jun 26 16:16:39 leonovo systemd[1]: Starting Network Manager Script Dispatcher Service...
Jun 26 16:16:39 leonovo dbus[480]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jun 26 16:16:39 leonovo systemd[1]: Started Network Manager Script Dispatcher Service.
Jun 26 16:16:39 leonovo nm-dispatcher: req:1 'connectivity-change': new request (1 scripts)
Jun 26 16:16:39 leonovo nm-dispatcher: req:1 'connectivity-change': start running ordered scripts...
Jun 26 16:16:40 leonovo nm-dispatcher: req:2 'down' [wlan0]: new request (1 scripts)
Jun 26 16:16:40 leonovo nm-dispatcher: req:2 'down' [wlan0]: start running ordered scripts...
Jun 26 16:16:40 leonovo avahi-daemon[494]: Withdrawing address record for fe80::7a45:61ff:feeb:9ac1 on wlan0.
Jun 26 16:16:40 leonovo avahi-daemon[494]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::7a45:61ff:feeb:9ac1.
Jun 26 16:16:40 leonovo avahi-daemon[494]: Interface wlan0.IPv6 no longer relevant for mDNS.
Jun 26 16:16:40 leonovo avahi-daemon[494]: Withdrawing address record for 192.168.0.120 on wlan0.
Jun 26 16:16:40 leonovo avahi-daemon[494]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.0.120.
Jun 26 16:16:40 leonovo avahi-daemon[494]: Interface wlan0.IPv4 no longer relevant for mDNS.
Jun 26 16:16:40 leonovo wpa_supplicant[605]: wlan0: Reject scan trigger since one is already pending

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1094

Hai dato un'occhiata qui? https://wiki.debian.org/rtl819x

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Ciao,
potresti provare con qualche opzione del driver :

echo "options rtl8821ae ips=0" | sudo tee /etc/modprobe.d/rtl8821ae.conf
sudo modprobe -rv rtl8821ae
sudo modprobe -v rtl8821ae

questa dovrebbe disabilitare il powersave sulla scheda, prova a vedere se cambia qualcosa e magari anche in combinazione con altri flag, quelli disponibili li vedi con :

/sbin/modinfo rtl8821ae

Ritratto di Leone Tassinari
Leone Tassinari
(Junior)
Offline
Junior
Iscritto: 20/04/2017
Messaggi: 35

@Claudio
Ho guardato il link e ho il driver giusto, almeno credo.

@badroot
Ho disabilitato il powersave e sembra andare per ora. Negli scorsi giorni ho fatto la stessa cosa, però con un comando diverso
sudo iw wlan0 set power_save off
e non è cambiato nulla. Non so bene quale sia la differenza.
In più ho dato un'occhiata a /sbin/modinfo e sembra corrotto. Ci sono un sacco di caratteri come ^@ o ^C tutti in fila evidenziati in azzurro.

Ritratto di Leone Tassinari
Leone Tassinari
(Junior)
Offline
Junior
Iscritto: 20/04/2017
Messaggi: 35

Ok, tutto era andato bene fino ad ora. Tra ieri e oggi ho visitato praticamente solo pagine di tldp.org, che sono molto leggere. Poi 5 minuti fa ho provato a gaurdare un video su youtube ed il wi-fi si è scollegato. Non so se questo possa essere un indizio utile.