Problema localizzazione Iceweasel

12 risposte [Ultimo contenuto]
Ritratto di Groucho
Groucho
(Junior)
Offline
Junior
Iscritto: 21/07/2011
Messaggi: 8

Salve a tutti, ho un problema riguardo alla lingua italiana su Iceweasel. Premetto che uso Debian Squeeze (6.0.2) da neanche un mese (sono un utente Linux Mint) e ho aggiornato Iceweasel alla versione 5 tramite il repo squeeze-backports iceweasel release. Quando vado ad installare il pacchetto 'iceweasel-l10n-it', Synaptic mi riporta quest'errore:

Come potrei risolvere?

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Direi che devi semplicemente installare anche il pacchetto iceweasel-l10n-it dai repository squeeze-backports, a quel punto tutto sara' consistente.

Ciao,
Marco

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di Groucho
Groucho
(Junior)
Offline
Junior
Iscritto: 21/07/2011
Messaggi: 8

Ehm è esattamente quello che ho fatto...

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Quali repository hai attivi? Quali pacchetti stai aggiornando quando ti compare l'errore? Puoi provare a duplicare l'errore usando aptitude o apt-get invece che uno strumento grafico, cosicché puoi riportare l'intero output del comando?

Ritratto di Groucho
Groucho
(Junior)
Offline
Junior
Iscritto: 21/07/2011
Messaggi: 8

Allora, i repository attivi sono: per il Debian Software 'main' e 'contrib', per Software di terze parti 'squeeze-updates main' e 'mozilla.debian.net/ squeeze-backports iceweasel-release'.
L'output del terminale è questo:

Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 iceweasel-l10n-it : Dipende: iceweasel (<= 3.5.99) ma la versione 5.0-3~bpo60+1 sta per essere installata
E: Pacchetti danneggiati<code>

Ritratto di mandian
mandian
(Geek)
Offline
Geek
Iscritto: 16/05/2011
Messaggi: 129

Groucho ha scritto:


I seguenti pacchetti hanno dipendenze non soddisfatte:
iceweasel-l10n-it : Dipende: iceweasel (<= 3.5.99) ma la versione 5.0-3~bpo60+1 sta per essere installata
E: Pacchetti danneggiati

Sembra che tu non abbia disinstallato la precedente versione di iceweasel-l10n-it che, dipendendo da iceweasel 3.5, genera un errore di dipendenza non soddisfatta. prova a disinstallarlo completamente con

apt-get purge iceweasel-l10n-it

e poi a reinstallare iceweasel 5

ciao,
mandian

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Tieni anche conto che la localizzazione in italiano NON è disponibile come backport.

Ritratto di Groucho
Groucho
(Junior)
Offline
Junior
Iscritto: 21/07/2011
Messaggi: 8

Niente, mi dice che il pacchetto non può essere rimosso perchè non è installato! Se non è disponibile come backports dove la prendo?

Ritratto di mandian
mandian
(Geek)
Offline
Geek
Iscritto: 16/05/2011
Messaggi: 129

Non ci avevo fatto caso in precedenza, ma stai usando il repo http://mozilla.debian.net, che (per ora?) non fornisce la localizzazione. Comunque puoi risolvere in almeno due modi:

  1. istalli iceweasel da sid (unstable) con relativa localizzazione (ma valuta attentamente se ti conviene!).
  2. puoi provare ad utilizzare la localizzazione di Firefox istallandola direttamente nel browser. In questo caso probabilmente verranno sostituite le scritte 'Iceweasel' con 'Firefox'.

ciao,
mandian

Ritratto di Groucho
Groucho
(Junior)
Offline
Junior
Iscritto: 21/07/2011
Messaggi: 8

Grande!! Ha funzionato il secondo metodo!
Grazie mille a tutti!

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1102

Scusate, in che cartella va messa la localizzazione it.xpi?
Grazie

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde