Problema con LAN

14 risposte [Ultimo contenuto]
Ritratto di Luc484
Luc484
(Junior)
Offline
Junior
Iscritto: 30/01/2005
Messaggi: 23

Evvai!! Grazie mille. Ora sembra che i due pc facciano il ping finalmente. Ho usato da linea di comando ifconfig. Cercavo ora il file da modificare nella cartella etc/sysconfig/networking/profiles/default/, però da me non esiste tale cartella. Dove si trova? C'è scritto che per rendere permanenti queste impostazioni bisogna modificarlo.
Grazie mille per la guida.

Ritratto di kio341
kio341
(Junior)
Offline
Junior
Iscritto: 20/12/2004
Messaggi: 47

in debian il file è /etc/network/interface come già ti avevo
detto Wink esempio:
Quote:

________________
# The loopback interface
# automatically added when upgrading
auto lo eth0 eth1
iface lo inet loopback

iface eth0 inet static
address 192.168.1.1
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.0

iface eth1 inet static
address 192.168.254.1
netmask 255.255.255.0
network 192.168.254.0
broadcast 192.168.254.255
_________________

in caso di cambiamenti riavviamo la rete con
#/etc/init.d/networking restart

:idea:

Ritratto di Luc484
Luc484
(Junior)
Offline
Junior
Iscritto: 30/01/2005
Messaggi: 23

Ah, è sempre quello??? Noooooo!!! Quello non mi funziona Smile. A parte il fatto che non capisco il perchè nella tua versione ci sia tutta quella roba impostata, proprio non riesco a farlo funzionare. Cioè, se ho un file così:

# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback

cioè mai modificato, funziona l'adsl ma non la rete.
Poi do il comando di prima e funziona anche la rete. Domanda: perchè per fare l'equivalente di questo comando è necessaria tutta quella roba nel file? Perchè devo impostare entrambe le schede se tanto uno già è a posto (quella che si connette al modem)? Se inserisco i soli dati della scheda collegata alla rete non parte nulla. Non sarebbe più semplice a questo punto scrivere nel file rc.local quel comando esatto che funziona? Ci deve essere qualche cosa che non capisco di tutto questo discorso.
Grazie comunque. Ora spero di potermi arrangiare, in caso vorrà dire che ad ogni avvio darò questo comando.
Scusa se ti ho fatto scrivere tutti questi messaggi. Evidentemente sono un pò tardo Smile.
Ciao.

Ritratto di Luc484
Luc484
(Junior)
Offline
Junior
Iscritto: 30/01/2005
Messaggi: 23

Uso la stessa configurazione che usavo con fedora. Il pc con debian deve avere ip 192.168.0.1. Il fatto è che ora non è impostato perchè non so come impostarlo. Come dicevo non mi voglio più arrischiare con quel etherconf perchè altrimenti mi parte l'adsl.
Grazie.