Problema con LAN

14 risposte [Ultimo contenuto]
Ritratto di Luc484
Luc484
(Junior)
Offline
Junior
Iscritto: 30/01/2005
Messaggi: 23

Salve a tutti. Nella mia nuova installazione di Debian, oltre ad altri problemi, mi sono ritrovato anche questo. Non riesco ad utilizzare la LAN. I pc in LAN non vengono proprio pingati. La cosa strana è che invece l'ADSL sull'altra scheda di rete invece è andata subito. Ho letto della documentazione online ed ho utilizzare etherconf per configurare tutto, ma non ha combinato nulla ed anzi non funzionava più nemmeno la ADSL. Poi, durante l'installazione, quando chiede di configurare il dispositivi di rete principale, ho notato questo. Se configuro la scheda della LAN, mi funziona la LAN ma non ADSL, se faccio il contrario viceversa. Ora mi funziona la ADSL, ma non la LAN Smile. Qualcuno mi saprebbe consigliare come comportarmi? Il fatto è che proprio non pinga nemmeno.
Grazie e ciao a tutti.

Ritratto di kingfesen
kingfesen
(Geek)
Offline
Geek
Iscritto: 07/12/2004
Messaggi: 117

innanzi tutto che indirizzi hanno le tue schede di rete? prova ad impostarli manualmente ...

ASCII Ribbon Campaign
against HTML email & vCards
against microsoft attachments

Ritratto di kripsio
kripsio
(Collaboratore)
Offline
Collaboratore
Iscritto: 10/09/2004
Messaggi: 1511

- Posta il file di /etc/network/interfaces,
- Posta l'output di ifconfig
- Dicci come ti connetti all'adsl (modem pppoe, modem che serve l'ip mezzo dhcp, router?)

Ritratto di Luc484
Luc484
(Junior)
Offline
Junior
Iscritto: 30/01/2005
Messaggi: 23

Quote:

kripsio ha scritto:
- Posta il file di /etc/network/interfaces,

# The loopback network interface
auto lo
iface lo inet loopback

Quote:

- Posta l'output di ifconfig

eth0 Link encap:Ethernet HWaddr 00:40:33:53:DC:88
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:181949 errors:0 dropped:0 overruns:0 frame:0
TX packets:98625 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:254891060 (243.0 MiB) TX bytes:7494425 (7.1 MiB)
Interrupt:19 Base address:0xd400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2667227 errors:0 dropped:0 overruns:0 frame:0
TX packets:2667227 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:443422396 (422.8 MiB) TX bytes:443422396 (422.8 MiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:82.50.122.83 P-t-P:192.168.100.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:180297 errors:0 dropped:0 overruns:0 frame:0
TX packets:96974 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:250825403 (239.2 MiB) TX bytes:5261777 (5.0 MiB)

Quote:

- Dicci come ti connetti all'adsl (modem pppoe, modem che serve l'ip mezzo dhcp, router?)

Mi connetto con modem pppoe. La scheda che uso per quel modem è eth0. L'altra è eth1 che si connette al resto della LAN.
Grazie mille.

Ritratto di kripsio
kripsio
(Collaboratore)
Offline
Collaboratore
Iscritto: 10/09/2004
Messaggi: 1511

Quote:

# The loopback network interface
auto lo
iface lo inet loopback

mi sembra un po' pochino.

Quote:

Mi connetto con modem pppoe. La scheda che uso per quel modem è eth0. L'altra è eth1 che si connette al resto della LAN.
Grazie mille.

Non ti serve una seconda scheda di rete. pppoe normalmente tira su interfaccia virtuale che verra' vista come default gateway, ti complichi un po' la vita con due ethernet.

Devi assegnare un ip statico da /etc/network/interface ad eth0 per connetterti alla rete locale. Quando avvii pppoe ti tira su ppp0 che, oltre a fare da default gateway, puoi utilizzare per servire la rete come router.

ciauu Smile

Ritratto di kio341
kio341
(Junior)
Offline
Junior
Iscritto: 20/12/2004
Messaggi: 47

leggiti questo da un mio tutorial :
Quote:

potrei entrare in /etc/network/interfaces e configurare a manina le interfacce ,questo è il file generato dal tool di configurazione
che posso sempre manipolare a piacimento:..
________________
# The loopback interface
# automatically added when upgrading
auto lo eth0 eth1
iface lo inet loopback

iface eth0 inet static
address 192.168.1.1
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.0

iface eth1 inet static
address 192.168.254.1
netmask 255.255.255.0
network 192.168.254.0
broadcast 192.168.254.255
_________________
in caso di cambiamenti riavviamo la rete con
#/etc/init.d/networking restart

nel tuo file di configurazione non c'è traccia di eth1!

Ritratto di Luc484
Luc484
(Junior)
Offline
Junior
Iscritto: 30/01/2005
Messaggi: 23

Prima di tutto grazie a tutti. Direi che ci siamo quasi. Il fatto è che a me serve che eth0 sia pppoe ed è appunto attaccato al modem adsl ethernet. eth1 è collegata alla lan.
Col file che mi hai scritto tu, non funziona. Infatti eth0 è statico, giusto? A me non serve statico.
La situazione che mi sono trovato ora è questa. Se uso questo:

Quote:

auto lo eth1
iface lo inet loopback

iface eth1 inet static
address 192.168.0.1
netmask 255.255.255.0
gateway 192.168.0.1

ottengo che adsl non funziona, mentre la rete pinga. Se al contrario inserisco questo:

Quote:

auto lo eth0
iface lo inet loopback

iface eth1 inet static
address 192.168.0.1
netmask 255.255.255.0
gateway 192.168.0.1

la rete non pinga più, mentre la adsl funziona. Cosa mi manca? Come faccio a far funzionare entrambi (contemporaneamente Laughing?
In caso mi puoi dare l'indirizzo giusto della guida che hai scritto? Non mi riesce di trovarlo. E' su questo sito?
Grazie ancora.

Ritratto di kio341
kio341
(Junior)
Offline
Junior
Iscritto: 20/12/2004
Messaggi: 47

il link è questo
http://www.knoppixitalia.org/modules/wfsection/article.php?articleid=1
tieni presente che il modem ethernet è collegato alla eth1 nella mia configurazione!
:idea:
ps-leggi la versione in calce all'articolo!

Ritratto di kripsio
kripsio
(Collaboratore)
Offline
Collaboratore
Iscritto: 10/09/2004
Messaggi: 1511

Quote:

Il fatto è che a me serve che eth0 sia pppoe

Perche'?
Oltretutto eth0 e' eth0... pppoe ti tira su ppp0... e non credo tu possa farci nulla... oltre al fatto che non ne vedo _nessuna_ utilita' pratica...

perche' quindi eth0 deve essere pppoe?

Ritratto di Luc484
Luc484
(Junior)
Offline
Junior
Iscritto: 30/01/2005
Messaggi: 23

Hihihi, raga....hihihi...sono proprio svarionato Smile
Ho letto di tutto, è tutto il pomeriggio che provo ahahah, ma trovo uno e mi perdo l'altro Smile
Cioè, o mi funziona la rete, oppure adsl. Ho letto tutte le guide, ma non c'è nulla da fare. La configurazione che mi ha dato kio341 presa in pieno non mi funziona, mi dice questo:

debian:~# /etc/init.d/networking start
Setting up IP spoofing protection: rp_filter.
Configuring network interfaces...ifup: interface lo already configured
ifup: interface eth0 already configured
SIOCADDRT: Network is unreachable
Failed to bring up eth1.
done.

leggendo le guide mi pareva di aver capito che fosse sufficiente settare la scheda che si collega alla lan. Il resto è stato configurato con lo script del sistema operativo. Mi sono scritto allora questo:

Quote:

# The loopback network interface
auto lo eth1
iface lo inet loopback

iface eth1 inet static
address 192.168.1.1
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.0

ed in effetti, senza scrivere nulla sulla eth0 la adsl funziona. Ma la rete no. La risposta è questa:

debian:~# /etc/init.d/networking restart
Setting up IP spoofing protection: rp_filter.
Reconfiguring network interfaces...Ignoring unknown interface eth0=eth0.
SIOCADDRT: Network is unreachable
Failed to bring up eth1.
done.

Perchè dice Network is unreachable e poi failed to bring up eth1?
Cosa non va nel file che ho scritto secondo voi?
Grazie ad entrambi per la pazienza.

Luca

Ritratto di kio341
kio341
(Junior)
Offline
Junior
Iscritto: 20/12/2004
Messaggi: 47

leggiti quest'altra mia guida e................forse:
http://www.linuxdesktop.it/modules.php?name=News&file=article&sid=521
il server non è debian ma redhat ma è lo stesso praticamente!
:idea: