plugin 32bit su Squeeze con kernel amd64

5 risposte [Ultimo contenuto]
Ritratto di blackout69
blackout69
(Junior)
Offline
Junior
Iscritto: 21/07/2007
Messaggi: 19

Salve a tutti,

utilizzo Squeeze con kernel amd64,

la scorsa settimana, ho notato, che hanno rimosso il seguente pacchetto:

nspluginwrapper

e di conseguenza non permette più l'installazione di alcuni plugin a 32bit tipo:

flashplayer-mozilla
mozilla-acroread

Non riesco a trovare una soluzione per far funzionare questi plugin

Qualcuno ha lo stesso problema?

Grazie

Ritratto di dariospy
dariospy
(Junior)
Offline
Junior
Iscritto: 18/05/2007
Messaggi: 31

Ciao, io posso darti una mano per quanto riguarda il plugin di flash a 64bit.

Intanto comincio col dirti che c'è una valida alternativa libera a flashplayer che è gnash.

Se invece vuoi macchiare il sistema, puoi usare il plugin proprietario di flash player 10 a 64bit nativo di casa Adobe scaricabile da qui .

Un altro sistema potrebbe essere quello di installare una debian 32 bit incastonata nella tua attuale versione a 64bit in modo da farvi girare lì dentro qualsiasi programma a 32 bit, ma se devi solo far funzionare sti due plugin te lo sconsiglio vivamente!
Una buona guida per l'installazione di questa Debian nella Debian è questa che a me ha funzionato alla perfezione.

Spero di essere stato utile
SaLuTi
Dario

condividi le tue conoscenze www.mytwocent.it
linux-user # 449678

Ritratto di blackout69
blackout69
(Junior)
Offline
Junior
Iscritto: 21/07/2007
Messaggi: 19

Grazie per la risposta,

è vero c'è gnash come sostituto di flash...

Il problema è che non si installa nemmeno acroread e mozilla-acroread.

Non capisco come mai, considerando che circa un mese fa, me li ha fatti installare senza problemi.

Invece adesso se provo ad installare uno dei plugin mi dice che dipende da nspluginwrapper e che non è più disponibile.

Non si tratta solo di flash... ma è per capire se con una distro con kernel amd64 non si può più installare plugin a 32bit.

Per la debian nella debian anche io credo che non ne vale la pena.

Mi chiedo se qualcuno è nella mia stessa condizione... e se ha trovato un modo per installare plugin a 32bit.

Grazie

blackout69

Ritratto di blackout69
blackout69
(Junior)
Offline
Junior
Iscritto: 21/07/2007
Messaggi: 19

Salve,

Posso credere che sono solo io a non riuscire ad installare i plugin a 32bit??

Qualcuno sa dirmi dove sbaglio?

Grazie

blackout69

Ritratto di francofait
francofait
(Geek)
Offline
Geek
Iscritto: 07/09/2004
Messaggi: 176

Per carità , stendiamo pure un velo pietoso su gnash , non ha mai funzionato con nessuna distro neppure in versione 32 bit figuriaqmoci poi per amd64.

Flash player plugins /amd64 sul sito di Adope è sempre deisponibile dall' area sviluppo sotto forma tar.gz binari.:

http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz

Non fai altro che estrarlo dalla tarball e copiarlo nella cartella plugins di Firefox.
Indipendentemente dalla distro in uso

Indipendentemente dalla distro in uso l' installazione del player originale di Adobe va in conflitto con l' eventuale presenza dei pacchetti relativi a gnash che va disistallato.

apt-get -f --purge remove swfdec

francofait@libero.it
Debian-Sid Gentoo Yoper

Ritratto di dariospy
dariospy
(Junior)
Offline
Junior
Iscritto: 18/05/2007
Messaggi: 31

Quote:

francofait ha scritto:
Per carità , stendiamo pure un velo pietoso su gnash , non ha mai funzionato con nessuna distro neppure in versione 32 bit figuriaqmoci poi per amd64.

A me funziona bene sia su ubuntu amd64 9.04, debian Lenny amd64, debian Squeeze amd64.

Quote:

francofait ha scritto:
Flash player plugins /amd64 sul sito di Adope è sempre deisponibile dall' area sviluppo sotto forma tar.gz binari.:

http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz

Avevo già segnalato il plugin di casa adobe

SaLuTi
Dario

condividi le tue conoscenze www.mytwocent.it
linux-user # 449678