NFS e automount

11 risposte [Ultimo contenuto]
Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Continua da "NFS Freeze"

Neanche a leggere le guide ci riesco!!! Sad
Questo e' quello che ho fatto:

<br />cat /etc/auto.master<br /><br />##questi sono originali<br />/var/autofs/misc        /etc/auto.misc<br />/var/autofs/net         /etc/auto.net<br /><br />##questo l'ho aggiunto, ma non funzia<br /><br />/home/fabio/dir_esportata        192.168.1.5:/dir_da_esportare<br />

<br />cat /etc/auto.misc<br /><br />dir_esportata    -fstype=ext3,sync,nodev,nosuid,rw       192.168.1.5:/dir_da_esportare<br />

dopo di che:
<br />#/etc/init.d/autofs restart<br />

e questa e' la risposta:

<br />Sep 21 21:17:06 thenext automount[3619]: cannot open lookup module 192.168.1.5 (/usr/lib/autofs//lookup_192.168.1.5.so: cannot open shared object file: No such file or directory)<br />

Evidentemente manca qualcosa! Thinking
ps.: ho seguito una guida che faceva riferimento a RH7.3.

Ciao
Fabio

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)

Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Quote:

maxer ha scritto:
scusa, ma non è di tipo nfs, e non ext3?

Ho corretto ma non funzia Sad

Hai mica una guida, per caso?
Io ho fatto riferimento a questa:
http://www.tu-chemnitz.de/docs/lindocs/RH73/RH-DOCS/rhl-cg-it-7.3/s1-nfs-mount.html

Ciao
Fabio

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)

Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Quote:

maxer ha scritto:
ho dato una occhiata alla guida...
se metti una riga del tipo...

dir_esportata -rw,soft,intr,rsize=8192,wsize=8192 192.168.1.5:/dir_da_esportare

come indicato nell guida..da errore?

/home/fabio/dir -fstype=nfs,rw,soft,intr,rsize=8192,wsize=8192 192.168.1.5:/dir

Niente Sad

Ho tentato pure:

#touch /etc/auto.dir

/home/fabio/dir -fstype=nfs,rw,soft,intr,rsize=8192,wsize=8192 192.168.1.5:/dir

in auto.master

/home/fabio/dir /etc/auto.dir

Adesso vado a letto, ma domani riprovo!
Ciao
e grazie Smile

Fabio

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)

Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Quote:

maxer ha scritto:
dicevo di togliere fstype...

Ho provato anche questo.
Pero' non capisco:
con mount -l
automount(pid7704) on /home/fabio/dir type autofs (rw,fd=5,pgrp=7704,minproto=2,maxproto=4)

Allora c'e' o non c'e'?
Bye
a domani Smile

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)

Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Non c'e' verso! Thinking
Ho provato in tutte le maniere e tutte le salse!

Appena ho tempo cerco altra documentazione, poi riprovo.

Grazie
Fabio

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)

Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Quote:

Appena ho tempo cerco altra documentazione, poi riprovo.

Grazie
Fabio

Rieccomi qua'!
http://it.tldp.org/HOWTO/Automount.html

Con questa sono riuscito nell'intento...
Così facile e così complicato!

Per chiamare il cdrom o floppy devo digitarlo, tipo:
<br />#ls /auto/floppy<br />
e lui si carica.
Ma per scaricarlo devo sempre fare:
<br />#umount /auto/floppy<br />

naturalmente la stessa procedura eseguita da utente non funzia!
<br />umount: /auto/floppy is not in the fstab (and you are not root)
:hammer:

...ma con
<br />/auto /etc/auto.misc --timeout 5 <br />
.. non dovrebbe smontarsi anche il cdrom dopo 5 secondi?

Ciao
Fabio

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)