network/interfaces ipstatic

13 risposte [Ultimo contenuto]
Ritratto di LarsSalazar
LarsSalazar
(Junior)
Offline
Junior
Iscritto: 13/02/2012
Messaggi: 22

Buon giorno a tutti.

Oggi alle prese con l'ip statico.

Ho seguito alla lettera le istruzioni prese da questo sito. (penso sia attendibile)

Leggendo poi qui problemi analoghi sul problema ho visto che veniva consigliato di modificare allow-hotplug eth0 in auto.

Il file l'ho modificato con mediante nano e d ho scritto le seguenti righe:

Comando chiamato => nano /etc/network/interfaces

File dopo le modifiche

auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet static
address 192.168.10.79
netmask 255.255.255.0
gateway 192.168.10.1
dns-domain indirizzo
dns-nameservers indirizzo

Quando riavvio il servizio ifup mi da failed e con lui tutti gl'altri servizi di rete.

La cosa strana è che su una macchina virtuale ho scritto le stesse cose ma non mi ha dato errore.
Ho ripristinato il file alla versione originale ma l' errore persiste

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Messaggi di errore? Log?

Ritratto di LarsSalazar
LarsSalazar
(Junior)
Offline
Junior
Iscritto: 13/02/2012
Messaggi: 22

Quando riavvio mi da un lunga serie di FAILED durante il caricamento dei servizi di rete ifup, etc. Anche riportando il file in condizione originaria, non cambia nulla gli errori persistono fino a che non si pianta letteralmente tutto e non riesce neanche più ad avviarsi l' S.O.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Non ci capisco più niente. Nel post precedente hai detto «quando riavvio il servizio», adesso mi sembra tu stia parlando di un reboot... Non puoi descrivere per bene quali comandi dai e quali messaggi ricevi?

Ritratto di LarsSalazar
LarsSalazar
(Junior)
Offline
Junior
Iscritto: 13/02/2012
Messaggi: 22

Ciò che ho fatto è stato modificare il network interfaces nel modo descritto nel primo post.

Dopo aver fatto questo ho riavviato la macchina.

Al riavvio ho ottenuto una lunga serie di Failed inerenti al ifup e tutto ciò ad esso connesso.

Ho provato a riportare il file nella sua condizione di origine riavviare ma l' errore continua a persistere.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Fai una cosa per volta:

# ifdown -a
# cat /etc/network/interfaces
# ifup -a
e posta l'output di ogni comando.

Se continui a citare «una serie di Failed» senza riportare i messaggi, dubito che qualcuno ti possa dare una mano.

Ritratto di LarsSalazar
LarsSalazar
(Junior)
Offline
Junior
Iscritto: 13/02/2012
Messaggi: 22

attualmente ho risolto mediante i seguenti script:

#!/bin/bash
ifconfig eth0 192.168.10.79 netmask 255.255.255.0 up
route add default gw 192.168.10.1

Chiamato a sua volta da uno script così composto:

#!/bin/bash
num_para=$#
if [ $num_para -lt  3 ]
then
	echo ""
	echo "Attenzione!!! il numero degli argomenti e' diverso da 4"
	echo ""
	echo "                       -----------------------------------------------------"
	echo "                       | dev  |      IP       |  subnet mask  |     gw     |"
	echo "----------------------------------------------------------------------------"
	echo "es: ./configNetwork.sh  eth0   192.168.1.100   255.255.255.0   192.168.1.1 "
	echo "----------------------------------------------------------------------------"
	echo ""
else
	echo "---------procedo!!!!------>"
	echo "#!/bin/bash" > "./configNetwork.d/"$1".sh"
	echo "ifconfig "$1" "$2" netmask "$3" up" >> "./configNetwork.d/"$1".sh"
	if [ $num_para -eq 4 ]
	then
		echo "route add default gw "$4 >> "./configNetwork.d/"$1".sh"
	fi
	chmod +x "./configNetwork.d/"$1".sh"
fi

il file /etc/network/interfaces l'ho modificato commentando la riga iface eth0 inet dhcp

Non ho potuto fare il controllo da te richiesto poichè ho dovuto reinstallare debian.

Da quel che mi sembra di capire il codice scritto nel primo post è corretto.

Proverò ad installare debian tramite virtualbox e fare nuovamente le modifiche del file sopra citato. Se mi dovesse dare errore riporterò i vari report.

Ritratto di LarsSalazar
LarsSalazar
(Junior)
Offline
Junior
Iscritto: 13/02/2012
Messaggi: 22

Ho modificato nuovamente il file interfaces eseguendo i comandi da te citati ho ottenuto queste risposte:

Dopo la modifica del file interfaces ho eseguito il seguente comando:
/etc/init.d/networking restart

output:

Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces ... (warning).
Reconfiguring network interfaces.../etc/network/interfaces:10: unknown method
ifdown: couldn't read interfaces file "/etc/network/interfaces"
/etc/network/interfaces:10: unknown method
ifup: couldn't read interfaces file "/etc/network/interfaces"
failed.

Comando:
root@mydeb:~# ifdown -a

OutPut
/etc/network/interfaces:10: unknown method
ifdown: couldn't read interfaces file "/etc/network/interfaces"

Comando:

root@mydeb:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet etho static
address 192.168.1.4
netmask 255.255.255.0
gateway 192.168.1.1
dns-domain xxxxxx
dns-nameservers xxxxxx

Comando:
ifdown -a

Output:

/etc/network/interfaces:10: too many parameters for iface line
ifdown: couldn't read interfaces file "/etc/network/interfaces"

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Il file /etc/network/interfaces contiene un errore. Se sia questo il problema non lo so, ma sicuramente niente funzionerà finché non lo metterai a posto:

iface eth0 inet etho static
C'è un eth0 di troppo!

Ritratto di LarsSalazar
LarsSalazar
(Junior)
Offline
Junior
Iscritto: 13/02/2012
Messaggi: 22

Hai ragione, provvedo subito e te ne darò il responso eseguendo nuovamente qui comandi.

effettuato la correzione eliminando l' eth0 di troppo la stringa è ora così composta:

iface eth0 inet static
address xxx.xxx.xxx.xxx
netmask xxx.xxx.xxx.xxx
gateway xxx.xxx.xxx.xxx

(dove le x sono gli indirizzi)

eseguendo il restart del servizio di networking:
Comando:
/etc/init.d/networking restart

ottengo la seguente risposta
Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces ... (Warning)

Se eseguo ifup -a non ottengo nulla
Se eseguo ifdown -a non ottengo nulla

Se eseguo il riavvio della macchina ottengo alla fine del caricamento questo output:
ALERT: exim paniclog /var/exim4/paniclog has non-zero size, mail system possibly broken... failed!

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

... e poi funziona o no? L'IP l'ha preso? Il ping va?