Montaggio cartella remota

14 risposte [Ultimo contenuto]
Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1431

Claudio ha scritto:

Ho corretto il comando impartito, ma il risultato è sempre identico[..]


L'ultimo comando impartito sembra - almeno nelle parti essenziali - correttamente impostato. Per ulteriore verifica puoi utilizzare il comando strace per registrare un log delle chiamate di sistema del comando mount (e tracciare esattamente la chiamata che genera l'errore).

Farei, comunque, una verifica della configurazione del computer Windows che esporta lo share nei cui log di sistema, in particolare, in quelli relativi alla sicurezza, dovresti trovare i dettagli relativi ai tentativi di autenticazione con l'esito avuto.

Ritratto di ntropia
ntropia
(Collaboratore)
Offline
Collaboratore
Iscritto: 18/09/2004
Messaggi: 944

Googolando un po' a proposito dell'errore 13, ho notato che su questo forum suggeriscono una possibile soluzione, specificando il domino della macchina Windows:

SBAGLIATO : mount -t cifs //<MachineName>/<Shared Folder> /mnt/Shared -o username=<username>,password=<password> (error 13)
 
CORRETTO  : mount -t cifs //<MachineName>/<SharedFolder> /mnt/Shared -o username=<DomainName>/<username>,password=<password>

L'utente che suggeriva questa soluzione dice di usare il nome della macchina Windows al posto del DomainName, nel caso in cui il domino non sia stato definito.
Prova anche a specificare l'opzione "--verbose" (prima di ogni opzione "-o") per stampare ulteriori informazioni di debug.

eNjoy

Chi ha intendimento conti il numero della Bestia, perché è un numero d'uomo; e il suo numero è... rw-rw-rw-

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1102

Scusate, non vi ho potuto rispondere più perché sono stato assorbito da cose personali. Inoltre, il pc della cartella remota il questione ha deciso che il suo tempo era arrivato dopo ben 10 anni e mezzo di servizio.
Gli hard disks funzionano ancora per cui preferirei si lasciasse questa discussione aperta poiché potrei ancora avere ancora necessità di riesumarla magari montando gli hard disks in questione da qualche altra parte.
Per ora, grazie di tutto.

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di luther_blissett
luther_blissett
(Junior)
Offline
Junior
Iscritto: 01/02/2012
Messaggi: 7

ciao la sintassi corretta.... almeno per me è:

~ # smbmount //(indirizzo ip)/c$ /(directory di mount)/ -o username=(username),password=(password),uid=500,gid=500

dove c$ è il percorso della directory winzouz.

esistono 10 tipi di persone: quelle che capiscono il codice binario e quelle che non lo capiscono!