Impostare i DNS su Debian 9.0 LXDE

10 risposte [Ultimo contenuto]
Ritratto di Rosssiiii
Rosssiiii
(Geek)
Offline
Geek
Iscritto: 18/01/2017
Messaggi: 101

Ciao Smile da qualche giorno sto cercando di modificare i dns su debian 9.0 ma non ci riesco o non ci riesco in maniera definitiva.

Ero andato a modificare il file in etc/resolv.config ma al riavvio successivo del pc ho dovuto rifarlo nuovamente.

Non so perchè ma non riesco a cambiarli dall'interfaccia grafica, in passato mi ricordo che lo avevo fatto con ubuntu mate 32 bit,il quale forse usava un diverso gestore della rete.

Ora con quello su Debian in questione, non riesco a configurarlo per farlo funzionare.

Ad esempio inserisco i dns di google:
https://i.imgur.com/mCpwXwI.png

ora funziona solo perchè anche oggi giorno ho modificato il file resolv.config, ma prima che lo modificassi usando solo le modifiche nell'interfaccia grafica non riuscivo a navigare.

Magari avrei dovuto riavviare il sistema:)

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2913

Se aveva senso negli anni '70, quando ogni computer aveva una sola connessione, oggi delegare in un file statico una qualsiasi configurazione di rete sembra anacronistico. Invece abbiamo protocolli come DHCP per determinare automaticamente i parametri della connessione del momento e strumenti come Network Manager e Wicd che riscrivono al volo quei file che una volta erano statici. Per questo le modifiche manuali a resolv.conf (non resolv.config) sono perse a ogni connessione e disconnessione.

Quanto al perché la configurazione impostata tramite interfaccia grafica non abbia effetto, non saprei: usando GNOME, non conosco la finestra che mostri. Non è che prende le impostazioni solo alla successiva connessione?

Ritratto di Rosssiiii
Rosssiiii
(Geek)
Offline
Geek
Iscritto: 18/01/2017
Messaggi: 101

mcortese ha scritto:

Se aveva senso negli anni '70, quando ogni computer aveva una sola connessione, oggi delegare in un file statico una qualsiasi configurazione di rete sembra anacronistico. Invece abbiamo protocolli come DHCP per determinare automaticamente i parametri della connessione del momento e strumenti come Network Manager e Wicd che riscrivono al volo quei file che una volta erano statici. Per questo le modifiche manuali a resolv.conf (non resolv.config) sono perse a ogni connessione e disconnessione.

Quanto al perché la configurazione impostata tramite interfaccia grafica non abbia effetto, non saprei: usando GNOME, non conosco la finestra che mostri. Non è che prende le impostazioni solo alla successiva connessione?


Si in effetti ora, giorni dopo che ho riacceso il pc ho trovato le impostazioni DNS attive.

Quindi probabile che una volta inseriti i DNS google nella grafica avrei dovuto disconnettermi e poi riconnettermi o riavviare il pc.

ora funziona cosi:
https://i.imgur.com/oVERZZb.png

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1087

La soluzione che hai adottato può anche essere valida ma resta una soluzione che va bene solo per il DE che hai in uso.
Se vuoi cambiare i DNS in maniera indipendente dal DE devi andare nel file /etc/dhcp/dhclient.conf e decommentare la seguente riga
#prepend domain-name-servers
per renderla, ad esempio, così:
prepend domain-name-servers 208.67.222.222, 208.67.220.220;

EDIT: scusate, non riesco a mettere l'ultima riga nel tag "code". Prego chi di dovere di correggere l'errore e di cancellare questo edit

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di borissa
borissa
(Newbie)
Offline
Newbie
Iscritto: 26/03/2018
Messaggi: 4

sto provando anche io a impostare i DNS tramite dhcpclient.conf.
Ho fatto una prova con OpenDNS e con relativa pagina di test https://welcome.opendns.com, vanamente.

prepend domain-name-servers x.x.x.x y.y.y.y

e anche

supersede domain-name-servers x.x.x.x y.y.y.y

e poi

/etc/init.d/networking restart

Ho anche provato a separare i due indirizzi IP dalla virgola senza risultato

Dov'è l'inghippo?

B.

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1087

Prova a postare il file dhcpclient.conf

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di borissa
borissa
(Newbie)
Offline
Newbie
Iscritto: 26/03/2018
Messaggi: 4

# Configuration file for /sbin/dhclient.
#
# This is a sample configuration file for dhclient. See dhclient.conf's
#	man page for more information about the syntax of this file
#	and a more comprehensive list of the parameters understood by
#	dhclient.
#
# Normally, if the DHCP server provides reasonable information and does
#	not leave anything out (like the domain name, for example), then
#	few changes must be made to this file, if any.
#
 
option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;
 
send host-name = gethostname();
request subnet-mask, broadcast-address, time-offset, routers,
	domain-name, domain-search, host-name,
	dhcp6.name-servers, dhcp6.domain-search, dhcp6.fqdn, dhcp6.sntp-servers,
	netbios-name-servers, netbios-scope, interface-mtu,
	rfc3442-classless-static-routes, ntp-servers;
 
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
#prepend domain-name-servers 127.0.0.1;
#require subnet-mask, domain-name-servers;
#timeout 60;
#retry 60;
#reboot 10;
#select-timeout 5;
#initial-interval 2;
#script "/sbin/dhclient-script";
#media "-link0 -link1 -link2", "link0 link1";
#reject 192.33.137.209;
 
#alias {
#  interface "eth0";
#  fixed-address 192.5.5.213;
#  option subnet-mask 255.255.255.255;
#}
 
#lease {
#  interface "eth0";
#  fixed-address 192.33.137.200;
#  medium "link0 link1";
#  option host-name "andare.swiftmedia.com";
#  option subnet-mask 255.255.255.0;
#  option broadcast-address 192.33.137.255;
#  option routers 192.33.137.250;
#  option domain-name-servers 127.0.0.1;
#  renew 2 2000/1/12 00:00:01;
#  rebind 2 2000/1/12 00:00:01;
#  expire 2 2000/1/12 00:00:01;
#}
supersede domain-name-servers 208.67.222.123 208.67.220.123

Alla riga request ho anche tolto domain-name-server, ma nada....

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1087

Cancella la riga
supersede domain-name-servers 208.67.222.123 208.67.220.123
ma abbi l'accortezza di lasciare una riga vuota dopo la }

Successivamente ti avevo detto di decommentare la riga
#prepend domain-name-servers
per renderla così:
prepend domain-name-servers 208.67.222.222, 208.67.220.220;

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di borissa
borissa
(Newbie)
Offline
Newbie
Iscritto: 26/03/2018
Messaggi: 4

Ciao Claudio, grazie, ho risolto come dicevi te. Non pensavo che la sequenza nel file fosse la discriminante…

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1087

Naturalmente gli indirizzi che ti ho scritto sono quelli che uso io (i generici di opendns). Tu dovresti sostituirli con quelli tuoi.
Ti faccio anche presente che puoi impostare ben più di due dns. Io, ad esempio, ne ho messi quattro.

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di borissa
borissa
(Newbie)
Offline
Newbie
Iscritto: 26/03/2018
Messaggi: 4

perfetto grazie, in realtà avevo appoggiato gli OpenDNS per un test, preferisco OpenNIC Project.

grazie ancora