help meee!!! problema wifi: modprobe: FATAL: Module p80211 not found. Failed to load p80211.ko.

10 risposte [Ultimo contenuto]
Ritratto di Guy92
Guy92
(Geek)
Offline
Geek
Iscritto: 26/02/2014
Messaggi: 93

Ciao a tutti,
ho un problema, quando attivo interfaccia wireless con ifup wlan0 su kernel 4.0.0.0 kali 2.0 ricervo il seguente output:

Successfully initialized wpa_supplicant
modprobe: FATAL: Module p80211 not found.
Failed to load p80211.ko.
run-parts: /etc/network/if-pre-up.d/linux-wlan-ng-pre-up exited with return code 1
Failed to bring up wlan0.

uso una scheda di rete Broadcom Corporation BCM43142 802.11b/g/n
la mia configurazione è:
auto wlan0
iface wlan0 inet dhcp
pre-up wpa_supplicant -iwlan0 -c /etc/wpa_supplicant.conf -B

il file di wpa subblicant è impostato nel seguente modo:

network={
 ssid="alicedlink"
 psk=fsdgafg34q524rgre5t5464564wrgw456245yqgaergqe5465fsd
 key_mgmt=WPA-PSK
 proto=WPA
 pairwise=CCMP TKIP
 }

potete aiutarmi perfavore?
lo stesso messaggio lo ricevo con gli adattatori usb wifi, se avete bisogno di altra informazione o di qualche log potete dirmi come trovare unicamente i log che riferiscono a questo problema grazie mille.
spero possiate aiutarmi, buona giornata a tutti!!!

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1106

prova a seguire queste istruzioni
https://wiki.debian.org/wl

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di Guy92
Guy92
(Geek)
Offline
Geek
Iscritto: 26/02/2014
Messaggi: 93

claudio ti rigrazio per il veloce aiuto, ma i driver sono già stati istallati proprio nella maniera da te indicata.
Infatti con il network-manager nessun problema, ma con la configurazione manuale invece si.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Ciao,
qui sembra che trattino un problema simile al tuo, prova a darci un'occhiata.

Ritratto di Guy92
Guy92
(Geek)
Offline
Geek
Iscritto: 26/02/2014
Messaggi: 93

soluzione già seguita badroot niente non funziona, non ho nemmeno i suoi stessi moduli a quello che vedo:

#lsmod
 
Module                  Size  Used by
binfmt_misc            20480  1 
nfnetlink_queue        24576  0 
nfnetlink_log          20480  0 
nfnetlink              16384  2 nfnetlink_log,nfnetlink_queue
xfrm_user              36864  2 
xfrm4_tunnel           16384  0 
tunnel4                16384  1 xfrm4_tunnel
ipcomp                 16384  0 
xfrm_ipcomp            16384  1 ipcomp
esp4                   20480  0 
pci_stub               16384  1 
ah4                    20480  0 
vboxpci                24576  0 
af_key                 36864  0 
xfrm_algo              16384  5 ah4,esp4,af_key,xfrm_user,xfrm_ipcomp
vboxnetadp             28672  0 
vboxnetflt             28672  0 
vboxdrv               385024  3 vboxnetadp,vboxnetflt,vboxpci
zram                   24576  4 
lz4_compress           16384  1 zram
rtsx_usb_ms            20480  0 
memstick               16384  1 rtsx_usb_ms
uvcvideo               86016  0 
btusb                  40960  0 
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_core         40960  1 uvcvideo
v4l2_common            16384  1 videobuf2_core
bluetooth             425984  2 btusb
videodev              131072  3 uvcvideo,v4l2_common,videobuf2_core
media                  20480  2 uvcvideo,videodev
wl                   6303744  0 
dell_led               16384  1 
joydev                 20480  0 
snd_hda_codec_realtek    69632  1 
snd_hda_codec_generic    65536  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     53248  1 
dell_wmi               16384  0 
sparse_keymap          16384  1 dell_wmi
iTCO_wdt               16384  0 
iTCO_vendor_support    16384  1 iTCO_wdt
hid_rmi                20480  0 
x86_pkg_temp_thermal    16384  0 
intel_powerclamp       20480  0 
pcspkr                 16384  0 
snd_hda_intel          28672  10 
dell_laptop            16384  0 
dcdbas                 16384  1 dell_laptop
intel_rapl             20480  0 
i8k                    16384  0 
iosf_mbi               16384  1 intel_rapl
kvm_intel             151552  0 
kvm                   425984  1 kvm_intel
evdev                  24576  16 
serio_raw              16384  0 
nouveau              1298432  0 
mxm_wmi                16384  1 nouveau
cfg80211              454656  1 wl
ttm                    77824  1 nouveau
rfkill                 20480  5 cfg80211,bluetooth,dell_laptop
snd_hda_controller     28672  1 snd_hda_intel
snd_hda_codec         110592  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_soc_rt5640         86016  0 
snd_soc_rl6231         16384  1 snd_soc_rt5640
snd_soc_core          147456  1 snd_soc_rt5640
snd_hwdep              16384  1 snd_hda_codec
snd_compress           20480  1 snd_soc_core
snd_pcm                90112  6 snd_soc_rt5640,snd_soc_core,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
mei_me                 20480  0 
i915                 1015808  4 
efi_pstore             16384  1 
efivars                20480  1 efi_pstore
battery                16384  0 
drm_kms_helper        102400  2 i915,nouveau
snd_timer              28672  1 snd_pcm
dw_dmac                16384  0 
dw_dmac_core           24576  1 dw_dmac
drm                   274432  7 ttm,i915,drm_kms_helper,nouveau
snd_soc_sst_acpi       16384  0 
i2c_algo_bit           16384  2 i915,nouveau
tpm_tis                20480  0 
mei                    77824  1 mei_me
i2c_i801               20480  0 
lpc_ich                24576  0 
tpm                    32768  1 tpm_tis
regmap_i2c             16384  1 snd_soc_rt5640
video                  20480  2 i915,nouveau
wmi                    20480  4 dell_led,dell_wmi,mxm_wmi,nouveau
snd                    69632  30 snd_hda_codec_realtek,snd_soc_core,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_compress
ac                     16384  0 
button                 16384  2 i915,nouveau
shpchp                 32768  0 
soundcore              16384  2 snd,snd_hda_codec
processor              28672  0 
i2c_designware_platform    16384  0 
i2c_designware_core    16384  1 i2c_designware_platform
coretemp               16384  0 
fuse                   90112  3 
autofs4                36864  2 
ext4                  499712  5 
crc16                  16384  2 ext4,bluetooth
mbcache                20480  1 ext4
jbd2                   86016  1 ext4
algif_skcipher         20480  0 
af_alg                 16384  1 algif_skcipher
dm_crypt               28672  1 
dm_mod                 94208  18 dm_crypt
rtsx_usb_sdmmc         28672  0 
rtsx_usb               20480  2 rtsx_usb_sdmmc,rtsx_usb_ms
mfd_core               16384  2 lpc_ich,rtsx_usb
sg                     32768  0 
sr_mod                 24576  0 
cdrom                  49152  1 sr_mod
sd_mod                 45056  3 
crct10dif_pclmul       16384  0 
crc32_pclmul           16384  0 
crc32c_intel           24576  0 
ghash_clmulni_intel    16384  0 
ahci                   32768  2 
libahci                28672  1 ahci
libata                180224  2 ahci,libahci
aesni_intel           167936  2 
xhci_pci               16384  0 
ehci_pci               16384  0 
xhci_hcd              155648  1 xhci_pci
ehci_hcd               77824  1 ehci_pci
aes_x86_64             20480  1 aesni_intel
lrw                    16384  1 aesni_intel
gf128mul               16384  1 lrw
glue_helper            16384  1 aesni_intel
ablk_helper            16384  1 aesni_intel
cryptd                 20480  4 ghash_clmulni_intel,aesni_intel,ablk_helper
r8169                  77824  0 
scsi_mod              200704  4 sg,libata,sd_mod,sr_mod
usbcore               200704  7 btusb,uvcvideo,rtsx_usb,ehci_hcd,ehci_pci,xhci_hcd,xhci_pci
mii                    16384  1 r8169
thermal                20480  0 
usb_common             16384  1 usbcore
thermal_sys            32768  5 video,intel_powerclamp,thermal,processor,x86_pkg_temp_thermal
sdhci_acpi             16384  0 
sdhci                  40960  1 sdhci_acpi
i2c_hid                20480  0 
hid                   106496  2 i2c_hid,hid_rmi
mmc_core              110592  3 sdhci,sdhci_acpi,rtsx_usb_sdmmc

invece con #lshw | grep ssb ricevo solo un radomizzazione di scrite usb scsi finche non si spegne restituendomi il nulla, ho cmq provato a mettere nella blacklist il modulo indicato in quella soluzione, ma al riavvio tutto è come prima, stesso errore.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Questo ti suggerisce qualcosa ?

Ritratto di Guy92
Guy92
(Geek)
Offline
Geek
Iscritto: 26/02/2014
Messaggi: 93

grande badroot!!!!! dopo aver eliminato linux-wlan-ng e i relativi paccheti dipendenti ( linux-wlan-ng* linux-wlan-ng-firmware*) finalmente quell'errore maledetto se ne andato, non ho ben capito cosa io abbia eliminato sicermante.
cmq sia sto impazzendo perchè ora ho un altro tipo di errore, sono veramente un pirla. non ne posso più.

Internet Systems Consortium DHCP Client 4.3.1
Copyright 2004-2014 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
 
Listening on LPF/wlan0/9c:ad:97:dd:1a:25
Sending on   LPF/wlan0/9c:ad:97:dd:1a:25
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 19
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

con dhcp statico
ifup wlan0
Successfully initialized wpa_supplicant
RTNETLINK answers: File exists
Failed to bring up wlan0.
se tolgo il pre-up in interfaces e metto semplicemente
wpa-ssid alicedlink
wpa-psk dadeegerghehehtehte

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Scusa ma non ho mica capito molto di quello che hai scritto.
Comunque io in /etc/network/interfaces avevo :

auto wlan0
iface wlan0 inet dhcp
	wpa-conf /etc/wpa_supplicant.conf

dove in /etc/wpa_supplicant.conf c'è :

ctrl_interface=/run/wpa_supplicant
update_config=1
 
network={
	ssid="IlMIoSSID"
	scan_ssid=1
	key_mgmt=WPA-PSK
	psk="1234456778999900"
}

poi :

sudo ifup wlan0

Ovviamente i dati sono solo di esempio.

Ritratto di Guy92
Guy92
(Geek)
Offline
Geek
Iscritto: 26/02/2014
Messaggi: 93

nulla don't work stesso problema, non è che forse devo pulire la cache delle connessioni? il problema che se fosse così non so come si faccia

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2074

Scusa ma a questo punto sorge il dubbio e quindi pongo la domanda.
Se sicuro che la configurazione wireless che hai fatto sia corretta, magari il problema del DHCP è conseguenza del fatto che non vi sia associazione con il router.
Guarda cosa succede eseguendo il comando manualmente.

sudo /sbin/wpa_supplicant -iwlan0 -c /etc/wpa_supplicant.conf -Dwext -dd

Applica le opportune modifiche in modo che rispecchino la tua situazione.

Ritratto di Guy92
Guy92
(Geek)
Offline
Geek
Iscritto: 26/02/2014
Messaggi: 93

ho già provato, ma nulla, Wext non sembra comprendere i miei driver, ho provato sia con -Dwl e -Db43, ma nulla, nella mia rete di casa invece sono riuscito a farla funzionare configurando il file interfaces nel seguente modo:

auto wlan0
iface wlan0 inet dhcp
wpa-ssid NETGEAR-DualBand-N
wpa-psk gsgfdgdfshgtrhytrhtyjtjt

criptando la psk con
wpa_passphrase miobssid miapassword 

a questo punto penso di lasciare questa configurazione, che vantaggi avrei configurando la mia rete con wpa_supplicant.conf rispetto a come è ora??