gestore di rete, questo sconosciuto

4 risposte [Ultimo contenuto]
Ritratto di _natty_
_natty_
(Newbie)
Offline
Newbie
Iscritto: 25/01/2016
Messaggi: 4

Salve,
cercando di impostare un client openvpn sulla mia debian jessie mi sono ritrovato un funzionamento non atteso di cui non ne capisco l'origine.

Provo a descrivere la situazione:

All'accensione del pc la rete funziona.
(eth0 su cavo)
Questo è il contenuto di "interfaces" da me modificato per avere un indirizzo ip statico nella sottorete:

natty@debian:~$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
source /etc/network/interfaces.d/*
# The loopback network interface
#auto eth0
#iface eth0 inet static
auto eth0
        iface eth0 inet static
        address 192.168.1.188
        netmask 255.255.255.0
        gateway 192.168.1.254

e se provo "ifconfig" l'interfaccia ha effettivamente ha quell'ip.

Da interfaccia grafico ho due icone:
-rete
-connessioni di rete

probabilmente è giusto che sia così ma non capisco bene il perchè di due interfaccie praticamente identiche.
inoltre in alto a dex accanto all'orologio non ho nessuna icona che mi segnala la connessione, devo accederci manualmente ricercandola tra i programmi.

Se accedo a "rete" vedo tutte le mie connessioni comprese alcune vecchie vpn che non uso più, non ricordo da dove furono impostate, ma se ora provo ad eliminarle, ad ogni riavvio le ritrovo la!
Ma non vedo la mia connessione ethernet!

Se accedo a "connesioni di rete" vedo come prima tutte le varie vpn ma vedo anche "wired connection 1" che usa la mia eth0 in dhcp.
Se provo a modificare abilitare o disabilitare questa connessione mi sparisce la connettività di rete e sono costretto o a riavviare il pc o a dare comandi come:
[code]sudo dhclient eth0
per rigenerare l'ip, ma questo funziona solo una volta!
Se cmq provo
ifconfig eth0
trovo ancora i miei ip corretti e se eseguo comandi di ping su server noti (tipo dns google) il comando da esito positivo senza sollevare un errore, ma browser e altri strumenti di rete risultano morti...

Quindi, ricapitolando:
che succede?
a chi affidare la gestione della rete?
come elimino le vecchie vpn?
come creo una nuova vpn?
come gestisco una sottorete statica?

spero di non essere stato troppo nebuloso.
grazie

Ritratto di Guy92
Guy92
(Geek)
Offline
Geek
Iscritto: 26/02/2014
Messaggi: 85

che network manager usi?
quale è la tua DE?

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2751

Credo che tu debba decidere se vuoi configurare la rete con gli strumenti grafici (Network Manager, applet, popup...) o quelli testuali (/etc/network/interfaces). Insieme funzionano male.

Ritratto di _natty_
_natty_
(Newbie)
Offline
Newbie
Iscritto: 25/01/2016
Messaggi: 4

salve a tutti,
scusate l'ignoranza, vi seguo sul "devi decidere cosa usare" ma non capisco come....

credo che l'ambiente grafico sia Gnome visto che "echo $DESKTOP_SESSION ----> mi restituisce DEFAULT"

a senso -poco- logico direi che sarebbe auspicabile che da ambiente grafico sia network-manager a gestire le connessioni, ma se ciò complica la vita nn mi spaventa usare interfaces.

come faccio a selezionare solo un "gestore" e fermare o rimuovere gli altri evitando questi conflitti che mi stanno affiggendo.
grazie

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2751

Commenta nel file interfaces le interfacce che vuoi che gestisca NM e riavvia.