flash plugin -- ubuntu --

11 risposte [Ultimo contenuto]
Ritratto di lucaflea
lucaflea
(Junior)
Offline
Junior
Iscritto: 05/07/2005
Messaggi: 32

ciao. vorrei risolvere quanto prima l'annoso problema del plugin flash x firefox/mozilla.

sono riuscito, dopo varie vicissitudini, a trovare una repo dalla quale scaricarlo. lo installo ma....firefox si chiude da solo appena lo lancio. se disinstallo il plugin ritorna tutto bello e funzionante come prima. come fare???

luca :-o

Ritratto di SuperPisu
SuperPisu
(Monster)
Offline
Monster
Iscritto: 06/11/2004
Messaggi: 228

se quei pacchtti ti mandano in crash firefox vuol dire che non vanno

ma nei repository ufficiali non c'è ???

8-) Superpisu 8-)

(10:47:50) chars: mi sposo
(10:48:07) chars: ho trovato l'amore
 
(17:47:09) chars: ai tempi d'oro
(17:47:19) chars: quando ero uno street boy

Ritratto di lucaflea
lucaflea
(Junior)
Offline
Junior
Iscritto: 05/07/2005
Messaggi: 32

c'è ma non me lo lasciava installare...ho cambiato repos e si installa però dà quel prob.
qualcuno mi suggerisce di scaricarlo dal sito di macromedia e installarlo manualmente...
che dici? come si farebbe??

ciao

Ritratto di rekstorm
rekstorm
(Geek)
Offline
Geek
Iscritto: 13/05/2005
Messaggi: 95

ciao... sei con hoary o con warty...

se sei con hoary! leggi la guida che trovi qui http://ubuntuguide.org/#flash-mozilla (anche se forse lo hai già fatto)... in particolare edita /etc/apt/source.list con i repository indicati nella guida.

firefox è tra le cose un po' problematiche in hoary, prima di tutto perchè cè qualche disguido tra la versione compilata per ubuntu e la versione ufficiale... nulla di che... si risolve con un piccolo trick:
dopo aver aggiunto i repository
apt-get update
apt-get upgrade

apri firefox scrivi about :config nella barra degli indirizzi e cerca questa chiave app.version e cambia il valore 1.0 in 1.0.4

a questo punto dovrebbe permetterti di scaricare le estensioni e i temi

per il plugin di flash:
apt-get install flashplayer-mozilla

dovrebbe funzionare (ho installato e risolto tutti i problemini in una notte quindi non mi ricordo bene tutti i passaggi!)

se hai bisogno per il plugin java dimmi che sono qui!
per problemi di questo tipo guarda nella sezione wiki di www.ubuntulinux.com

Spero di esserti stato utile!

ciao
Rekstorm Laughing

Ritratto di lucaflea
lucaflea
(Junior)
Offline
Junior
Iscritto: 05/07/2005
Messaggi: 32

niente da fare.

ho provato con il metodo indicato da rekstorm e anche con quello manuale ma non va niente....

nel caso in cui da synaptic provo a scaricarlo, si installa e firefox si pianta. se invece scarico il plugin quando è il momento di install dice che non è adatto all'architettura del mio sistema...

facendo apt-get install flashplayer-mozilla dice che "E: Impossibile trovare flashplayer-mozilla"

che p...e....

che fare??

Ritratto di rekstorm
rekstorm
(Geek)
Offline
Geek
Iscritto: 13/05/2005
Messaggi: 95

sei con hoary o con warty????

hai aggiunto i repository???

prova a fare apt-get remove firefox e a reinstallarlo! non so che dirti a me funza!

ciao facci sapere!

Rekstorm

Ritratto di submax
submax
(Monster)
Offline
Monster
Iscritto: 21/10/2004
Messaggi: 361

installarlo...... tramite l'utility di firefox.......

go debian! Laughing

Ritratto di lucaflea
lucaflea
(Junior)
Offline
Junior
Iscritto: 05/07/2005
Messaggi: 32

ragazzi niente da fare, ho provato tutte le soluzioni

sono con hoary ma amd64...

ho letto che non ci sono plugin flash x il 64...

e ora??

devo tornare a winzozzo???

no eh?!?!?!?!

Ritratto di rekstorm
rekstorm
(Geek)
Offline
Geek
Iscritto: 13/05/2005
Messaggi: 95

MEA culpa!!!

rettifica del post inviato qualche giorno fa...

allora

aggiungi i repo della guida,
apt-get update
apt-get upgrade qua dovrebbe dirti qualcosa del genere:

[I seguenti pacchetti sono stati mantenuti alla versione attuale:
mozilla-firefox mozilla-firefox-gnome-support
] :-o
apt-get dist-upgrade e qua:
[Sono occorsi degli errori processando:
/var/cache/apt/archives/firefox-gnome-support_1.0.4-1ubuntu3~5.04ubp5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
] Thinking
e allora qua mi sono rotto con ste dipendenze...Laughing
apt-get remove mozilla-firefox mozilla-firefox-gnome-support
qualunque cosa dica:
apt-get -f install Laughing

apri firefox e controlla la versione dal menu [?] deve essere la 1.0.4

ora però non vanno le estensioni!!!
Sad --> https://bugzilla.ubuntu.com/show_bug.cgi?id=10681

in pratica apri firefox: about :config
modifica general.useragent.vendorSub con il valore 1.0.4

l'altro giorno mi ero sbagliato e andando a memoria avevo detto di cambiare il numero a version_qualcosa...

mi scuso e correggo!

ho cercato in giro ed effettivamente su AMD64 non c'è il plugin per firefox... cmq non è un buon motivo per tornare a winzozz, cmq vedi tu!!! ciao... spero di essere stato utile anche ad altri con questo post! ciaoz

Rekstorm :-P

Ritratto di roxhan
roxhan
(Geek)
Offline
Geek
Iscritto: 08/10/2004
Messaggi: 58

Per esperienza personale, io ho sempre avuto problemi con plugin flash installati da apt, mentre mi sono sempre tovato bene scaricando da macromedia l'installer, se decidi di provare questa strada rimuovi prima tutti i pacchetti tipo:

libflash-mozplugin o
flashplayer-mozilla

www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash

ciao

Ritratto di lucaflea
lucaflea
(Junior)
Offline
Junior
Iscritto: 05/07/2005
Messaggi: 32

ma allora ha senso fare tutto questo procedimento se tanto x l'amd64 non c'è il plugin???