dhcp ed eth0 configurazione

2 risposte [Ultimo contenuto]
Ritratto di roxhan
roxhan
(Geek)
Offline
Geek
Iscritto: 08/10/2004
Messaggi: 58

Ok, innanzi tutto un ciao a tutti e poi il problema:
Ho installato dai repos ufficiali il kernel image 2.6.11-1-386,
pero' con questo non riesco a connettermi con dhcp, ora per
mentre tutto era ok col vecchio kernel, ho notato quanto segue

kerne funzionante 2.6.8-2
!durante il boot:
Listening on LPG/eth0/00:c0:9f:37:7a:2f

output di ifconfig
Perseo:~# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:C0:9F:37:7A:2F
inet addr:129.... etc Bcast:129... etc
inet6 etc. etc.
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2685 errors:0 dropped:0 overruns:0 frame:0
TX packets:410 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:465830 (454.9 KiB) TX bytes:62086 (60.6 KiB)
Interrupt:6

Kernel non funzionante
Listening on LPG/eth0/<null>

Perseo:~# ifconfig eth0
eth0 Link encap:UNSPEC HWaddr 00-C0-9F-00-00-18-27-15-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:5 dropped:5 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 Cool TX bytes:0 (0.0 Cool

Io sono molto niubbo pero' mi sembra di capire che nel caso non funzionante alla eth0 viene associato un HWaddr diverso, perche'? E' normale? anche il formato e' diverso,
Spero che possiate aiutarmi ciao
Roxhan

Ritratto di roxhan
roxhan
(Geek)
Offline
Geek
Iscritto: 08/10/2004
Messaggi: 58

Va bene mi rispondo da solo, io non so perche', tuttavia
mentre il kernel vecchio riconosceva la scheda ethernet e
ne caricava il driver tg3.ko, trattasi di una broadcom gigabit etc, il kernel nuovo no, si vede che e' un numero dispari, infatti e' stato impacchettato senza tale modulo, ho risolto scaricando i source via apt-get install bcm5700... e installando il modulo con module-assistant, ora tutto ok, solo una piccola cosa la eth0 e' rimasta quella di prima mentre alla scheda ethernet col corretto hwaddr e' ora associato eth1. L'esperienza da niubbo mi ha insegnato quanto segue:
Mai usare compilatori della unstable, gia tempo fa ho avuto problemi con gcc-4.0 e sono dovuto passare a gcc-3.4 ora per compilare questo modulo ho dovuto usare gcc-3.3 che lasciero' come default!!

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1124

Il problema potrebbe essere che a partire dal kernel 2.6.11 la Debian ha deciso di non inserire il driver tg3 per motivi di licenza.

Dovresti essere comunque in grado di trovare altrove i driver per la Broadcom.

Ciao

Debian. Be unique.