Debian Stretch - Scheda Wireless disabilitata dall'Hardware

10 risposte [Ultimo contenuto]
Ritratto di J0hn3ch2
J0hn3ch2
(Junior)
Offline
Junior
Iscritto: 31/12/2016
Messaggi: 8

Salve a tutti, ho da poco installato Debian Stretch per risolvere dei problemi legati al touchpad e alla modifica della luminosità nel mio notebook avuto con Debian Jessie 8.6. Tuttavia, installando Debian Stretch ho un problema con la scheda wireless, poichè viene rilevata ma non è possibile attivarla. Quando cerco di avviare il Wifi l'errore che GNOME mostra è: "Wi-Fi Hardware Disabled".

Il notebook in questione è un Asus K501UX-DM086T, la scheda wireless è un Qualcomm Atheros AR9462, la scheda a quanto ho capito dovrebbe usare i driver ath9k, lanciando il comando lsmod | grep -i ath9k capisco che viene caricato dal kernel, ma il la scheda wifi non funziona comunque. Cerco consigli su come risolvere il problema.

Grazie in anticipo.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2069

Ciao,
prova a installare il pacchetto rfkill e poi dare il comando :

sudo /usr/sbin/rfkill list

dall'output vedrai se sono attivi o meno dei soft/hard block sulla periferica.
Se è un hard block allora credo che dovresti usare un interruttore fisico per accendere o spegnere la scheda, su alcuni pc è così.
Altrimenti se è solo un soft block lo sblocchi con :

sudo /usr/sbin/rfkill unblock 0

ovviamente al posto di 0 devi mettere il numero che appare vicino alla tua scheda, probabilmente sarà 0 ma non è detto.

Visto che usi GNOME prima prova a vedere che non sia impostata su ON la modalità aereo ( rif. ).

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1102

Prova ad installare da repository il pacchetto firmware-atheros

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di J0hn3ch2
J0hn3ch2
(Junior)
Offline
Junior
Iscritto: 31/12/2016
Messaggi: 8

Si tratta di un Hard block, inoltre non ho un interruttore fisico per abilitare il wifi.

Attached images:

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1102

Claudio ha scritto:

Prova ad installare da repository il pacchetto firmware-atheros

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di J0hn3ch2
J0hn3ch2
(Junior)
Offline
Junior
Iscritto: 31/12/2016
Messaggi: 8

Ho provato ed ho riavviato il pc. Purtroppo nessun cambiamento.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2069

La butto lì .... sulla tastiera in altro a sinistra sotto il tasto F2 c'è il simbolo dell'aeroplano ... non è che con Fn+F2 si abilita/disabilità il wireless ?

Ritratto di J0hn3ch2
J0hn3ch2
(Junior)
Offline
Junior
Iscritto: 31/12/2016
Messaggi: 8

Ho acceso il notebook proprio adesso e senza interagire in alcun modo con la scheda wifi ho eseguito il comando rfkill list

Allegato 1: dopo aver lanciato il comando noto che, le etichette:
- 0: phy0: Wireless LAN è
SOFT BLOCK: yes
HARD BLOCK: no

- 1: asus-wlan: Wireless LAN è
SOFT BLOCK yes
HARD BLOCK: no

Dunque ho provato a sbloccarle come mi è stato consigliato con il comando  rfkill unblock [identificativo]

Allegato 2: Entrambe le due opzioni sono SOFT e HARD BLOCK: no

Allegato 3: Tuttavia lanciando dopo circa 3 minuti di nuovo il comando  rfkill list l'etichetta 0: phy0: Wireless LAN è impostata ad HARD BLOCK: yes

Premesso che, la modalità aereo era disattivata sin dall'accensione del notebook

------PROVA CON IL TASTO FN+F2-------------

Allegato 4: Attivo la modalità aereo tramite FN+F2
Risultato: 0: phy0: Wireless LAN e 1: asus-wlan: Wireless LAN tornano ad essere:
SOFT BLOCK: yes
HARD BLOCK: no

Allegato 5: Disattivo la modalità aereo premendo di nuovo FN+F2
Risultato: 0: phy0: Wireless LAN torna ad essere:
SOFT BLOCK: no
HARD BLOCK: yes

1: asus-wlan: Wireless LAN
SOFT BLOCK: no
HARD BLOCK: no

Attached images:

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2069

Sinceramente non sono sicuro di avere capito .... si disattiva il wireless per conto proprio ?
Prova questo settaggio e riavvia :

sudo tee /etc/modprobe.d/asus.conf <<< "options asus_nb_wmi wapf=4"

e vedi se la situazione migliora, dopo il riavvio controlla con rfkill.

Ritratto di J0hn3ch2
J0hn3ch2
(Junior)
Offline
Junior
Iscritto: 31/12/2016
Messaggi: 8

PROBLEMA RISOLTO GRAZIE MILLE @badroot Applause

Potresti spiegarmi, per favore, qual era il problema ?

Il file asus.conf nella directory /etc/modprobe.d non era presente. Anzi, la directory /etc/modprobe.d non conteneva nessun file, ma ora dopo aver lanciato il comando da te inviato è stato creato il file "asus.conf" al cui interno è presente solo la stringa " option asus_nb_wmi wapf=4 "

Grazie ancora per l'aiuto Big Hug

Attached images:

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2069

Bene sono contento che hai risolto.
Il problema con il wifi e con rfkill sembra piuttosto comune su quella serie di modelli Asus, anche con wifi Intel. Da quello che ho trovato spulciando in rete sembra che sia un problema con EFI/UEFI e che forzando quell'opzione lo stato/funzionamento di Fn+F2 risulta coerente tra le impostazioni del BIOS e quanto rilevato dal sistema operativo. Il modulo asus_nb_wmi veniva già caricato in automatico essendo il tuo notebook un Asus ma quell'opzione non era settata, creando quel file, che per comodità abbiamo chiamato asus.conf, contenente quella stringa di istruzioni si dice al kernel di caricare il modulo con l'opzione indicata.